From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 052CF3195EB for ; Mon, 10 Nov 2025 18:28:03 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1762799284; cv=none; b=LUGv0CfgnrMSDyGZONIDYHwAr+XNL9xo6Zyg+2gTbU7iBVq7HacD/xfqw1KZVH3AJay2ebVqr0dOvEd/SIcJhBIIFGK8DrQH8JJHVS6d0C8IPPd050DaDWO5IeI1a7RVBoVSRyl56FDX8O1rMnZMyJp6kG1WKKK0QUEEaAcnq5E= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1762799284; c=relaxed/simple; bh=9Za0s+jRH4S1Z2bulO5fzs+8YHVqt4OhMTO0L/jbjMk=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=pw+FFAFdMVsW1t8/I3nzbeHEMA8EQpiQ99XGjcwehG+3oFpeaLcKXWuKNId8F769QJbCsdyFjqgRJo8EQo2kQbWy2RfTKKCIxBVwif+BmA3BDbLAFz/x8zlwr/B9STVa5jKsP2boHV0ptgEDjydXw81LjkfiBlZslAwIhG4Bvw4= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=Lb8b3mZ0; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="Lb8b3mZ0" Received: by smtp.kernel.org (Postfix) with ESMTPSA id D1C2AC113D0; Mon, 10 Nov 2025 18:28:00 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1762799283; bh=9Za0s+jRH4S1Z2bulO5fzs+8YHVqt4OhMTO0L/jbjMk=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=Lb8b3mZ0SnK/L1P86vnjLalv72ylv0BWzsMxAb3TmQ8ePx/x48jOCMHYWPPtlb3vg z9a2wH0eZprNpxtivM0IEAAgzZNLGTO0np+h+sMlv8A1g1HjBSrdFEvhv/PAEy6j0R Bly+Pqn+iRKpcLGSHqimhrvciigzyyr1ZdMxl4urqDzBdAdj68w4OwfR6EZvDIUQ9e iYDMgfjc+K3/5KLr+wXJLmEJb48d2Jui0NG1Z9ggQkzx+8y2YdoQg7w8MMhpQE7ocw lnjkriSQ+T0ZzKDZQ2Qwc1qhvIDERKl1t43X5XzG6F+CEs2fT6xvXShAqCyqSLbghx a6WfrOCzE8oSQ== Message-ID: <669b8132-3dae-4f0d-a3e0-7c73a50205a8@kernel.org> Date: Mon, 10 Nov 2025 19:27:58 +0100 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v2 1/2] mm: rename walk_page_range_mm() To: Lorenzo Stoakes , Andrew Morton Cc: "Liam R . Howlett" , Vlastimil Babka , Mike Rapoport , Suren Baghdasaryan , Michal Hocko , Jann Horn , linux-mm@kvack.org, linux-kernel@vger.kernel.org References: From: "David Hildenbrand (Red Hat)" Content-Language: en-US In-Reply-To: Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit On 10.11.25 18:22, Lorenzo Stoakes wrote: > Make it clear we're referencing an unsafe variant of this function > explicitly. > > This is laying the foundation for exposing more such functions and > maintaining a consistent naming scheme. > > As a part of this change, rename check_ops_valid() to check_ops_safe() for > consistency. > > Signed-off-by: Lorenzo Stoakes > --- Acked-by: David Hildenbrand (Red Hat) -- Cheers David