mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Bean Huo <beanhuo@iokpp.de>
To: Arthur Simchaev <Arthur.Simchaev@wdc.com>, martin.petersen@oracle.com
Cc: beanhuo@micron.com, linux-scsi@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 4/4] ufs: core: Remove ufshcd_map_desc_id_to_length function
Date: Wed, 23 Nov 2022 18:31:20 +0100	[thread overview]
Message-ID: <67f8930848d9c6b73f225a55920de29623db9bdd.camel@iokpp.de> (raw)
In-Reply-To: <1669045590-26101-5-git-send-email-Arthur.Simchaev@wdc.com>

On Mon, 2022-11-21 at 17:46 +0200, Arthur Simchaev wrote:
............
> -	if (param_offset >= buff_len) {
> -		dev_err(hba->dev, "%s: Invalid offset 0x%x in
> descriptor IDN 0x%x, length 0x%x\n",
> -			__func__, param_offset, desc_id, buff_len);
> -		return -EINVAL;
> -	}
> -
>  	/* Check whether we need temp memory */
>  	if (param_offset != 0 || param_size < buff_len) {
>  		desc_buf = kzalloc(buff_len, GFP_KERNEL);
> @@ -3434,15 +3407,23 @@ int ufshcd_read_desc_param(struct ufs_hba
> *hba,
>  
>  	/* Request for full descriptor */
>  	ret = ufshcd_query_descriptor_retry(hba,
> UPIU_QUERY_OPCODE_READ_DESC,
> -					desc_id, desc_index, 0,
> -					desc_buf, &buff_len);
> -
> +					    desc_id, desc_index, 0,
> +					    desc_buf, &buff_len);
>  	if (ret) {
>  		dev_err(hba->dev, "%s: Failed reading descriptor.
> desc_id %d, desc_index %d, param_offset %d, ret %d\n",
>  			__func__, desc_id, desc_index, param_offset,
> ret);
>  		goto out;
>  	}
>  
> +	/* Update descriptor length */
> +	buff_len = desc_buf[QUERY_DESC_LENGTH_OFFSET];
> +
> +	if (param_offset >= buff_len) {
> +		dev_err(hba->dev, "%s: Invalid offset 0x%x in
> descriptor IDN 0x%x, length 0x%x\n",
> +			__func__, param_offset, desc_id, buff_len);
> +		return -EINVAL;
> +	}
> +

a little bit concerned here, but understood your point that you want to
anyway read descriptor, then check if param_offset is a valid input. I
think, there is no problem. 

All in all, this series is a very nice cleanup, we removed all
unnecessary if-state, and complicated rules, making code more readable
than before.

Reviewed-by: Bean Huo <beanhuo@micron.com>


Thanks,
Bean




      reply	other threads:[~2022-11-23 17:32 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-11-21 15:46 [PATCH v2 0/4] ufs: core: Always read the descriptors with max length Arthur Simchaev
2022-11-21 15:46 ` [PATCH v3 1/4] ufs: core: Remove redundant wb check Arthur Simchaev
2022-11-23 16:43   ` Bean Huo
2022-11-21 15:46 ` [PATCH v3 2/4] ufs: core: Remove redundant desc_size variable from hba Arthur Simchaev
2022-11-23 17:10   ` Bean Huo
2022-11-21 15:46 ` [PATCH v3 3/4] ufs: core: Remove len parameter from ufshcd_set_active_icc_lvl Arthur Simchaev
2022-11-23 17:18   ` Bean Huo
2022-11-21 15:46 ` [PATCH v3 4/4] ufs: core: Remove ufshcd_map_desc_id_to_length function Arthur Simchaev
2022-11-23 17:31   ` Bean Huo [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=67f8930848d9c6b73f225a55920de29623db9bdd.camel@iokpp.de \
    --to=beanhuo@iokpp.de \
    --cc=Arthur.Simchaev@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®