From: Willem de Bruijn <willemdebruijn.kernel@gmail.com>
To: Jon Kohler <jon@nutanix.com>,
Willem de Bruijn <willemdebruijn.kernel@gmail.com>
Cc: "Michael S. Tsirkin" <mst@redhat.com>,
"Jason Wang" <jasowang@redhat.com>,
"Eugenio Pérez" <eperezma@redhat.com>,
"Alexei Starovoitov" <ast@kernel.org>,
"Daniel Borkmann" <daniel@iogearbox.net>,
"David S. Miller" <davem@davemloft.net>,
"Jakub Kicinski" <kuba@kernel.org>,
"Jesper Dangaard Brouer" <hawk@kernel.org>,
"John Fastabend" <john.fastabend@gmail.com>,
"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"virtualization@lists.linux.dev" <virtualization@lists.linux.dev>,
"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"bpf@vger.kernel.org" <bpf@vger.kernel.org>
Subject: Re: [PATCH net-next] vhost/net: align variable names with XDP terminology
Date: Thu, 08 May 2025 09:42:17 -0400 [thread overview]
Message-ID: <681cb4b95dde7_2583cf294d@willemb.c.googlers.com.notmuch> (raw)
In-Reply-To: <C9ADA542-813C-42C4-AF5D-92445EB70A6A@nutanix.com>
Jon Kohler wrote:
>
>
> > On May 7, 2025, at 1:23 PM, Willem de Bruijn <willemdebruijn.kernel@gmail.com> wrote:
> >
> > !-------------------------------------------------------------------|
> > CAUTION: External Email
> >
> > |-------------------------------------------------------------------!
> >
Minor: can you fix email to avoid the above?
> > Jon Kohler wrote:
> >> Refactor variable names in vhost_net_build_xdp to align with XDP
> >> terminology, enhancing code clarity and consistency. Additionally,
> >> reorder variables to follow a reverse Christmas tree structure,
> >> improving code organization and readability.
> >>
> >> This change introduces no functional modifications.
> >>
> >> Signed-off-by: Jon Kohler <jon@nutanix.com>
> >
> > We generally don't do pure refactoring patches.
> >
> > They add churn to code history for little gain (and some
> > overhead and risk).
> >
>
> Ok, I’ll club this together with the larger change I’m working on
> for multi-buffer support in vhost/net, ill send that as a series
> when it is ready for eyes
I forgot to add that it makes stable fixes harder to apply across
LTS, distro and other derived kernels.
So resist the urge the just make stylistic changes. Functional
improvements warrants the risk, churn and extra work.
next prev parent reply other threads:[~2025-05-08 13:42 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-07 16:02 Jon Kohler
2025-05-07 17:23 ` Willem de Bruijn
2025-05-07 17:31 ` Jon Kohler
2025-05-08 13:42 ` Willem de Bruijn [this message]
2025-05-08 13:45 ` Jon Kohler
2025-05-08 12:00 ` kernel test robot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=681cb4b95dde7_2583cf294d@willemb.c.googlers.com.notmuch \
--to=willemdebruijn.kernel@gmail.com \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=daniel@iogearbox.net \
--cc=davem@davemloft.net \
--cc=eperezma@redhat.com \
--cc=hawk@kernel.org \
--cc=jasowang@redhat.com \
--cc=john.fastabend@gmail.com \
--cc=jon@nutanix.com \
--cc=kuba@kernel.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mst@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=virtualization@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®