From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: ACPI Devel Maling List <linux-acpi@vger.kernel.org>
Cc: LKML <linux-kernel@vger.kernel.org>,
Linux PM list <linux-pm@vger.kernel.org>,
Aaron Lu <aaron.lu@intel.com>, Lan Tianyu <tianyu.lan@intel.com>
Subject: [PATCH 0/4] ACPI / PM: Cleanups and device power state selection rework
Date: Fri, 14 Jun 2013 14:29:57 +0200 [thread overview]
Message-ID: <6895318.cKDBc4OdI0@vostro.rjw.lan> (raw)
Hi All,
The following series of patches cleans up the ACPI device PM core code and
reworks the routine used for selecting power states to put devices into.
[1/4] Rename a function whose name is the same as the name of a data type and
make it static.
[2/4] Replace ACPI_STATE_D3 with ACPI_STATE_D3_COLD in device_pm.c.
[3/4] Rework functions used for selecting power states to put devices into.
[4/4] Drop some unused code.
Thanks,
Rafael
--
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
next reply other threads:[~2013-06-14 12:25 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-14 12:29 Rafael J. Wysocki [this message]
2013-06-14 12:31 ` [PATCH 1/4] ACPI / PM: Rename function acpi_device_power_state() and make it static Rafael J. Wysocki
2013-06-14 12:31 ` [PATCH 2/4] ACPI / PM: Replace ACPI_STATE_D3 with ACPI_STATE_D3_COLD in device_pm.c Rafael J. Wysocki
2013-06-14 12:32 ` [PATCH 3/4] ACPI / PM: Rework and clean up acpi_dev_pm_get_state() Rafael J. Wysocki
2013-06-27 8:11 ` Aaron Lu
2013-06-27 12:09 ` Rafael J. Wysocki
2013-06-28 7:53 ` Aaron Lu
2013-06-14 12:33 ` [PATCH 4/4] ACPI / PM: Drop two functions that are not used any more Rafael J. Wysocki
2013-06-18 9:20 ` Aaron Lu
2013-06-18 13:00 ` Rafael J. Wysocki
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6895318.cKDBc4OdI0@vostro.rjw.lan \
--to=rjw@sisk.pl \
--cc=aaron.lu@intel.com \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=tianyu.lan@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®