From: Joe Perches <joe@perches.com>
To: Liam Beguin <liambeguin@gmail.com>,
lars@metafoo.de, Michael.Hennerich@analog.com, jic23@kernel.org,
charles-antoine.couret@essensium.com, Nuno.Sa@analog.com
Cc: linux-kernel@vger.kernel.org, linux-iio@vger.kernel.org,
devicetree@vger.kernel.org, robh+dt@kernel.org
Subject: Re: [PATCH v5 1/5] iio: adc: ad7949: define and use bitfield names
Date: Mon, 09 Aug 2021 13:03:10 -0700 [thread overview]
Message-ID: <6a75b875a01e8697b5a3556d14f3ee9bd72d5050.camel@perches.com> (raw)
In-Reply-To: <CDEHW1G78JUJ.CQG08OEMNYLQ@shaak>
On Sun, 2021-08-08 at 18:46 -0400, Liam Beguin wrote:
> On Sun Aug 8, 2021 at 12:51 PM EDT, Joe Perches wrote:
> > On Sat, 2021-08-07 at 21:56 -0400, Liam Beguin wrote:
> > > Replace raw configuration register values by using FIELD_PREP and
> > > defines to improve readability.
> > []
> > > diff --git a/drivers/iio/adc/ad7949.c b/drivers/iio/adc/ad7949.c
> > []
> > +#define AD7949_CFG_BIT_INCC GENMASK(12, 10)
> >
>
> Hi Joe,
>
> > I think the naming is a bit confusing as it appears as if
> > these bitfield ranges are single bits.
>
> That makes sense.
> Would AD7949_CFG_BITS_* be good enough?
Sure, or add MASK or something else like AD7949_CFG_MASK_INCC.
It's pretty common to define _MASK and _SHIFT for these types
of uses.
For instance:
include/drm/drm_dp_helper.h-# define DP_DSC_MAJOR_MASK (0xf << 0)
include/drm/drm_dp_helper.h-# define DP_DSC_MINOR_MASK (0xf << 4)
include/drm/drm_dp_helper.h:# define DP_DSC_MAJOR_SHIFT 0
include/drm/drm_dp_helper.h:# define DP_DSC_MINOR_SHIFT 4
next prev parent reply other threads:[~2021-08-09 20:03 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-08 1:56 [PATCH v5 0/5] AD7949 Fixes Liam Beguin
2021-08-08 1:56 ` [PATCH v5 1/5] iio: adc: ad7949: define and use bitfield names Liam Beguin
2021-08-08 16:51 ` Joe Perches
2021-08-08 22:46 ` Liam Beguin
2021-08-09 20:03 ` Joe Perches [this message]
2021-08-08 1:56 ` [PATCH v5 2/5] iio: adc: ad7949: fix spi messages on non 14-bit controllers Liam Beguin
2021-08-08 1:56 ` [PATCH v5 3/5] iio: adc: ad7949: add support for internal vref Liam Beguin
2021-08-08 16:36 ` Jonathan Cameron
2021-08-08 22:43 ` Liam Beguin
2021-08-09 19:42 ` Jonathan Cameron
2021-08-13 20:51 ` Liam Beguin
2021-08-16 8:07 ` Andy Shevchenko
2021-08-10 12:15 ` Andy Shevchenko
2021-08-10 19:46 ` Liam Beguin
2021-08-10 19:55 ` Andy Shevchenko
2021-08-10 20:51 ` Liam Beguin
2021-08-08 1:56 ` [PATCH v5 4/5] dt-bindings: iio: adc: ad7949: add per channel reference Liam Beguin
2021-08-08 1:56 ` [PATCH v5 5/5] iio: adc: ad7949: use devm managed functions Liam Beguin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6a75b875a01e8697b5a3556d14f3ee9bd72d5050.camel@perches.com \
--to=joe@perches.com \
--cc=Michael.Hennerich@analog.com \
--cc=Nuno.Sa@analog.com \
--cc=charles-antoine.couret@essensium.com \
--cc=devicetree@vger.kernel.org \
--cc=jic23@kernel.org \
--cc=lars@metafoo.de \
--cc=liambeguin@gmail.com \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®