From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from vps0.lunn.ch (vps0.lunn.ch [156.67.10.101]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 523263FCB16 for ; Mon, 18 May 2026 12:06:45 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=156.67.10.101 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1779106008; cv=none; b=dszpJBLuhyv2RKuDUjX+kbZ3CyIX2Bo1YXSjGZfgCkDRWsffcteRxo7hUzDG6y0nrFe5bodvppR+mxjpsTT6TNotJK9QBy8AF0W59Zcv3NhE7QKBNodLZDDxXXivLy/8xJiVLu+MTIAO00ptMJq9aKOPVW7XjVpUGW218kBweM4= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1779106008; c=relaxed/simple; bh=IMQDXlcyvebHQxz2VKDbuxFbBiWUDfhqIX7YVtuto10=; h=Date:From:To:Cc:Subject:Message-ID:References:MIME-Version: Content-Type:Content-Disposition:In-Reply-To; b=H3gH/RVpNi2gjovHzfS9np9nwGg2tG9NQfpoY54fWS40tcWAnbTwUWDGoCQ48fVOcoMXb9ZgvLrQD/XOkUr+IILYgNKKmC4Azo6AWnsRDYeIaXVX/DSGEqG2lFRwDw8/H8OmFpfuKxZdZJFDQIc3ki2fOOUJJJ9mMzysbgXa+04= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=lunn.ch; spf=pass smtp.mailfrom=lunn.ch; dkim=pass (1024-bit key) header.d=lunn.ch header.i=@lunn.ch header.b=riAyyy3R; arc=none smtp.client-ip=156.67.10.101 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=lunn.ch Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=lunn.ch Authentication-Results: smtp.subspace.kernel.org; dkim=pass (1024-bit key) header.d=lunn.ch header.i=@lunn.ch header.b="riAyyy3R" DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=lunn.ch; s=20171124; h=In-Reply-To:Content-Transfer-Encoding:Content-Disposition: Content-Type:MIME-Version:References:Message-ID:Subject:Cc:To:From:Date:From: Sender:Reply-To:Subject:Date:Message-ID:To:Cc:MIME-Version:Content-Type: Content-Transfer-Encoding:Content-ID:Content-Description:Content-Disposition: In-Reply-To:References; bh=DSUOQkA4G9lIzr97crkRbWUMdPAUQSFiQh0ExbJayX8=; b=ri Ayyy3R+rKgw8i3ipTJONzX3ese8qPk789uvh4TYpYGROjcoMq3F2WlHR/oIG5W5rPvTBszFgCHvmq uTdGs/DEWr/80pZc0IeD9WlvmONZbwZTkNdWQP+RzybYW9DfB4z6H+EbsS6i9d/BLY6Ab/Fw7P3f/ Cxvz+zupang0j0M=; Received: from andrew by vps0.lunn.ch with local (Exim 4.94.2) (envelope-from ) id 1wOwk4-003UCG-Mq; Mon, 18 May 2026 14:06:40 +0200 Date: Mon, 18 May 2026 14:06:40 +0200 From: Andrew Lunn To: Ethan Nelson-Moore Cc: linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Russell King , Sebastian Hesselbarth , Gregory Clement Subject: Re: [PATCH] ARM: PCI: expand single-line pci_common_init() wrapper function Message-ID: <6b13f087-e865-4afb-bc8c-504eb268ce8e@lunn.ch> References: <20260517235916.57178-1-enelsonmoore@gmail.com> Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Disposition: inline Content-Transfer-Encoding: 8bit In-Reply-To: On Sun, May 17, 2026 at 09:20:46PM -0700, Ethan Nelson-Moore wrote: > Hi, Andrew, > > On Sun, May 17, 2026 at 8:42 PM Andrew Lunn wrote: > > Nobody seems to call pci_common_init_dev() without passing NULL. So i > > think it makes more sense to rename pci_common_init_dev() to > > pci_common_init() and drop struct device *parent parameter. You then > > only need to change pci.h and bios32.c. > > I considered that, but decided against it because it would prevent the > code from easily being updated to pass a parent parameter in the > future. However, given the age of the affected platforms, that is > unlikely to happen, so your approach might make more sense. What do > you think? These are all old platforms, they are likely to be slowly removed over the next few years, and then pci_common_init* can be removed. I don't expect any code to need to set the parent. And some new board does come along which needs it, it is an easy revert. You could also include a tiny patch which removes parent from pcibios_init_hw(). Andrew