From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id ACCD6EED616 for ; Fri, 15 Sep 2023 15:49:28 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S236295AbjIOPtE (ORCPT ); Fri, 15 Sep 2023 11:49:04 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:44190 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S236457AbjIOPs7 (ORCPT ); Fri, 15 Sep 2023 11:48:59 -0400 Received: from bombadil.infradead.org (bombadil.infradead.org [IPv6:2607:7c80:54:3::133]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id BFDDC2710; Fri, 15 Sep 2023 08:48:30 -0700 (PDT) DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=infradead.org; s=bombadil.20210309; h=Content-Transfer-Encoding: Content-Type:In-Reply-To:From:References:Cc:To:Subject:MIME-Version:Date: Message-ID:Sender:Reply-To:Content-ID:Content-Description; bh=leftU7vnx6ubtSCIPio+hyF+23cQ6uL5tDPuDZIs4dk=; b=YYqjIA6Phg4gWr7cpr90C7AQMG JPBckC5Gp1gat/6r+oY6tjpgDW2+MFCpZSMEDW3nt665gO51B+Du/Mg+YnEcWoAb7R3hkyhcBF0cT PiGlO3s6ZnHcXbXKr9QsStIrRq0KhTZYMPGQ7jfzMdzS2VGcoau6RYdsgxnbVP072afdAkyhPatLG T7R4OmlL1OWfWdfFPXGK0eifZ+B1dEwoWLHTAJiq6rYRw+hlrr5G9jZkOw2q3TFKN0+WiYKPfUx5q n1WOC1qIBz9/wzIHSnpi6BegyzrRyOFcNMFftrs34uJ4iHR5x9pAKQsQnbWWnlbkq1dVk4OtR1B/P BhPoA3uQ==; Received: from [2601:1c2:980:9ec0:e65e:37ff:febd:ee53] by bombadil.infradead.org with esmtpsa (Exim 4.96 #2 (Red Hat Linux)) id 1qhB3C-00B13L-1W; Fri, 15 Sep 2023 15:48:10 +0000 Message-ID: <6b507126-c4e6-40f2-9574-fe1abb0463ee@infradead.org> Date: Fri, 15 Sep 2023 08:48:08 -0700 MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH] Documentation: kbuild: explain handling optional dependencies Content-Language: en-US To: Arnd Bergmann , Jani Nikula , Masahiro Yamada Cc: Arnd Bergmann , Jonathan Corbet , Sakari Ailus , Javier Martinez Canillas , Nathan Chancellor , Nick Desaulniers , Nicolas Schier , linux-kbuild@vger.kernel.org, linux-doc@vger.kernel.org, linux-kernel@vger.kernel.org References: <20230913113801.1901152-1-arnd@kernel.org> <874jjwx44g.fsf@intel.com> <763b1599-06b7-490e-9cbf-eb07f1deedb3@app.fastmail.com> <87sf7fvqiz.fsf@intel.com> From: Randy Dunlap In-Reply-To: Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 9/15/23 00:44, Arnd Bergmann wrote: > On Fri, Sep 15, 2023, at 09:34, Jani Nikula wrote: >> >> IS_REACHABLE() considered harmful. > +1 absolutely. > Absolutely agreed, and I'm sorry I introduced it in the > first place in commit 9b174527e7b75 ("[media] Add and use > IS_REACHABLE macro"). > > At the time, it was only used by drivers/media, which used > to have a lot of open-coded instances of it and a lot of > wrong checks. > > Having a formal syntax for it was an improvement for > drivers/media since it was more broken before, but it's > usually a mistake to use it when there is another solution, > and we probably should have tried harder to fix the > dependencies in drivers/media at the time. > > Arnd -- ~Randy