mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Len Brown <lenb@kernel.org>
To: linux-acpi@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: Shaohua Li <shaohua.li@intel.com>, Len Brown <len.brown@intel.com>
Subject: [PATCH 32/85] ACPI: introduce notifier change to avoid duplicates
Date: Sat, 11 Oct 2008 02:35:52 -0400	[thread overview]
Message-ID: <6bd00a61ab63d4ceb635ae0316353c11c900b8d8.1223706853.git.len.brown@intel.com> (raw)
In-Reply-To: <1223707005-26864-1-git-send-email-lenb@kernel.org>
In-Reply-To: <1d80ebdb81444701024ad9b9f026516561496a43.1223706853.git.len.brown@intel.com>

From: Shaohua Li <shaohua.li@intel.com>

The battery driver already registers notification handler.
To avoid registering notification handler again,
introduce a notifier chain in global system notifier handler
and use it in dock driver.

Signed-off-by: Shaohua Li <shaohua.li@intel.com>
Signed-off-by: Len Brown <len.brown@intel.com>
---
 drivers/acpi/bus.c      |   15 +++++++++++++++
 drivers/acpi/dock.c     |   46 ++++++++++++++++++++++++----------------------
 include/acpi/acpi_bus.h |    3 +++
 3 files changed, 42 insertions(+), 22 deletions(-)

diff --git a/drivers/acpi/bus.c b/drivers/acpi/bus.c
index ccae305..0dc4494 100644
--- a/drivers/acpi/bus.c
+++ b/drivers/acpi/bus.c
@@ -496,6 +496,19 @@ static int acpi_bus_check_scope(struct acpi_device *device)
 	return 0;
 }
 
+static BLOCKING_NOTIFIER_HEAD(acpi_bus_notify_list);
+int register_acpi_bus_notifier(struct notifier_block *nb)
+{
+	return blocking_notifier_chain_register(&acpi_bus_notify_list, nb);
+}
+EXPORT_SYMBOL_GPL(register_acpi_bus_notifier);
+
+void unregister_acpi_bus_notifier(struct notifier_block *nb)
+{
+	blocking_notifier_chain_unregister(&acpi_bus_notify_list, nb);
+}
+EXPORT_SYMBOL_GPL(unregister_acpi_bus_notifier);
+
 /**
  * acpi_bus_notify
  * ---------------
@@ -506,6 +519,8 @@ static void acpi_bus_notify(acpi_handle handle, u32 type, void *data)
 	int result = 0;
 	struct acpi_device *device = NULL;
 
+	blocking_notifier_call_chain(&acpi_bus_notify_list,
+		type, (void *)handle);
 
 	if (acpi_bus_get_device(handle, &device))
 		return;
diff --git a/drivers/acpi/dock.c b/drivers/acpi/dock.c
index 799a0fd..2563bc6 100644
--- a/drivers/acpi/dock.c
+++ b/drivers/acpi/dock.c
@@ -748,6 +748,28 @@ static void dock_notify(acpi_handle handle, u32 event, void *data)
 	}
 }
 
+static int acpi_dock_notifier_call(struct notifier_block *this,
+	unsigned long event, void *data)
+{
+	struct dock_station *dock_station;
+	acpi_handle handle = (acpi_handle)data;
+
+	if (event != ACPI_NOTIFY_BUS_CHECK && event != ACPI_NOTIFY_DEVICE_CHECK
+	   && event != ACPI_NOTIFY_EJECT_REQUEST)
+		return 0;
+	list_for_each_entry(dock_station, &dock_stations, sibiling) {
+		if (dock_station->handle == handle) {
+			dock_notify(handle, event, dock_station);
+			return 0 ;
+		}
+	}
+	return 0;
+}
+
+static struct notifier_block dock_acpi_notifier = {
+	.notifier_call = acpi_dock_notifier_call,
+};
+
 /**
  * find_dock_devices - find devices on the dock station
  * @handle: the handle of the device we are examining
@@ -861,7 +883,6 @@ static DEVICE_ATTR(uid, S_IRUGO, show_dock_uid, NULL);
 static int dock_add(acpi_handle handle)
 {
 	int ret;
-	acpi_status status;
 	struct dock_dependent_device *dd;
 	struct dock_station *dock_station;
 	struct platform_device *dock_device;
@@ -956,23 +977,10 @@ static int dock_add(acpi_handle handle)
 	}
 	add_dock_dependent_device(dock_station, dd);
 
-	/* register for dock events */
-	status = acpi_install_notify_handler(dock_station->handle,
-					     ACPI_SYSTEM_NOTIFY,
-					     dock_notify, dock_station);
-
-	if (ACPI_FAILURE(status)) {
-		printk(KERN_ERR PREFIX "Error installing notify handler\n");
-		ret = -ENODEV;
-		goto dock_add_err;
-	}
-
 	dock_station_count++;
 	list_add(&dock_station->sibiling, &dock_stations);
 	return 0;
 
-dock_add_err:
-	kfree(dd);
 dock_add_err_unregister:
 	device_remove_file(&dock_device->dev, &dev_attr_docked);
 	device_remove_file(&dock_device->dev, &dev_attr_undock);
@@ -990,7 +998,6 @@ dock_add_err_unregister:
 static int dock_remove(struct dock_station *dock_station)
 {
 	struct dock_dependent_device *dd, *tmp;
-	acpi_status status;
 	struct platform_device *dock_device = dock_station->dock_device;
 
 	if (!dock_station_count)
@@ -1001,13 +1008,6 @@ static int dock_remove(struct dock_station *dock_station)
 				 list)
 	    kfree(dd);
 
-	/* remove dock notify handler */
-	status = acpi_remove_notify_handler(dock_station->handle,
-					    ACPI_SYSTEM_NOTIFY,
-					    dock_notify);
-	if (ACPI_FAILURE(status))
-		printk(KERN_ERR "Error removing notify handler\n");
-
 	/* cleanup sysfs */
 	device_remove_file(&dock_device->dev, &dev_attr_docked);
 	device_remove_file(&dock_device->dev, &dev_attr_undock);
@@ -1069,6 +1069,7 @@ static int __init dock_init(void)
 		return 0;
 	}
 
+	register_acpi_bus_notifier(&dock_acpi_notifier);
 	printk(KERN_INFO PREFIX "%s: %d docks/bays found\n",
 		ACPI_DOCK_DRIVER_DESCRIPTION, dock_station_count);
 	return 0;
@@ -1078,6 +1079,7 @@ static void __exit dock_exit(void)
 {
 	struct dock_station *dock_station;
 
+	unregister_acpi_bus_notifier(&dock_acpi_notifier);
 	list_for_each_entry(dock_station, &dock_stations, sibiling)
 		dock_remove(dock_station);
 }
diff --git a/include/acpi/acpi_bus.h b/include/acpi/acpi_bus.h
index a5ac0bc..f74f882 100644
--- a/include/acpi/acpi_bus.h
+++ b/include/acpi/acpi_bus.h
@@ -327,6 +327,9 @@ int acpi_bus_get_private_data(acpi_handle, void **);
 extern int acpi_notifier_call_chain(struct acpi_device *, u32, u32);
 extern int register_acpi_notifier(struct notifier_block *);
 extern int unregister_acpi_notifier(struct notifier_block *);
+
+extern int register_acpi_bus_notifier(struct notifier_block *nb);
+extern void unregister_acpi_bus_notifier(struct notifier_block *nb);
 /*
  * External Functions
  */
-- 
1.5.5.1


  parent reply	other threads:[~2008-10-11  6:58 UTC|newest]

Thread overview: 111+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-11  6:35 ACPI patch queue for 2.6.28 Len Brown
2008-10-11  6:35 ` [PATCH 01/85] ACPI: Add missing acpi.debug_layer Documentation hunk from Thomas Renninger Len Brown
2008-10-11  6:35   ` [PATCH 02/85] acpi: replace AE_BAD_ADDRESS exception code with AE_ERROR Len Brown
2008-10-11  6:35   ` [PATCH 03/85] ACPI: Get the device power state in the course of scanning device Len Brown
2008-10-11  6:35   ` [PATCH 04/85] ACPI: Attach the ACPI device to the ACPI handle as early as possible Len Brown
2008-10-11  6:35   ` [PATCH 05/85] ACPI: Add "acpi.power_nocheck=1" to disable power state check in power transition Len Brown
2008-10-11  6:35   ` [PATCH 06/85] ACPI: Add DMI check " Len Brown
2008-10-11  6:35   ` [PATCH 07/85] ACPI : Load device driver according to the status of acpi device Len Brown
2008-10-11  6:35   ` [PATCH 08/85] ACPICA: Copy dynamically loaded tables to local buffer Len Brown
2008-10-11  6:35   ` [PATCH 09/85] ACPICA: Add check for invalid handle in acpi_get_object_info Len Brown
2008-10-11  6:35   ` [PATCH 10/85] ACPICA: Allow same ACPI table to be loaded/unloaded more than once Len Brown
2008-10-11  6:35   ` [PATCH 11/85] ACPICA: Fix wrong resource descriptor length for 64-bit build Len Brown
2008-10-11  6:35   ` [PATCH 12/85] ACPICA: Fix table compare code, length then data Len Brown
2008-10-11  6:35   ` [PATCH 13/85] ACPICA: Return status from global init function Len Brown
2008-10-11  6:35   ` [PATCH 14/85] ACPICA: Add function to dereference returned reference objects Len Brown
2008-10-11  6:35   ` [PATCH 15/85] ACPICA: Fix warning for 64-bit build Len Brown
2008-10-11  6:35   ` [PATCH 16/85] ACPICA: Cleanup macro definition file Len Brown
2008-10-11  6:35   ` [PATCH 17/85] ACPICA: Return method arg count from acpi_get_object_info Len Brown
2008-10-11  6:35   ` [PATCH 18/85] ACPICA: Update version to 20080701 Len Brown
2008-10-11  6:35   ` [PATCH 19/85] ACPICA: Add function to decode reference obj types to strings Len Brown
2008-10-11  6:35   ` [PATCH 20/85] ACPICA: Improve object conversion error messages Len Brown
2008-10-11  6:35   ` [PATCH 21/85] ACPICA: x2APIC support: changes for MADT and SRAT ACPI tables Len Brown
2008-10-11  6:35   ` [PATCH 22/85] ACPICA: Update version to 20080729 Len Brown
2008-10-11  6:35   ` [PATCH 23/85] ACPI: Clear WAK_STS on resume Len Brown
2008-10-13  9:01     ` Christian Borntraeger
2008-10-11  6:35   ` [PATCH 24/85] ACPI : Add the support for _TTS object Len Brown
2008-10-11  6:35   ` [PATCH 25/85] Introduce FW_BUG, FW_WARN and FW_INFO to consistenly tell users about BIOS bugs Len Brown
2008-10-11  6:35   ` [PATCH 26/85] ACPI: cpufreq, processor: Detect old BIOS, not supporting CPU freq on a recent CPU Len Brown
2008-10-11  6:35   ` [PATCH 27/85] CPUFREQ: powernow-k8: Try to detect old BIOS, not supporting CPU freq on a recent AMD CPUs Len Brown
2008-10-11  6:35   ` [PATCH 28/85] ACPI: dock: avoid check _STA method Len Brown
2008-10-11  6:35   ` [PATCH 29/85] dock: fix eject request process (2.6.27-rc1 regression) Len Brown
2008-10-11  6:35   ` [PATCH 30/85] dock: add _LCK support Len Brown
2008-10-11  6:35   ` [PATCH 31/85] dock: add bay and battery hotplug support Len Brown
2008-10-11  6:35   ` Len Brown [this message]
2008-10-11  6:35   ` [PATCH 33/85] ACPI: fix hotplug race Len Brown
2008-10-11  6:35   ` [PATCH 34/85] libata: remove functions now handed by ACPI dock driver Len Brown
2008-10-11  6:35   ` [PATCH 35/85] dock: introduce .uevent for devices in dock, eg libata Len Brown
2008-10-11  6:35   ` [PATCH 36/85] bay: remove driver, all functions now handled by dock driver Len Brown
2008-10-11  6:35   ` [PATCH 37/85] dock: fix for ATA bay in a dock station Len Brown
2008-10-11  6:35   ` [PATCH 38/85] dock: add 'type' sysfs file Len Brown
2008-10-11  6:35   ` [PATCH 39/85] dock: Shaohua Li is new maintainer Len Brown
2008-10-11  6:36   ` [PATCH 40/85] ACPI suspend: Always use the 32-bit waking vector Len Brown
2008-10-11  6:36   ` [PATCH 41/85] panasonic-laptop: add Panasonic Let's Note laptop extras driver v0.94 Len Brown
2008-10-11  6:36   ` [PATCH 42/85] ACPI: EC: do transaction from interrupt context Len Brown
2008-10-11  6:36   ` [PATCH 43/85] ACPI: EC: Rename some variables Len Brown
2008-10-11  6:36   ` [PATCH 44/85] ACPICA: add preemption point after each opcode parse Len Brown
2008-10-11  6:36   ` [PATCH 45/85] ACPI Suspend: Enable ACPI during resume if SCI_EN is not set Len Brown
2008-10-11  6:36   ` [PATCH 46/85] ACPI: don't enable control method power button as wakeup device when Fixed Power button is used Len Brown
2008-10-11  6:36   ` [PATCH 47/85] acer-wmi: Add rfkill support for wireless and bluetooth Len Brown
2008-10-11  6:36   ` [PATCH 48/85] acer-wmi: Remove wireless and bluetooth sysfs entries Len Brown
2008-10-11  6:36   ` [PATCH 49/85] ACPI: WMI: Enable event methods when registering notifiers Len Brown
2008-10-11  6:36   ` [PATCH 50/85] ACPI: Change acpi_evaluate_integer to support 64-bit on 32-bit kernels Len Brown
2008-10-11  6:36   ` [PATCH 51/85] ACPI: fix FADT parsing Len Brown
2008-10-11  6:36   ` [PATCH 52/85] fujitsu-laptop: better handling of P8010 hotkey Len Brown
2008-10-11  6:36   ` [PATCH 53/85] i7300_idle driver v1.55 Len Brown
2008-10-11  8:33     ` Ingo Molnar
2008-10-15 22:32       ` Len Brown
2008-10-16 22:05       ` [PATCH 1/2] x86: allow module driver to register idle notifier Len Brown
2008-10-21  1:57         ` Len Brown
2008-10-21 11:49           ` Ingo Molnar
2008-10-16 22:08       ` [PATCH 2/2] i7300_idle driver v1.55 Len Brown
2008-10-20 17:32         ` Randy Dunlap
2008-10-21 22:09           ` Pallipadi, Venkatesh
2008-10-21 22:15             ` Randy Dunlap
2008-10-21 23:02               ` Pallipadi, Venkatesh
2008-10-21 16:47         ` Andi Kleen
2008-10-21 22:34           ` Pallipadi, Venkatesh
2008-10-22  7:19             ` Andi Kleen
2008-10-22 23:34               ` [PATCH] Disable ioat channel only on platforms where ile driver can load Venki Pallipadi
2008-10-22 23:51                 ` [PATCH] Cleanup of i7300_idle based on review comments Venki Pallipadi
2008-10-24 17:03                   ` Len Brown
2008-10-24 17:02                 ` [PATCH] Disable ioat channel only on platforms where ile driver can load Len Brown
     [not found]                 ` <f12847240810270941v68a1cf7aqfa7db14fceb61fe5@mail.gmail.com>
2008-10-28 16:30                   ` Sosnowski, Maciej
2008-10-22 23:40               ` [PATCH 2/2] i7300_idle driver v1.55 Venki Pallipadi
2008-10-23  1:11                 ` Andi Kleen
2008-10-23  4:59                   ` Pallipadi, Venkatesh
2008-10-23 12:26                     ` Andi Kleen
2008-10-23 15:00                     ` Paul E. McKenney
2008-10-23 16:26                       ` Andi Kleen
2008-10-11  6:36   ` [PATCH 54/85] eeepc-laptop: Use standard interfaces Len Brown
2008-10-11  6:36   ` [PATCH 55/85] x86: remove magic number from ACPI sleep stack buffer Len Brown
2008-10-11  6:36   ` [PATCH 56/85] x86: trim " Len Brown
2008-10-11  6:36   ` [PATCH 57/85] ACPI: acpi_driver_data could only be applied to acpi_device Len Brown
2008-10-11  6:36   ` [PATCH 58/85] ACPI: toshiba_acpi.c fix sparse signedness mismatch warnings Len Brown
2008-10-11  6:36   ` [PATCH 59/85] ACPI: catch calls of acpi_driver_data on pointer of wrong type Len Brown
2008-10-11  6:36   ` [PATCH 60/85] toshiba_acpi: depends on INPUT Len Brown
2008-10-11  6:36   ` [PATCH 61/85] PNP: fix debug formatting (cosmetic) Len Brown
2008-10-11  6:36   ` [PATCH 62/85] PNPACPI: use dev_printk when possible Len Brown
2008-10-11  6:36   ` [PATCH 63/85] PNP: convert the last few pnp_info() uses to printk() Len Brown
2008-10-11  6:36   ` [PATCH 64/85] PNP: use new vsprintf symbolic function pointer format Len Brown
2008-10-11  6:36   ` [PATCH 65/85] PNP: remove some uses of DEBUG ifdef Len Brown
2008-10-11  6:36   ` [PATCH 66/85] PNP: add CONFIG_PNP_DEBUG_MESSAGES and pnp_dbg() Len Brown
2008-10-11  6:36   ` [PATCH 67/85] PNP: convert to using pnp_dbg() Len Brown
2008-10-11  6:36   ` [PATCH 68/85] PNP: remove old CONFIG_PNP_DEBUG option Len Brown
2008-10-11  6:36   ` [PATCH 69/85] ACPI: don't load acpi_cpufreq if acpi=off Len Brown
2008-10-11  6:36   ` [PATCH 70/85] ACPI: remove unused have_arch_parse_srat Len Brown
2008-10-11  6:36   ` [PATCH 71/85] acer-wmi: Remove private workqueue Len Brown
2008-10-11  6:36   ` [PATCH 72/85] Subject: ACPI dock: Use ACPI_EXCEPTION instead of printk(KERN_ERR Len Brown
2008-10-11  6:36   ` [PATCH 73/85] ACPI cm_sbs: Debug interface used for error message cleanup Len Brown
2008-10-11  6:36   ` [PATCH 74/85] ACPI memhotplug: " Len Brown
2008-10-11  6:36   ` [PATCH 75/85] ACPI processor: " Len Brown
2008-10-11  6:36   ` [PATCH 76/85] ACPI video: " Len Brown
2008-10-11  6:36   ` [PATCH 77/85] ACPI scan: " Len Brown
2008-10-11  6:36   ` [PATCH 78/85] ACPI fan: " Len Brown
2008-10-11  6:36   ` [PATCH 79/85] ACPI osl: " Len Brown
2008-10-11  6:36   ` [PATCH 80/85] ACPI thermal: " Len Brown
2008-10-11  6:36   ` [PATCH 81/85] ACPI system: " Len Brown
2008-10-11  6:36   ` [PATCH 82/85] ACPI: remove unused acpi_is_child_device() Len Brown
2008-10-11  6:36   ` [PATCH 83/85] ACPI: Enable EC device immediately after ACPI full initialization Len Brown
2008-10-11  6:36   ` [PATCH 84/85] delete drivers/acpi/bay.c Len Brown
2008-10-11  6:36   ` [PATCH 85/85] panasonic-laptop: fix build Len Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6bd00a61ab63d4ceb635ae0316353c11c900b8d8.1223706853.git.len.brown@intel.com \
    --to=lenb@kernel.org \
    --cc=len.brown@intel.com \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=shaohua.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®