From: Steven Price <steven.price@arm.com>
To: Karunika Choo <karunika.choo@arm.com>, dri-devel@lists.freedesktop.org
Cc: nd@arm.com, Boris Brezillon <boris.brezillon@collabora.com>,
Liviu Dudau <liviu.dudau@arm.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 01/10] drm/panthor: Factor out GPU_ID register read into separate function
Date: Mon, 20 Oct 2025 09:57:19 +0100 [thread overview]
Message-ID: <6c01f00b-7be3-451e-8429-2c5036dfe103@arm.com> (raw)
In-Reply-To: <20251014094337.1009601-2-karunika.choo@arm.com>
On 14/10/2025 10:43, Karunika Choo wrote:
> Split the GPU_ID register read into its own helper function. The GPU_ID
> value will be used to enable architecture-specific behaviours, which may
> also affect how other registers (such as those used for gpu_info) are
> read.
>
> This change separates the read operation so that subsequent code can
> depend on the intermediate result of processing the GPU_ID.
>
> Signed-off-by: Karunika Choo <karunika.choo@arm.com>
I'd be very tempted to squash this into the next commit and simple read
the GPU ID at the beginning of panthor_hw_bind_device(). Is there any
reason not to?
Steve
> ---
> drivers/gpu/drm/panthor/panthor_hw.c | 16 +++++++++++++++-
> 1 file changed, 15 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/panthor/panthor_hw.c b/drivers/gpu/drm/panthor/panthor_hw.c
> index 4f2858114e5e..326a9db0b5c2 100644
> --- a/drivers/gpu/drm/panthor/panthor_hw.c
> +++ b/drivers/gpu/drm/panthor/panthor_hw.c
> @@ -62,7 +62,6 @@ static void panthor_gpu_info_init(struct panthor_device *ptdev)
> {
> unsigned int i;
>
> - ptdev->gpu_info.gpu_id = gpu_read(ptdev, GPU_ID);
> ptdev->gpu_info.csf_id = gpu_read(ptdev, GPU_CSF_ID);
> ptdev->gpu_info.gpu_rev = gpu_read(ptdev, GPU_REVID);
> ptdev->gpu_info.core_features = gpu_read(ptdev, GPU_CORE_FEATURES);
> @@ -117,8 +116,23 @@ static void panthor_hw_info_init(struct panthor_device *ptdev)
> ptdev->gpu_info.tiler_present);
> }
>
> +static int panthor_hw_gpu_id_init(struct panthor_device *ptdev)
> +{
> + ptdev->gpu_info.gpu_id = gpu_read(ptdev, GPU_ID);
> + if (!ptdev->gpu_info.gpu_id)
> + return -ENXIO;
> +
> + return 0;
> +}
> +
> int panthor_hw_init(struct panthor_device *ptdev)
> {
> + int ret = 0;
> +
> + ret = panthor_hw_gpu_id_init(ptdev);
> + if (ret)
> + return ret;
> +
> panthor_hw_info_init(ptdev);
>
> return 0;
next prev parent reply other threads:[~2025-10-20 8:57 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-14 9:43 [PATCH v1 00/10] drm/panthor: Add support for Mali-G1 GPUs Karunika Choo
2025-10-14 9:43 ` [PATCH v1 01/10] drm/panthor: Factor out GPU_ID register read into separate function Karunika Choo
2025-10-20 8:57 ` Steven Price [this message]
2025-10-14 9:43 ` [PATCH v1 02/10] drm/panthor: Add arch-specific panthor_hw binding Karunika Choo
2025-10-20 8:57 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 03/10] drm/panthor: Introduce framework for architecture-specific features Karunika Choo
2025-10-20 9:06 ` Steven Price
2025-10-24 6:43 ` Boris Brezillon
2025-10-24 9:26 ` Karunika Choo
2025-10-24 10:49 ` Boris Brezillon
2025-10-14 9:43 ` [PATCH v1 04/10] drm/panthor: Add architecture-specific function operations Karunika Choo
2025-10-20 9:10 ` Steven Price
2025-10-23 20:59 ` Karunika Choo
2025-10-24 9:34 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 05/10] drm/panthor: Introduce panthor_pwr API and power control framework Karunika Choo
2025-10-20 9:40 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 06/10] drm/panthor: Implement L2 power on/off via PWR_CONTROL Karunika Choo
2025-10-15 5:01 ` kernel test robot
2025-10-16 8:29 ` kernel test robot
2025-10-20 10:50 ` Steven Price
2025-10-23 22:16 ` Karunika Choo
2025-10-24 9:43 ` Steven Price
2025-10-24 11:51 ` Karunika Choo
2025-10-24 13:02 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 07/10] drm/panthor: Implement soft and fast reset " Karunika Choo
2025-10-20 11:24 ` Steven Price
2025-10-23 22:31 ` Karunika Choo
2025-10-14 9:43 ` [PATCH v1 08/10] drm/panthor: Support GLB_REQ.STATE field for Mali-G1 GPUs Karunika Choo
2025-10-20 11:39 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 09/10] drm/panthor: Support 64-bit endpoint_req register for Mali-G1 Karunika Choo
2025-10-20 13:12 ` Steven Price
2025-10-14 9:43 ` [PATCH v1 10/10] drm/panthor: Add support for Mali-G1 GPUs Karunika Choo
2025-10-20 13:18 ` Steven Price
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6c01f00b-7be3-451e-8429-2c5036dfe103@arm.com \
--to=steven.price@arm.com \
--cc=airlied@gmail.com \
--cc=boris.brezillon@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=karunika.choo@arm.com \
--cc=linux-kernel@vger.kernel.org \
--cc=liviu.dudau@arm.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=nd@arm.com \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®