mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: bot+bpf-ci@kernel.org
To: yanlonglong@kylinos.cn,andrii@kernel.org,eddyz87@gmail.com,ast@kernel.org,daniel@iogearbox.net,memxor@gmail.com,martin.lau@linux.dev,song@kernel.org,bpf@vger.kernel.org,linux-kselftest@vger.kernel.org,linux-kernel@vger.kernel.org
Cc: yanlonglong@kylinos.cn,ast@kernel.org,andrii@kernel.org,daniel@iogearbox.net,martin.lau@kernel.org,eddyz87@gmail.com,yonghong.song@linux.dev,clm@meta.com,ihor.solodrai@linux.dev
Subject: Re: [PATCH] libarena: use ARRAY_SIZE macro in test_rbtree.bpf.c
Date: Fri, 17 Jul 2026 08:29:45 +0000 (UTC)	[thread overview]
Message-ID: <6c21d7ae537ee667858193d330b8b0bac579355f44a650e66de881db958e3810@mail.kernel.org> (raw)
In-Reply-To: <20260717073237.1048-1-yanlonglong@kylinos.cn>

[-- Attachment #1: Type: text/plain, Size: 888 bytes --]

>     libarena: use ARRAY_SIZE macro in test_rbtree.bpf.c
>
>     The ARRAY_SIZE macro is more compact and more formal in linux source.
>
>     Fixes: 6c3e8a4d4765 ("selftests/bpf: libarena: Add rbtree data structure")
>     Signed-off-by: longlong yan <yanlonglong@kylinos.cn>

Should this commit include a Fixes: tag? The original code in commit
6c3e8a4d4765 was functionally correct - 'sizeof(keys) / sizeof(keys[0])'
produces the same result as 'ARRAY_SIZE(keys)'. This change improves code
style and readability but doesn't fix a bug.

Fixes: tags are typically reserved for commits that correct incorrect
behavior or address actual defects.


---
AI reviewed your patch. Please fix the bug or email reply why it's not a bug.
See: https://github.com/kernel-patches/vmtest/blob/master/ci/claude/README.md

CI run summary: https://github.com/kernel-patches/bpf/actions/runs/29564321134

  reply	other threads:[~2026-07-17  8:29 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-17  7:32 longlong yan
2026-07-17  8:29 ` bot+bpf-ci [this message]
2026-07-17 21:29 ` Emil Tsalapatis
  -- strict thread matches above, loose matches on Subject: below --
2026-07-17  6:47 longlong yan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6c21d7ae537ee667858193d330b8b0bac579355f44a650e66de881db958e3810@mail.kernel.org \
    --to=bot+bpf-ci@kernel.org \
    --cc=andrii@kernel.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=clm@meta.com \
    --cc=daniel@iogearbox.net \
    --cc=eddyz87@gmail.com \
    --cc=ihor.solodrai@linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=martin.lau@kernel.org \
    --cc=martin.lau@linux.dev \
    --cc=memxor@gmail.com \
    --cc=song@kernel.org \
    --cc=yanlonglong@kylinos.cn \
    --cc=yonghong.song@linux.dev \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox