mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dev Jain <dev.jain@arm.com>
To: Mark Brown <broonie@kernel.org>
Cc: shuah@kernel.org, oleg@redhat.com, stsp2@yandex.ru,
	mingo@kernel.org, tglx@linutronix.de, mark.rutland@arm.com,
	ryan.roberts@arm.com, suzuki.poulose@arm.com,
	Anshuman.Khandual@arm.com, DeepakKumar.Mishra@arm.com,
	AneeshKumar.KizhakeVeetil@arm.com,
	linux-kselftest@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] selftests: Add a test mangling with uc_sigmask
Date: Fri, 7 Jun 2024 19:56:57 +0530	[thread overview]
Message-ID: <6c946ece-3663-4520-a90a-68be4d93c56d@arm.com> (raw)
In-Reply-To: <ZmMOOOEg06SWQ05m@finisterre.sirena.org.uk>


On 6/7/24 19:12, Mark Brown wrote:
> On Fri, Jun 07, 2024 at 06:53:27PM +0530, Dev Jain wrote:
>> On 6/7/24 18:42, Mark Brown wrote:
>>> On Fri, Jun 07, 2024 at 05:53:19PM +0530, Dev Jain wrote:
>>>> + * Test describing a clear distinction between signal states - delivered and
>>>> + * blocked, and their relation with ucontext.
>>> This would be clearer if it said more positiviely what the relationship
>>> between these things is actually expected to be and how they're tested.
>>> Right now it's a bit hard to tell what the test is actually verifying.
>> I thought I had described that quite well in the code comments.
>> Anyways, I shall incorporate some detail into the initial test
>> description too.
> If the overview is confusing and people have to read the code to figure
> out what it means then that's an issue...


You are right.

I shall post a v2 rather quickly, perhaps in 1-2 days;

the SIGPIPE vs SIGSEGV mistake basically renders

this patch useless (although the test would still

pass), and makes the code unnecessarily hard

to review.


      reply	other threads:[~2024-06-07 14:27 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-06-07 12:23 [PATCH 0/2] Add test to distinguish between thread's signal mask and ucontext_t Dev Jain
2024-06-07 12:23 ` [PATCH 1/2] selftests: Rename sigaltstack to generic signal Dev Jain
2024-06-07 12:45   ` Mark Brown
2024-06-07 12:23 ` [PATCH 2/2] selftests: Add a test mangling with uc_sigmask Dev Jain
2024-06-07 13:12   ` Mark Brown
2024-06-07 13:23     ` Dev Jain
2024-06-07 13:42       ` Mark Brown
2024-06-07 14:26         ` Dev Jain [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6c946ece-3663-4520-a90a-68be4d93c56d@arm.com \
    --to=dev.jain@arm.com \
    --cc=AneeshKumar.KizhakeVeetil@arm.com \
    --cc=Anshuman.Khandual@arm.com \
    --cc=DeepakKumar.Mishra@arm.com \
    --cc=broonie@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=mingo@kernel.org \
    --cc=oleg@redhat.com \
    --cc=ryan.roberts@arm.com \
    --cc=shuah@kernel.org \
    --cc=stsp2@yandex.ru \
    --cc=suzuki.poulose@arm.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®