From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-1.web.codeaurora.org [10.30.226.201]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 38F992DCF7C for ; Fri, 28 Nov 2025 07:39:51 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=10.30.226.201 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1764315592; cv=none; b=gc/nGra/plcLdT/DCp6THUjm48RLyjkgR7c1qu67ahfT0shqBkgo3nW5VfabpU6+z77vZeQuonf4LxbgUFcuKOC/w1vr2e+fCcIEwX/FIzm449bkoiNl7hL3ue0s4QPNYr3Q2vvE8u8pj3tAkGD+LIGeQYDwNmqKwpcqxpiprcI= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1764315592; c=relaxed/simple; bh=L3fUvx3/4h6sB/neiDyj0+7nKMrKXGD2gImaI/RwOMI=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=rnj3Qtgv0kalqicLSPCtKaXxuc8bLqJRJ6HQcDKi95MjMWNqX7C+UiTI6NwNu08Df1M12+EKT/KS23V4jD1eWWJKCpCv/oFS97OcigZ492f5K1T6we1w6SXu5zCdTevAfsUOtXgKVsIY6fmjRTesGjDzLG2EX6mCm+FnwBnOUnI= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=UP0ipruO; arc=none smtp.client-ip=10.30.226.201 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="UP0ipruO" Received: by smtp.kernel.org (Postfix) with ESMTPSA id D08BDC116B1; Fri, 28 Nov 2025 07:39:46 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=kernel.org; s=k20201202; t=1764315591; bh=L3fUvx3/4h6sB/neiDyj0+7nKMrKXGD2gImaI/RwOMI=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=UP0ipruOgOTR/Dg6FIwQ4nodKu+6zNOYwMdVq0WDRzVsRbhBXGIf5AkCZrqZIfM2N KaqzYIk1Zgbhqro9VPRn4M6Ez94pATD4lidhtfX0sFDJxf/Av5Jttb4cN1ZKqmYUoX zlBJsdX+X1PPFL77TctY5FK0/4irX6c/Zs/I/2h4IJuu896+DqRsa6mfWGHDvFN/SR w1PKXsHOMsaASBG0ub9ldcJ3JnoWrSCMtQ6I1bQauSsY3nt9pJFGovMUacwMfFjPJN 8EtPjFRO+WgeujcFWzvUasot96xbLtqzu6lDV0hMlBFY2jLCBsNkU98PPLMmBvFSoK Lcai1/OO4Gbpg== Message-ID: <6d2605e8-409d-4b4a-9729-599dd2526b74@kernel.org> Date: Fri, 28 Nov 2025 08:39:44 +0100 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH v9 1/7] treewide: provide a generic clear_user_page() variant To: Ankur Arora Cc: "David Hildenbrand (Red Hat)" , linux-kernel@vger.kernel.org, linux-mm@kvack.org, x86@kernel.org, akpm@linux-foundation.org, bp@alien8.de, dave.hansen@linux.intel.com, hpa@zytor.com, mingo@redhat.com, mjguzik@gmail.com, luto@kernel.org, peterz@infradead.org, tglx@linutronix.de, willy@infradead.org, raghavendra.kt@amd.com, boris.ostrovsky@oracle.com, konrad.wilk@oracle.com References: <20251121202352.494700-1-ankur.a.arora@oracle.com> <20251121202352.494700-2-ankur.a.arora@oracle.com> <189bc218-8f19-4686-b2ee-5ddc6a0b4684@kernel.org> <87bjkq8s7a.fsf@oracle.com> <87tsyf58ro.fsf@oracle.com> From: "Christophe Leroy (CS GROUP)" Content-Language: fr-FR In-Reply-To: <87tsyf58ro.fsf@oracle.com> Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 8bit Hi Ankur, Le 28/11/2025 à 00:57, Ankur Arora a écrit : > > Ankur Arora writes: > > > How about something like this for clear_user_page() (though maybe I > should be always defining clear_user_page() and not conditioning it on > the existence of the generic clear_user_highpage()): > > diff --git a/include/linux/highmem.h b/include/linux/highmem.h > index abc20f9810fd..ca9d28aa29b2 100644 > --- a/include/linux/highmem.h > +++ b/include/linux/highmem.h > @@ -197,6 +197,22 @@ static inline void invalidate_kernel_vmap_range(void *vaddr, int size) > } > #endif > > +#if !defined(clear_user_page) && !defined(clear_user_highpage) > +/** > + * clear_user_page() - clear a page to be mapped to user space > + * @addr: the address of the page > + * @vaddr: the address of the user mapping > + * @page: the page > + * > + * The sole user of clear_user_page() is clear_user_highpage(). > + * Define it if the arch does not and only if needed. > + */ > +static inline void clear_user_page(void *addr, unsigned long vaddr, struct page *page) > +{ > + clear_page(addr); > +} > +#endif WOuld be more obvious if you enclose that inside the same #ifdef as clear_user_highpage(), something like: #ifndef clear_user_highpage #ifndef clear_user_page static inline void clear_user_page(void *addr, unsigned long vaddr, struct page *page) { clear_page(addr); } #endif static inline void clear_user_highpage(struct page *page, unsigned long vaddr) { void *addr = kmap_local_page(page); clear_user_page(addr, vaddr, page); kunmap_local(addr); } #endif > + > /* when CONFIG_HIGHMEM is not set these will be plain clear/copy_page */ > #ifndef clear_user_highpage > static inline void clear_user_highpage(struct page *page, unsigned long vaddr) > > And for clear_user_pages(): > > diff --git a/include/linux/highmem.h b/include/linux/highmem.h > index ca9d28aa29b2..b9b3cc76a91a 100644 > --- a/include/linux/highmem.h > +++ b/include/linux/highmem.h > @@ -223,6 +223,35 @@ static inline void clear_user_highpage(struct page *page, unsigned long vaddr) > } > #endif > > +/** > + * clear_user_pages() - clear a page range to be mapped to user space > + * @addr: start address > + * @vaddr: start address of the user mapping > + * @page: start page > + * @npages: number of pages > + * > + * Assumes that the region (@addr, +@npages) has been validated > + * already so this does no exception handling. > + */ > +static inline void clear_user_pages(void *addr, unsigned long vaddr, > + struct page *page, unsigned int npages) > +{ > +#ifdef clear_user_page > + do { > + clear_user_page(addr, vaddr, page); > + addr += PAGE_SIZE; > + vaddr += PAGE_SIZE; > + page++; > + } while (--npages); > +#else > + /* > + * Prefer clear_pages() to allow for architectural optimizations > + * when operations on contiguous page ranges. > + */ > + clear_pages(addr, npages); > +#endif > +} Not sure to understand the logic. You say this is not expected to be overriden by architectures in the near future, then why do we need that ? Can't we do everything inside clear_user_highpages() for clarity ? At the time being clear_user_page() is used exclusively by clear_user_highpage() so I expect clear_user_page() to only exist when CONFIG_HIGHMEM is enabled. And in that case clear_user_highpages() doesn't call clear_user_pages() so at the end only the else part remains, which is a simple call to clear_pages(). Why not just call clear_pages() directly from clear_user_highpages() and drop clear_user_pages() ? Christophe