From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 0D7F518B0F for ; Fri, 26 Jun 2026 17:01:59 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1782493321; cv=none; b=CO2wsQ7QaWL8jgD6TxsQtw+49WML1w3MotrSiwuZrsIOx+bsS8MqbrpUoDnM14OkG+v8mzA5hLkxHr2IzgB4cFKSwd5pm+AfK1zo/y6G/BH9YtI3cxnrI0/I6yZ24pigjKvZNH0YWqlpqLCNcD6QYrjDEZdy49i+RAsD+2Vr1vg= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1782493321; c=relaxed/simple; bh=rPl2MnE+c0lps0DRtclvVrRPrjrP0Lm0ltnq1ABCaho=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=rvymbWb2awZlHO05a6PTpFNwpzWu8YpqK4q6B/3mNOiLFisspqwTp62iFJ5k8XfBb3fUrchK7B929jbb96BnZA6Pe+sSD+GiLPyXDtCzxlte5R0I4/PUA2AtKSTQ+8sZwGvMFGwCt5KnbdR6o4BfVhu1HWY5+lQhRcsD7/3A1Io= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=d40MDhLL; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="d40MDhLL" Received: by smtp.kernel.org (Postfix) with ESMTPSA id CC0091F000E9; Fri, 26 Jun 2026 17:01:54 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1782493319; bh=IDLJ3unlJJuJqzXW94kopPN3/rkEcpY2dYB5PnTRk30=; h=Date:Subject:To:Cc:References:From:In-Reply-To; b=d40MDhLL2pbmkmMZZZmju8x4k1gaiIk8fUXTIjQOAilsMzseLiDEu1XvfE9ghM/Zv lFHPVzygKpkr1o7SY1Q+ZG9aW/PU9kW3tTo6OeEs5LnhBVtr1W7KHhgaVPFNI6NMt1 uunjwPF+dmVGNPyQbl6SIcqxd4xZiQZN6pqyPqpdGtM5RXNT8MFSYsM9LnV7iD429X GPPtFQ5vy+KKj3lY/z6EDCaxVDAOJuTHbFLnP9uG3fJWX2nrysNsGiP/GWmwDXsU75 YSQLFQ/3lpDk89nUXTifLckYOU0D0T3QhTsQOTSmQgN16UoEYTShL8T94GCO/LeL0+ g58sBSq53zfjw== Message-ID: <6da834ec-e62a-467a-9951-b591cf9c508d@kernel.org> Date: Fri, 26 Jun 2026 19:01:53 +0200 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH 1/3] mm/migrate: rename page to folio leftovers To: "Garg, Shivank" , Andrew Morton , Zi Yan , Matthew Brost , Joshua Hahn , Rakie Kim , Byungchul Park , Gregory Price , Ying Huang , Alistair Popple , Lorenzo Stoakes , "Liam R. Howlett" , Vlastimil Babka , Mike Rapoport , Suren Baghdasaryan , Michal Hocko Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org, Dev Jain References: <20260626-migrate-cleanups-prep-v1-0-a95933af7619@amd.com> <20260626-migrate-cleanups-prep-v1-1-a95933af7619@amd.com> <53e834e9-2cb1-49c1-ab27-2d6b51d50fc0@kernel.org> <6d477d0b-1f14-4e33-958d-e6a66c647963@amd.com> From: "David Hildenbrand (Arm)" Content-Language: en-US Autocrypt: addr=david@kernel.org; keydata= xsFNBFXLn5EBEAC+zYvAFJxCBY9Tr1xZgcESmxVNI/0ffzE/ZQOiHJl6mGkmA1R7/uUpiCjJ dBrn+lhhOYjjNefFQou6478faXE6o2AhmebqT4KiQoUQFV4R7y1KMEKoSyy8hQaK1umALTdL QZLQMzNE74ap+GDK0wnacPQFpcG1AE9RMq3aeErY5tujekBS32jfC/7AnH7I0v1v1TbbK3Gp XNeiN4QroO+5qaSr0ID2sz5jtBLRb15RMre27E1ImpaIv2Jw8NJgW0k/D1RyKCwaTsgRdwuK Kx/Y91XuSBdz0uOyU/S8kM1+ag0wvsGlpBVxRR/xw/E8M7TEwuCZQArqqTCmkG6HGcXFT0V9 PXFNNgV5jXMQRwU0O/ztJIQqsE5LsUomE//bLwzj9IVsaQpKDqW6TAPjcdBDPLHvriq7kGjt WhVhdl0qEYB8lkBEU7V2Yb+SYhmhpDrti9Fq1EsmhiHSkxJcGREoMK/63r9WLZYI3+4W2rAc UucZa4OT27U5ZISjNg3Ev0rxU5UH2/pT4wJCfxwocmqaRr6UYmrtZmND89X0KigoFD/XSeVv jwBRNjPAubK9/k5NoRrYqztM9W6sJqrH8+UWZ1Idd/DdmogJh0gNC0+N42Za9yBRURfIdKSb B3JfpUqcWwE7vUaYrHG1nw54pLUoPG6sAA7Mehl3nd4pZUALHwARAQABzS5EYXZpZCBIaWxk ZW5icmFuZCAoQ3VycmVudCkgPGRhdmlkQGtlcm5lbC5vcmc+wsGQBBMBCAA6AhsDBQkmWAik AgsJBBUKCQgCFgICHgUCF4AWIQQb2cqtc1xMOkYN/MpN3hD3AP+DWgUCaYJt/AIZAQAKCRBN 3hD3AP+DWriiD/9BLGEKG+N8L2AXhikJg6YmXom9ytRwPqDgpHpVg2xdhopoWdMRXjzOrIKD g4LSnFaKneQD0hZhoArEeamG5tyo32xoRsPwkbpIzL0OKSZ8G6mVbFGpjmyDLQCAxteXCLXz ZI0VbsuJKelYnKcXWOIndOrNRvE5eoOfTt2XfBnAapxMYY2IsV+qaUXlO63GgfIOg8RBaj7x 3NxkI3rV0SHhI4GU9K6jCvGghxeS1QX6L/XI9mfAYaIwGy5B68kF26piAVYv/QZDEVIpo3t7 /fjSpxKT8plJH6rhhR0epy8dWRHk3qT5tk2P85twasdloWtkMZ7FsCJRKWscm1BLpsDn6EQ4 jeMHECiY9kGKKi8dQpv3FRyo2QApZ49NNDbwcR0ZndK0XFo15iH708H5Qja/8TuXCwnPWAcJ DQoNIDFyaxe26Rx3ZwUkRALa3iPcVjE0//TrQ4KnFf+lMBSrS33xDDBfevW9+Dk6IISmDH1R HFq2jpkN+FX/PE8eVhV68B2DsAPZ5rUwyCKUXPTJ/irrCCmAAb5Jpv11S7hUSpqtM/6oVESC 3z/7CzrVtRODzLtNgV4r5EI+wAv/3PgJLlMwgJM90Fb3CB2IgbxhjvmB1WNdvXACVydx55V7 LPPKodSTF29rlnQAf9HLgCphuuSrrPn5VQDaYZl4N/7zc2wcWM7BTQRVy5+RARAA59fefSDR 9nMGCb9LbMX+TFAoIQo/wgP5XPyzLYakO+94GrgfZjfhdaxPXMsl2+o8jhp/hlIzG56taNdt VZtPp3ih1AgbR8rHgXw1xwOpuAd5lE1qNd54ndHuADO9a9A0vPimIes78Hi1/yy+ZEEvRkHk /kDa6F3AtTc1m4rbbOk2fiKzzsE9YXweFjQvl9p+AMw6qd/iC4lUk9g0+FQXNdRs+o4o6Qvy iOQJfGQ4UcBuOy1IrkJrd8qq5jet1fcM2j4QvsW8CLDWZS1L7kZ5gT5EycMKxUWb8LuRjxzZ 3QY1aQH2kkzn6acigU3HLtgFyV1gBNV44ehjgvJpRY2cC8VhanTx0dZ9mj1YKIky5N+C0f21 zvntBqcxV0+3p8MrxRRcgEtDZNav+xAoT3G0W4SahAaUTWXpsZoOecwtxi74CyneQNPTDjNg azHmvpdBVEfj7k3p4dmJp5i0U66Onmf6mMFpArvBRSMOKU9DlAzMi4IvhiNWjKVaIE2Se9BY FdKVAJaZq85P2y20ZBd08ILnKcj7XKZkLU5FkoA0udEBvQ0f9QLNyyy3DZMCQWcwRuj1m73D sq8DEFBdZ5eEkj1dCyx+t/ga6x2rHyc8Sl86oK1tvAkwBNsfKou3v+jP/l14a7DGBvrmlYjO 59o3t6inu6H7pt7OL6u6BQj7DoMAEQEAAcLBfAQYAQgAJgIbDBYhBBvZyq1zXEw6Rg38yk3e EPcA/4NaBQJonNqrBQkmWAihAAoJEE3eEPcA/4NaKtMQALAJ8PzprBEXbXcEXwDKQu+P/vts IfUb1UNMfMV76BicGa5NCZnJNQASDP/+bFg6O3gx5NbhHHPeaWz/VxlOmYHokHodOvtL0WCC 8A5PEP8tOk6029Z+J+xUcMrJClNVFpzVvOpb1lCbhjwAV465Hy+NUSbbUiRxdzNQtLtgZzOV Zw7jxUCs4UUZLQTCuBpFgb15bBxYZ/BL9MbzxPxvfUQIPbnzQMcqtpUs21CMK2PdfCh5c4gS sDci6D5/ZIBw94UQWmGpM/O1ilGXde2ZzzGYl64glmccD8e87OnEgKnH3FbnJnT4iJchtSvx yJNi1+t0+qDti4m88+/9IuPqCKb6Stl+s2dnLtJNrjXBGJtsQG/sRpqsJz5x1/2nPJSRMsx9 5YfqbdrJSOFXDzZ8/r82HgQEtUvlSXNaXCa95ez0UkOG7+bDm2b3s0XahBQeLVCH0mw3RAQg r7xDAYKIrAwfHHmMTnBQDPJwVqxJjVNr7yBic4yfzVWGCGNE4DnOW0vcIeoyhy9vnIa3w1uZ 3iyY2Nsd7JxfKu1PRhCGwXzRw5TlfEsoRI7V9A8isUCoqE2Dzh3FvYHVeX4Us+bRL/oqareJ CIFqgYMyvHj7Q06kTKmauOe4Nf0l0qEkIuIzfoLJ3qr5UyXc2hLtWyT9Ir+lYlX9efqh7mOY qIws/H2t In-Reply-To: <6d477d0b-1f14-4e33-958d-e6a66c647963@amd.com> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 6/26/26 18:42, Garg, Shivank wrote: > > > On 6/26/2026 9:40 PM, David Hildenbrand (Arm) wrote: >> On 6/26/26 11:37, Shivank Garg wrote: >>> Rename migrate_folio_undo_src()'s page_was_mapped parameter to >>> folio_was_mapped, matching FOLIO_WAS_MAPPED naming. >>> >>> Also fix migrate_folio() kerneldoc to say "folio" instead of "page". >>> >>> Suggested-by: Dev Jain >>> Signed-off-by: Shivank Garg >>> --- >>> mm/migrate.c | 11 ++++------- >>> 1 file changed, 4 insertions(+), 7 deletions(-) >>> >>> diff --git a/mm/migrate.c b/mm/migrate.c >>> index d9b23909d716..dd7dbd8d84a0 100644 >>> --- a/mm/migrate.c >>> +++ b/mm/migrate.c >>> @@ -884,7 +884,7 @@ static int __migrate_folio(struct address_space *mapping, struct folio *dst, >>> * @mapping: The address_space containing the folio. >>> * @dst: The folio to migrate the data to. >>> * @src: The folio containing the current data. >>> - * @mode: How to migrate the page. >>> + * @mode: How to migrate the folio. >>> * >>> * Common logic to directly migrate a single LRU folio suitable for >>> * folios that do not have private data. >>> @@ -1157,13 +1157,10 @@ static void __migrate_folio_extract(struct folio *dst, >>> } >>> >>> /* Restore the source folio to the original state upon failure */ >>> -static void migrate_folio_undo_src(struct folio *src, >>> - int page_was_mapped, >>> - struct anon_vma *anon_vma, >>> - bool locked, >>> - struct list_head *ret) >>> +static void migrate_folio_undo_src(struct folio *src, int folio_was_mapped, >>> + struct anon_vma *anon_vma, bool locked, struct list_head *ret) >>> { >>> - if (page_was_mapped) >>> + if (folio_was_mapped) >> >> Why not "was_mapped" given that folio is part of the function name? >> >> (it's also not "folio_locked") :) >> > > yes, makes sense. I'll use was_mapped. > > While here, what's your opinion on unmap_and_move_huge_page()? > It also has local variable named page_was_mapped even though the function > is fully folio-based. The function name and comments still have "page". Ah, yeah ... please fix that. And while at it, rename it to "unmap_and_move_hugetlb_folio". Thx :) -- Cheers, David