mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Arnd Bergmann" <arnd@kernel.org>
To: "Bjorn Helgaas" <helgaas@kernel.org>,
	"Gerd Bayer" <gbayer@linux.ibm.com>
Cc: "Hans Zhang" <18255117159@163.com>,
	bhelgaas@google.com, "Alexander Gordeev" <agordeev@linux.ibm.com>,
	"Christian Borntraeger" <borntraeger@linux.ibm.com>,
	"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
	jingoohan1@gmail.com,
	"Krzysztof Wilczyński" <kwilczynski@kernel.org>,
	linux-kernel@vger.kernel.org, linux-s390@vger.kernel.org,
	linux-next <linux-next@vger.kernel.org>,
	linux-pci@vger.kernel.org,
	"Lorenzo Pieralisi" <lpieralisi@kernel.org>,
	"Manivannan Sadhasivam" <mani@kernel.org>,
	"Rob Herring" <robh@kernel.org>,
	"Niklas Schnelle" <schnelle@linux.ibm.com>
Subject: Re: [PATCH] PCI: Fix endianness issues in pci_bus_read_config()
Date: Thu, 31 Jul 2025 21:01:17 +0200	[thread overview]
Message-ID: <6e34b4af-dff9-4360-b3da-c95ca7c740c9@app.fastmail.com> (raw)
In-Reply-To: <20250731183944.GA3424583@bhelgaas>

On Thu, Jul 31, 2025, at 20:39, Bjorn Helgaas wrote:
> On Thu, Jul 31, 2025 at 07:38:58PM +0200, Gerd Bayer wrote:
>>  
>> -	if (size == 1)
>> -		return pci_bus_read_config_byte(bus, devfn, where, (u8 *)val);
>> -	else if (size == 2)
>> -		return pci_bus_read_config_word(bus, devfn, where, (u16 *)val);
>> -	else if (size == 4)
>> -		return pci_bus_read_config_dword(bus, devfn, where, val);
>> -	else
>> -		return PCIBIOS_BAD_REGISTER_NUMBER;
>> +	if (size == 1) {
>> +		rc = pci_bus_read_config_byte(bus, devfn, where, (u8 *)val);
>> +#if (IS_ENABLED(CONFIG_CPU_BIG_ENDIAN))
>> +		*val = ((*val >> 24) & 0xff);
>> +#endif
>
> Yeah, this is all pretty ugly.  Obviously the previous code in
> __pci_find_next_cap_ttl() didn't need this.  My guess is that was
> because the destination for the read data was always the correct type
> (u8/u16/u32), but here we always use a u32 and cast it to the
> appropriate type.  Maybe we can use the correct types here instead of
> the casts?

Agreed, the casts here just add more potential for bugs.

The pci_bus_read_config() interface itself may have been a
mistake, can't the callers just use the underlying helpers
directly?

      Arnd

  reply	other threads:[~2025-07-31 19:01 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-07-16 16:11 [PATCH v14 0/7] Refactor capability search into common macros Hans Zhang
2025-07-16 16:11 ` [PATCH v14 1/7] PCI: Introduce generic bus config read helper function Hans Zhang
2025-07-16 16:11 ` [PATCH v14 2/7] PCI: Clean up __pci_find_next_cap_ttl() readability Hans Zhang
2025-07-16 16:11 ` [PATCH v14 3/7] PCI: Refactor standard capability search into common macro Hans Zhang
2025-07-16 16:12 ` [PATCH v14 4/7] PCI: Refactor extended " Hans Zhang
2025-07-16 16:12 ` [PATCH v14 5/7] PCI: dwc: Use common PCI host bridge APIs for finding the capabilities Hans Zhang
2025-07-16 16:12 ` [PATCH v14 6/7] PCI: cadence: " Hans Zhang
2025-07-16 16:12 ` [PATCH v14 7/7] PCI: cadence: Use cdns_pcie_find_*capability to avoid hardcode Hans Zhang
2025-07-16 23:11 ` [PATCH v14 0/7] Refactor capability search into common macros Bjorn Helgaas
2025-07-31  7:32   ` [REGRESSION] next/master: suspect endianness issue in common PCI capability search macro Gerd Bayer
2025-07-31 17:38     ` [PATCH] PCI: Fix endianness issues in pci_bus_read_config() Gerd Bayer
2025-07-31 18:39       ` Bjorn Helgaas
2025-07-31 19:01         ` Arnd Bergmann [this message]
2025-08-01  8:18           ` Manivannan Sadhasivam
2025-08-01  9:25             ` Hans Zhang
2025-08-01  9:47               ` Manivannan Sadhasivam
2025-08-01 10:06                 ` Hans Zhang
2025-08-01 10:54                   ` Manivannan Sadhasivam
2025-08-01 11:30                     ` Gerd Bayer
2025-08-01 16:54                       ` Hans Zhang
2025-08-01 18:08                         ` Keith Busch
2025-08-02 15:23                           ` Hans Zhang
2025-08-02 15:40                             ` Arnd Bergmann
2025-08-04  3:06                       ` Hans Zhang
2025-08-04  8:03                         ` Arnd Bergmann
2025-08-04  8:25                           ` Hans Zhang
2025-08-04 10:09                         ` Gerd Bayer
2025-08-12 14:44                           ` Hans Zhang
2025-08-13  7:47                             ` Niklas Schnelle
2025-08-13  7:50                               ` Hans Zhang
2025-08-04 14:33                         ` Bjorn Helgaas
2025-08-04 15:04                           ` Hans Zhang
2025-08-01 16:47                     ` Hans Zhang
2025-07-31 18:53       ` Lukas Wunner
2025-08-01  7:52       ` Geert Uytterhoeven
2025-08-01 13:00   ` [PATCH v14 0/7] Refactor capability search into common macros Bjorn Helgaas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6e34b4af-dff9-4360-b3da-c95ca7c740c9@app.fastmail.com \
    --to=arnd@kernel.org \
    --cc=18255117159@163.com \
    --cc=agordeev@linux.ibm.com \
    --cc=bhelgaas@google.com \
    --cc=borntraeger@linux.ibm.com \
    --cc=gbayer@linux.ibm.com \
    --cc=helgaas@kernel.org \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=jingoohan1@gmail.com \
    --cc=kwilczynski@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-next@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-s390@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=mani@kernel.org \
    --cc=robh@kernel.org \
    --cc=schnelle@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®