From: Paolo Bonzini <pbonzini@redhat.com>
To: "Radim Krčmář" <rkrcmar@redhat.com>
Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org
Subject: Re: [PATCH 2/6] KVM: x86: decouple irqchip_in_kernel() and pic_irqchip()
Date: Fri, 25 Nov 2016 18:22:15 +0100 [thread overview]
Message-ID: <6f41f3cc-1d79-0bc1-114e-c20d90bb5608@redhat.com> (raw)
In-Reply-To: <20161125171159.GA6065@potion>
On 25/11/2016 18:11, Radim Krčmář wrote:
> 2016-11-25 03:59-0500, Paolo Bonzini:
>> ----- Original Message -----
>>> From: "Radim Krčmář" <rkrcmar@redhat.com>
>>> To: "Paolo Bonzini" <pbonzini@redhat.com>
>>> Cc: linux-kernel@vger.kernel.org, kvm@vger.kernel.org
>>> Sent: Thursday, November 24, 2016 6:21:04 PM
>>> Subject: Re: [PATCH 2/6] KVM: x86: decouple irqchip_in_kernel() and pic_irqchip()
>>>
>>> 2016-11-24 11:55-0500, Paolo Bonzini:
>>>>> irqchip_in_kernel() tried to save a bit by reusing pic_irqchip(), but it
>>>>> just complicated the code.
>>>>> Add kvm->arch.irqchip_kvm that matches kvm->arch.irqchip_split.
>>>>> (Turning them into an exclusive type would be nicer.)
>>>>
>>>> Then do it. ;)
>>>
>>> It is hard to name! :)
>>>
>>> I would squash something like this if the names were ok:
>>>
>>> diff --git a/arch/x86/include/asm/kvm_host.h
>>> b/arch/x86/include/asm/kvm_host.h
>>> index 929228ec2839..726235f0e3f3 100644
>>> --- a/arch/x86/include/asm/kvm_host.h
>>> +++ b/arch/x86/include/asm/kvm_host.h
>>> @@ -706,6 +706,12 @@ struct kvm_hv {
>>> HV_REFERENCE_TSC_PAGE tsc_ref;
>>> };
>>>
>>> +enum kvm_kernel_irqchip {
>>
>> kvm_kernel_irqchip_mode?
>
> If we append the mode, what about just "kvm_irqchip_mode"?
>
> irqchip_in_kernel() tells which one is in the kernel.
>
>>> + KVM_IRQCHIP_NONE,
>>> + KVM_IRQCHIP_KVM, /* created in KVM_CREATE_IRQCHIP */
>>> + KVM_IRQCHIP_SPLIT, /* created in KVM_CAP_SPLIT_IRQCHIP */
>>
>> Since you pretty much asked to nitpick,
>
> I am always interested in nitpicks!
>
>> KVM_IRQCHIP_KERNEL would
>> match irqchip_in_kernel better.
>
> Matching the enum name prefix would be nice, so I'd rename it to
> enum kvm_irqchip_kernel_mode then. I'd keep them this way if we go with
> enum kvm_irqchip_mode.
kvm_irqchip_mode is best I think (NONE/KERNEL/SPLIT).
Paolo
>> Also, s/in/with/? :)
>
> Ok.
>
>>> +};
>>> +
>>> struct kvm_arch {
>>> unsigned int n_used_mmu_pages;
>>> unsigned int n_requested_mmu_pages;
>>> @@ -778,8 +784,7 @@ struct kvm_arch {
>>>
>>> u64 disabled_quirks;
>>>
>>> - bool irqchip_kvm;
>>> - bool irqchip_split;
>>> + enum kvm_kernel_irqchip irqchip;
>>
>> irqchip_mode?
>
> Yes, thanks.
>
next prev parent reply other threads:[~2016-11-25 17:22 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-11-24 16:31 [PATCH 0/6] KVM: x86: minor irqchip improvements (API change) Radim Krčmář
2016-11-24 16:31 ` [PATCH 1/6] KVM: x86: do allow kvm irqchip with split irqchip Radim Krčmář
2016-11-24 16:31 ` [PATCH 2/6] KVM: x86: decouple irqchip_in_kernel() and pic_irqchip() Radim Krčmář
2016-11-24 16:55 ` Paolo Bonzini
2016-11-24 17:21 ` Radim Krčmář
2016-11-25 8:59 ` Paolo Bonzini
2016-11-25 17:11 ` Radim Krčmář
2016-11-25 17:22 ` Paolo Bonzini [this message]
2016-11-24 16:31 ` [PATCH 3/6] KVM: x86: make pic setup code look like ioapic setup Radim Krčmář
2016-11-24 16:31 ` [PATCH 4/6] KVM: x86: refactor pic setup in kvm_set_routing_entry Radim Krčmář
2016-11-24 16:31 ` [PATCH 5/6] KVM: x86: prevent setup of invalid routes Radim Krčmář
2016-11-24 16:31 ` [PATCH 6/6] KVM: x86: simplify conditions with split/kvm irqchip Radim Krčmář
2016-11-24 16:58 ` [PATCH 0/6] KVM: x86: minor irqchip improvements (API change) Paolo Bonzini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6f41f3cc-1d79-0bc1-114e-c20d90bb5608@redhat.com \
--to=pbonzini@redhat.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rkrcmar@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®