From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755501Ab3AEAtB (ORCPT ); Fri, 4 Jan 2013 19:49:01 -0500 Received: from hydra.sisk.pl ([212.160.235.94]:60597 "EHLO hydra.sisk.pl" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1754934Ab3AEAs6 (ORCPT ); Fri, 4 Jan 2013 19:48:58 -0500 From: "Rafael J. Wysocki" To: Bjorn Helgaas , "H. Peter Anvin" Cc: Yinghai Lu , "linux-pci@vger.kernel.org" , ACPI Devel Maling List , Greg Kroah-Hartman , LKML , Tony Luck , Jiang Liu , Myron Stowe Subject: Re: [Alternative 2][PATCH] ACPI / PCI: Set root bridge ACPI handle in advance Date: Sat, 05 Jan 2013 01:54:34 +0100 Message-ID: <7114758.9n3BYUUJrs@vostro.rjw.lan> User-Agent: KMail/4.9.5 (Linux/3.8.0-rc2+; KDE/4.9.5; x86_64; ; ) In-Reply-To: References: <1558789.gX8cmBgyDV@vostro.rjw.lan> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="utf-8" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Friday, January 04, 2013 05:36:55 PM Bjorn Helgaas wrote: > On Fri, Jan 4, 2013 at 5:19 PM, Yinghai Lu wrote: > > On Fri, Jan 4, 2013 at 4:14 PM, Rafael J. Wysocki wrote: > >> On Friday, January 04, 2013 04:03:01 PM Yinghai Lu wrote: > >>> On Fri, Jan 4, 2013 at 3:38 AM, Rafael J. Wysocki wrote: > >>> >> --- a/arch/x86/include/asm/pci.h > >>> >> +++ b/arch/x86/include/asm/pci.h > >>> >> @@ -14,6 +14,7 @@ > >>> >> struct pci_sysdata { > >>> >> int domain; /* PCI domain */ > >>> >> int node; /* NUMA node */ > >>> >> + void *acpi_handle; > >>> >> #ifdef CONFIG_X86_64 > >>> >> void *iommu; /* IOMMU private data */ > >>> >> #endif > >>> >> > >>> > >>> acpi_handle is not good name and it is confusing. > >> > >> Well, what would be a better name in your opinion? > >> > >> I was going to put that into a #ifdef CONFIG_ACPI / #endif, so what about > >> calling it acpi_data? > > > > yes, with #ifdef, you can use acpi_handle type directly. > > > > it is acpi handle for pci_root. > > > > so would call int pci_root_acpi_handle ? > > I just copied the name from the corresponding ia64 code. I don't care > if you want to change it, but I think there is *some* value in keeping > the x86 and ia64 code as similar as possible because it would be nice > to converge it some day. Well, the corresponding data structure for ia64 is called struct pci_controller, so it is quite obvious what acpi_handle in there means. :-) Since the data structure for x86 is called struct pci_sysdata and the data type for the field in question may be acpi_handle, perhaps we can call that field simply "root_handle"? Alternatively, in analogy with the iommu we could use void * as its data type and call it simply "acpi". That said I'm fine with using just "void *acpi_handle" as you did, but I would do the #ifdef CONFIG_ACPI / #endif around it anyway. I wonder what Peter thinks? Thanks, Rafael -- I speak only for myself. Rafael J. Wysocki, Intel Open Source Technology Center.