From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1756726AbdAKUgj (ORCPT ); Wed, 11 Jan 2017 15:36:39 -0500 Received: from mout.web.de ([212.227.15.4]:60724 "EHLO mout.web.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752734AbdAKUfl (ORCPT ); Wed, 11 Jan 2017 15:35:41 -0500 To: linux-mtd@lists.infradead.org, Boris Brezillon , Brian Norris , Cyrille Pitchen , David Woodhouse , Denys Vlasenko , Marek Vasut , Richard Weinberger From: SF Markus Elfring Subject: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Cc: LKML , kernel-janitors@vger.kernel.org Message-ID: <71189baa-8780-b80a-0b4d-9dae74763ba3@users.sourceforge.net> Date: Wed, 11 Jan 2017 21:34:13 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.6.0 MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-Provags-ID: V03:K0:QhSNt0/kdaynvV55l4/ia31FGJXmUrmp65ChlnFYX6I8CuaNRr/ xwZR28JowS7HlWM8tTKtX7jhsD+R+VuXPiuiBfwxeOpfjOCY3pEaPXj7eGtKobjlvu209IC 2oYY3zdnvGzB6tK6mCND1u4eyAJ/nQbWjqTQcZ+B9SOM6pQN4Qc0qIhlJ3GMh1pogzM8ICw YwoQp9cacb1MRWNuqjyEA== X-UI-Out-Filterresults: notjunk:1;V01:K0:oCqsXT1dhXE=:3JirlTycTaO7U0zKc3LeCA GP2rRzFa+R8t1L7efdefUKJHAgzs9e4Wv6A8gJ7vZl5A/CBs/8IgTTIbVb+VMPNPz8Dr1GR4M rjROjiUdeV1fUgfOH59HtxhkMiIzoaOwPDLRuJjEvsJLHxaT4HKvsVyu1PtCnuQsRYfUYmrX6 QJvMDdtA2dGU9OyTZ3XtCF2uso3dLKtOwGuZ2/ly3W3am4nCX3j2/UoFLsQLiIy4q9bgJUcTl grqwHwUn1Wz6LaIiYGeTIz6yNcqhY0C6o8b/Gwe33C9LZI0cM6MyqecoJd0UnXmzjNZqk12/5 U/XkODtVsF6aH0Hkx18fa74hhYMjo2AIzYvnjHe4L/gPLoqCxIm9R7WnlDiS1G+M0Y3uclKkD g5XvgWpdU63mCmJ6y1KXtjK5PPXFAGl/DV1Clbt7qkXhzuhzcThNMqEnfPg6SLAALNJnsEuO8 hcZjbBD8FxlUkAZxe2p5lK4UCgyQsBzXKCYBKfBdqB2epwIQb4I+G9ruJ8Z5t4ozXmwcLP5iF HxQ6gCQKw0ywRGsvKQdQGa/0XHgPPfKINqp1DLXAw2uRJXUC6kNmk5csN+J6eojoDXJH8X86U j3Zxxwrwsbdf/Ln7+c24gCgjHQENJ5zzfI3piWM9kBVH2NOZXj9jAfw0TlyhzcgNO8HatsuRa H4A6ETwiF188sSa2EU69FFjCGagGxLBzzAiLmPvxYfS0g1prSnRllrsaj14aQ4dT6vZvI5I/B ssU3l7TDPaAQ1KOwJKc82Ju+l1CtP/lhEv/mSH5zjwfuo6t1JbvArQAZjW9RS8siIn+gOT/Ec xSRSOt8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org From: Markus Elfring Date: Wed, 11 Jan 2017 21:21:12 +0100 Several update suggestions were taken into account from static source code analysis. Markus Elfring (18): Use kmalloc_array() in cfi_intelext_partition_fixup() Improve another size determination in cfi_intelext_partition_fixup() cfi_cmdset_0001: Add some spaces for better code readability cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() cfi_cmdset_0001: Use common error handling code in do_write_oneword() Use kcalloc() in cfi_intelext_setup() One function call and an unnecessary check less in cfi_intelext_setup() Rename a jump label in cfi_intelext_setup() Use kmalloc_array() in cfi_amdstd_setup() One function call less in cfi_amdstd_setup() after error detection Rename a jump label in cfi_amdstd_setup() cfi_cmdset_0002: Add some spaces for better code readability cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() cfi_cmdset_0002: Use common error handling code in do_write_oneword() Use kcalloc() in cfi_ppb_unlock() Use kmalloc_array() in cfi_staa_setup() Use common error handling code in cfi_staa_setup() cfi_cmdset_0020: Add some spaces for better code readability drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++----------------- drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++----------- drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++------------- 3 files changed, 214 insertions(+), 188 deletions(-) -- 2.11.0