From: Shivendra Pratap <shivendra.pratap@oss.qualcomm.com>
To: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
Cc: Bartosz Golaszewski <bartosz.golaszewski@linaro.org>,
Bjorn Andersson <andersson@kernel.org>,
Sebastian Reichel <sre@kernel.org>, Rob Herring <robh@kernel.org>,
Sudeep Holla <sudeep.holla@arm.com>,
Souvik Chakravarty <Souvik.Chakravarty@arm.com>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Andy Yan <andy.yan@rock-chips.com>,
Mark Rutland <mark.rutland@arm.com>,
Lorenzo Pieralisi <lpieralisi@kernel.org>,
Arnd Bergmann <arnd@arndb.de>,
Konrad Dybcio <konradybcio@kernel.org>,
cros-qcom-dts-watchers@chromium.org,
Vinod Koul <vkoul@kernel.org>,
Catalin Marinas <catalin.marinas@arm.com>,
Will Deacon <will@kernel.org>,
Florian Fainelli <florian.fainelli@broadcom.com>,
Mukesh Ojha <mukesh.ojha@oss.qualcomm.com>,
Stephen Boyd <swboyd@chromium.org>,
Andre Draszik <andre.draszik@linaro.org>,
linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-arm-msm@vger.kernel.org,
Elliot Berman <quic_eberman@quicinc.com>,
Srinivas Kandagatla <srini@kernel.org>
Subject: Re: [PATCH v11 2/8] power: reset: reboot-mode: Add support for 64 bit magic
Date: Sat, 19 Jul 2025 20:43:24 +0530 [thread overview]
Message-ID: <713b2cc8-1bc7-a8b7-678b-5fc7fe25615a@oss.qualcomm.com> (raw)
In-Reply-To: <6vlm3ybjpy2jq3cr2pzj4vcmqwoissdml2xmhfzlulfbrpzakt@xrepu6c5zykb>
On 7/19/2025 12:10 AM, Dmitry Baryshkov wrote:
> On Thu, Jul 17, 2025 at 06:16:48PM +0530, Shivendra Pratap wrote:
>> Current reboot-mode supports a single 32-bit argument for any
>> supported mode. Some reboot-mode based drivers may require
>> passing two independent 32-bit arguments during a reboot
>> sequence, for uses-cases, where a mode requires an additional
>> argument. Such drivers may not be able to use the reboot-mode
>> driver. For example, ARM PSCI vendor-specific resets, need two
>> arguments for its operation – reset_type and cookie, to complete
>> the reset operation. If a driver wants to implement this
>> firmware-based reset, it cannot use reboot-mode framework.
>>
>> Introduce 64-bit magic values in reboot-mode driver to
>> accommodate dual 32-bit arguments when specified via device tree.
>> In cases, where no second argument is passed from device tree,
>> keep the upper 32-bit of magic un-changed(0) to maintain backward
>> compatibility.
>>
>> Update the current drivers using reboot-mode for a 64-bit magic
>> value.
>>
>> Signed-off-by: Shivendra Pratap <shivendra.pratap@oss.qualcomm.com>
>> ---
>> drivers/power/reset/nvmem-reboot-mode.c | 5 ++---
>> drivers/power/reset/qcom-pon.c | 5 ++---
>> drivers/power/reset/reboot-mode.c | 27 +++++++++++++++------------
>> drivers/power/reset/syscon-reboot-mode.c | 5 ++---
>> include/linux/reboot-mode.h | 4 +++-
>> 5 files changed, 24 insertions(+), 22 deletions(-)
>>
>> diff --git a/drivers/power/reset/nvmem-reboot-mode.c b/drivers/power/reset/nvmem-reboot-mode.c
>> index 41530b70cfc48c2a83fbbd96f523d5816960a0d1..e3eed943fdefa271b22e1f1891abef5c9095b9a5 100644
>> --- a/drivers/power/reset/nvmem-reboot-mode.c
>> +++ b/drivers/power/reset/nvmem-reboot-mode.c
>> @@ -16,15 +16,14 @@ struct nvmem_reboot_mode {
>> struct nvmem_cell *cell;
>> };
>>
>> -static int nvmem_reboot_mode_write(struct reboot_mode_driver *reboot,
>> - unsigned int magic)
>> +static int nvmem_reboot_mode_write(struct reboot_mode_driver *reboot, u64 magic)
>> {
>> int ret;
>> struct nvmem_reboot_mode *nvmem_rbm;
>>
>> nvmem_rbm = container_of(reboot, struct nvmem_reboot_mode, reboot);
>>
>> - ret = nvmem_cell_write(nvmem_rbm->cell, &magic, sizeof(magic));
>> + ret = nvmem_cell_write(nvmem_rbm->cell, (u32 *)&magic, sizeof(u32));
>
> This will work differently on BE and LE systems. Assign a temp var and
> use it.
Ack.
>
>> if (ret < 0)
>> dev_err(reboot->dev, "update reboot mode bits failed\n");
>>
>> diff --git a/drivers/power/reset/qcom-pon.c b/drivers/power/reset/qcom-pon.c
>> index 7e108982a582e8243c5c806bd4a793646b87189f..93daf93c097f970afbaf43d36b1e4f725ca7a81f 100644
>> --- a/drivers/power/reset/qcom-pon.c
>> +++ b/drivers/power/reset/qcom-pon.c
>> @@ -27,8 +27,7 @@ struct qcom_pon {
>> long reason_shift;
>> };
>>
>> -static int qcom_pon_reboot_mode_write(struct reboot_mode_driver *reboot,
>> - unsigned int magic)
>> +static int qcom_pon_reboot_mode_write(struct reboot_mode_driver *reboot, u64 magic)
>> {
>> struct qcom_pon *pon = container_of
>> (reboot, struct qcom_pon, reboot_mode);
>> @@ -37,7 +36,7 @@ static int qcom_pon_reboot_mode_write(struct reboot_mode_driver *reboot,
>> ret = regmap_update_bits(pon->regmap,
>> pon->baseaddr + PON_SOFT_RB_SPARE,
>> GENMASK(7, pon->reason_shift),
>> - magic << pon->reason_shift);
>> + ((u32)magic) << pon->reason_shift);
>> if (ret < 0)
>> dev_err(pon->dev, "update reboot mode bits failed\n");
>>
>> diff --git a/drivers/power/reset/reboot-mode.c b/drivers/power/reset/reboot-mode.c
>> index 0269ec55106472cf2f2b12bd65704dd0114bf4a3..1196627fbf98d87eec57a3d4ee544e403e6eb946 100644
>> --- a/drivers/power/reset/reboot-mode.c
>> +++ b/drivers/power/reset/reboot-mode.c
>> @@ -19,12 +19,11 @@
>>
>> struct mode_info {
>> const char *mode;
>> - u32 magic;
>> + u64 magic;
>> struct list_head list;
>> };
>>
>> -static unsigned int get_reboot_mode_magic(struct reboot_mode_driver *reboot,
>> - const char *cmd)
>> +static struct mode_info *get_reboot_mode_info(struct reboot_mode_driver *reboot, const char *cmd)
>
> Why? This doesn't seem relevant to u32 -> u64 conversion.
yes. This function is no more needed. Will update it for u64.
>
>> {
>> const char *normal = "normal";
>> struct mode_info *info;
>> @@ -35,11 +34,11 @@ static unsigned int get_reboot_mode_magic(struct reboot_mode_driver *reboot,
>>
>> list_for_each_entry(info, &reboot->head, list)
>> if (!strcmp(info->mode, cmd))
>> - return info->magic;
>> + return info;
>>
>> /* try to match again, replacing characters impossible in DT */
>> if (strscpy(cmd_, cmd, sizeof(cmd_)) == -E2BIG)
>> - return 0;
>> + return NULL;
>>
>> strreplace(cmd_, ' ', '-');
>> strreplace(cmd_, ',', '-');
>> @@ -47,21 +46,21 @@ static unsigned int get_reboot_mode_magic(struct reboot_mode_driver *reboot,
>>
>> list_for_each_entry(info, &reboot->head, list)
>> if (!strcmp(info->mode, cmd_))
>> - return info->magic;
>> + return info;
>>
>> - return 0;
>> + return NULL;
>> }
>>
>> static int reboot_mode_notify(struct notifier_block *this,
>> unsigned long mode, void *cmd)
>> {
>> struct reboot_mode_driver *reboot;
>> - unsigned int magic;
>> + struct mode_info *info;
>>
>> reboot = container_of(this, struct reboot_mode_driver, reboot_notifier);
>> - magic = get_reboot_mode_magic(reboot, cmd);
>> - if (magic)
>> - reboot->write(reboot, magic);
>> + info = get_reboot_mode_info(reboot, cmd);
>> + if (info)
>> + reboot->write(reboot, info->magic);
>>
>> return NOTIFY_DONE;
>> }
>> @@ -78,6 +77,7 @@ int reboot_mode_register(struct reboot_mode_driver *reboot, struct device_node *
>> struct mode_info *info;
>> struct property *prop;
>> size_t len = strlen(PREFIX);
>> + u32 magic_64;
>> int ret;
>>
>> if (!np)
>> @@ -95,12 +95,15 @@ int reboot_mode_register(struct reboot_mode_driver *reboot, struct device_node *
>> goto error;
>> }
>>
>> - if (of_property_read_u32(np, prop->name, &info->magic)) {
>> + if (of_property_read_u32(np, prop->name, (u32 *)&info->magic)) {
>
> Again, somebody didn't think about endianness.
Ack. will update this wherever applicable.
>
>> pr_err("reboot mode %s without magic number\n", info->mode);
>> kfree(info);
>> continue;
>> }
>>
>> + if (!of_property_read_u32_index(np, prop->name, 1, &magic_64))
>> + info->magic |= (u64)magic_64 << 32;
>> +
>> info->mode = kstrdup_const(prop->name + len, GFP_KERNEL);
>> if (!info->mode) {
>> ret = -ENOMEM;
>> diff --git a/drivers/power/reset/syscon-reboot-mode.c b/drivers/power/reset/syscon-reboot-mode.c
>> index e0772c9f70f7a19cd8ec8a0b7fdbbaa7ba44afd0..6783d05e80fbc2c812b45ffe69755478af90d30a 100644
>> --- a/drivers/power/reset/syscon-reboot-mode.c
>> +++ b/drivers/power/reset/syscon-reboot-mode.c
>> @@ -20,8 +20,7 @@ struct syscon_reboot_mode {
>> u32 mask;
>> };
>>
>> -static int syscon_reboot_mode_write(struct reboot_mode_driver *reboot,
>> - unsigned int magic)
>> +static int syscon_reboot_mode_write(struct reboot_mode_driver *reboot, u64 magic)
>> {
>> struct syscon_reboot_mode *syscon_rbm;
>> int ret;
>> @@ -29,7 +28,7 @@ static int syscon_reboot_mode_write(struct reboot_mode_driver *reboot,
>> syscon_rbm = container_of(reboot, struct syscon_reboot_mode, reboot);
>>
>> ret = regmap_update_bits(syscon_rbm->map, syscon_rbm->offset,
>> - syscon_rbm->mask, magic);
>> + syscon_rbm->mask, (u32)magic);
>> if (ret < 0)
>> dev_err(reboot->dev, "update reboot mode bits failed\n");
>>
>> diff --git a/include/linux/reboot-mode.h b/include/linux/reboot-mode.h
>> index 36f071f4b82e1fc255d8dd679a18e537655c3179..d9d9165a8635e5d55d92197a69c7fae179ac2045 100644
>> --- a/include/linux/reboot-mode.h
>> +++ b/include/linux/reboot-mode.h
>> @@ -2,10 +2,12 @@
>> #ifndef __REBOOT_MODE_H__
>> #define __REBOOT_MODE_H__
>>
>> +#include <linux/types.h>
>> +
>> struct reboot_mode_driver {
>> struct device *dev;
>> struct list_head head;
>> - int (*write)(struct reboot_mode_driver *reboot, unsigned int magic);
>> + int (*write)(struct reboot_mode_driver *reboot, u64 magic);
>> struct notifier_block reboot_notifier;
>> };
>>
>>
>> --
>> 2.34.1
>>
>
next prev parent reply other threads:[~2025-07-19 15:13 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-17 12:46 [PATCH v11 0/8] Implement vendor resets for PSCI SYSTEM_RESET2 Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 1/8] power: reset: reboot-mode: Add device tree node-based registration Shivendra Pratap
2025-07-18 18:37 ` Dmitry Baryshkov
2025-07-19 15:35 ` Shivendra Pratap
2025-07-20 18:43 ` Dmitry Baryshkov
2025-07-17 12:46 ` [PATCH v11 2/8] power: reset: reboot-mode: Add support for 64 bit magic Shivendra Pratap
2025-07-18 18:40 ` Dmitry Baryshkov
2025-07-19 15:13 ` Shivendra Pratap [this message]
2025-07-19 16:57 ` Andrew Lunn
2025-07-19 17:37 ` Shivendra Pratap
2025-07-20 15:16 ` Andrew Lunn
2025-07-20 15:24 ` Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 3/8] dt-bindings: arm: Document reboot mode magic Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 4/8] firmware: psci: Implement vendor-specific resets as reboot-mode Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 5/8] arm64: dts: qcom: qcm6490-idp: Add PSCI SYSTEM_RESET2 types Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 6/8] arm64: dts: qcom: qcs6490-rb3gen2: " Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 7/8] arm64: dts: qcom: sa8775p-ride: " Shivendra Pratap
2025-07-17 12:46 ` [PATCH v11 8/8] power: reset: reboot-mode: Expose sysfs for registered reboot_modes Shivendra Pratap
2025-07-18 21:29 ` [PATCH v11 0/8] Implement vendor resets for PSCI SYSTEM_RESET2 Florian Fainelli
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=713b2cc8-1bc7-a8b7-678b-5fc7fe25615a@oss.qualcomm.com \
--to=shivendra.pratap@oss.qualcomm.com \
--cc=Souvik.Chakravarty@arm.com \
--cc=andersson@kernel.org \
--cc=andre.draszik@linaro.org \
--cc=andy.yan@rock-chips.com \
--cc=arnd@arndb.de \
--cc=bartosz.golaszewski@linaro.org \
--cc=catalin.marinas@arm.com \
--cc=conor+dt@kernel.org \
--cc=cros-qcom-dts-watchers@chromium.org \
--cc=devicetree@vger.kernel.org \
--cc=dmitry.baryshkov@oss.qualcomm.com \
--cc=florian.fainelli@broadcom.com \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mark.rutland@arm.com \
--cc=mukesh.ojha@oss.qualcomm.com \
--cc=quic_eberman@quicinc.com \
--cc=robh@kernel.org \
--cc=sre@kernel.org \
--cc=srini@kernel.org \
--cc=sudeep.holla@arm.com \
--cc=swboyd@chromium.org \
--cc=vkoul@kernel.org \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®