From: "Gustavo A. R. Silva" <gustavo@embeddedor.com>
To: Joe Perches <joe@perches.com>,
Jakub Kicinski <jakub.kicinski@netronome.com>,
"David S. Miller" <davem@davemloft.net>
Cc: oss-drivers@netronome.com, netdev@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH net-next] nfp: use struct_size() in kzalloc()
Date: Thu, 31 Jan 2019 11:15:05 -0600 [thread overview]
Message-ID: <714fd5ae-2738-c157-8497-0b6bdeef3ae7@embeddedor.com> (raw)
In-Reply-To: <dc6d827c187cd228b917f8d9d984bd5ea578d712.camel@perches.com>
Hi Joe,
On 1/31/19 11:11 AM, Joe Perches wrote:
> On Wed, 2019-01-30 at 18:38 -0600, Gustavo A. R. Silva wrote:
>> One of the more common cases of allocation size calculations is finding
>> the size of a structure that has a zero-sized array at the end, along
>> with memory for some number of elements for that array. For example:
>>
>> struct foo {
>> int stuff;
>> struct boo entry[];
>> };
>>
>> instance = kzalloc(sizeof(struct foo) + count * sizeof(struct boo), GFP_KERNEL);
>>
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
>>
>> instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL);
>>
>> This code was detected with the help of Coccinelle.
>
> Might be useful to augment the script to include cases
> where the computed size is saved to a temporary and
> that temporary is used ala:
>
Yep. That's already on my list.
> https://patchwork.kernel.org/patch/10782453/
>
> On Sat, 2019-01-26 at 20:42 +0800, YueHaibing wrote:
>> Use kmemdup rather than duplicating its implementation
> []
>> diff --git a/drivers/net/wireless/intel/iwlwifi/iwl-nvm-parse.c b/drivers/net/wireless/intel/iwlwifi/iwl-nvm-parse.c
> []
>> @@ -1196,13 +1196,9 @@ iwl_parse_nvm_mcc_info(struct device *dev, const struct iwl_cfg *cfg,
>> regd_to_copy = sizeof(struct ieee80211_regdomain) +
>> valid_rules * sizeof(struct ieee80211_reg_rule);
>> - copy_rd = kzalloc(regd_to_copy, GFP_KERNEL);
>> - if (!copy_rd) {
>> + copy_rd = kmemdup(regd, regd_to_copy, GFP_KERNEL);
>
> This should probably be
>
> copy_rd = kmemdup(regd, struct_size(regd, reg_rules, valid_rules),
> GFP_KERNEL);
>
I agree.
Thanks
--
Gustavo
next prev parent reply other threads:[~2019-01-31 17:15 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-01-31 0:38 Gustavo A. R. Silva
2019-01-31 0:52 ` Jakub Kicinski
2019-01-31 0:57 ` Gustavo A. R. Silva
2019-01-31 17:11 ` Joe Perches
2019-01-31 17:15 ` Gustavo A. R. Silva [this message]
2019-02-01 23:13 ` David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=714fd5ae-2738-c157-8497-0b6bdeef3ae7@embeddedor.com \
--to=gustavo@embeddedor.com \
--cc=davem@davemloft.net \
--cc=jakub.kicinski@netronome.com \
--cc=joe@perches.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=oss-drivers@netronome.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®