From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by smtp.subspace.kernel.org (Postfix) with ESMTP id A65B032F770 for ; Tue, 10 Mar 2026 08:42:57 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=217.140.110.172 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773132179; cv=none; b=PxvxHS/4osEBjYPlBiKpjQ1m0CLEtbY6eLjO8I7QrSzW7bR613Mb9GUeB/n39qoR5ys+w0a5j5+CS8FC1RRXNFiYlzQ3Vb40NNgV63s1oNva+qLDblxC7vCdYHq1kK0mLHs8JABFJKNyz3BYK1nYM3uyjr4wO/iqNpx6cdh7Qlw= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1773132179; c=relaxed/simple; bh=VJLywPqVB0xSdkxy/9dYeYRfLrUmmVjIbfAYp7inF+g=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=hJCNiCFVOgi5/akUo1CG23Gy+xzN1xkV2K0M7jwanYHxjcVEZgx5ND0920VrD3MP4QNfJOKSW5jfYDGANq00HxR25+G3VP/hvKLEFG6DLqjzcuSv7TW4HnddXfS4kfZzV2Oim/0Uz799P8Gl1uKqj4jGxH0snNY4L6ukzWG8pC8= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com; spf=pass smtp.mailfrom=arm.com; arc=none smtp.client-ip=217.140.110.172 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=arm.com Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id ADE53169C; Tue, 10 Mar 2026 01:42:50 -0700 (PDT) Received: from [10.164.19.59] (unknown [10.164.19.59]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 25CF83F7BD; Tue, 10 Mar 2026 01:42:47 -0700 (PDT) Message-ID: <71e7df79-cfe1-4f3d-b00c-8ac53f886c04@arm.com> Date: Tue, 10 Mar 2026 14:12:45 +0530 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH 3/9] mm/rmap: refactor lazyfree unmap commit path to commit_ttu_lazyfree_folio() To: "Lorenzo Stoakes (Oracle)" Cc: akpm@linux-foundation.org, axelrasmussen@google.com, yuanchu@google.com, david@kernel.org, hughd@google.com, chrisl@kernel.org, kasong@tencent.com, weixugc@google.com, Liam.Howlett@oracle.com, vbabka@kernel.org, rppt@kernel.org, surenb@google.com, mhocko@suse.com, riel@surriel.com, harry.yoo@oracle.com, jannh@google.com, pfalcato@suse.de, baolin.wang@linux.alibaba.com, shikemeng@huaweicloud.com, nphamcs@gmail.com, bhe@redhat.com, baohua@kernel.org, youngjun.park@lge.com, ziy@nvidia.com, kas@kernel.org, willy@infradead.org, yuzhao@google.com, linux-mm@kvack.org, linux-kernel@vger.kernel.org, ryan.roberts@arm.com, anshuman.khandual@arm.com References: <20260310073013.4069309-1-dev.jain@arm.com> <20260310073013.4069309-4-dev.jain@arm.com> <3915e3bc-c390-44bc-a463-bdd687598284@lucifer.local> Content-Language: en-US From: Dev Jain In-Reply-To: <3915e3bc-c390-44bc-a463-bdd687598284@lucifer.local> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 10/03/26 1:49 pm, Lorenzo Stoakes (Oracle) wrote: > On Tue, Mar 10, 2026 at 01:00:07PM +0530, Dev Jain wrote: >> Clean up the code by refactoring the post-pte-clearing path of lazyfree >> folio unmapping, into commit_ttu_lazyfree_folio(). >> >> No functional change is intended. >> >> Signed-off-by: Dev Jain > > This is a good idea, and we need more refactoring like this in the rmap code, > but comments/nits below. > >> --- >> mm/rmap.c | 93 ++++++++++++++++++++++++++++++++----------------------- >> 1 file changed, 54 insertions(+), 39 deletions(-) >> >> diff --git a/mm/rmap.c b/mm/rmap.c >> index 1fa020edd954a..a61978141ee3f 100644 >> --- a/mm/rmap.c >> +++ b/mm/rmap.c >> @@ -1966,6 +1966,57 @@ static inline unsigned int folio_unmap_pte_batch(struct folio *folio, >> FPB_RESPECT_WRITE | FPB_RESPECT_SOFT_DIRTY); >> } >> >> +static inline int commit_ttu_lazyfree_folio(struct vm_area_struct *vma, > > Strange name, maybe lazyfree_range()? Not sure what ttu has to do with ttu means try_to_unmap, just like it is used in TTU_SYNC, TTU_SPLIT_HUGE_PMD, etc. So personally I really like the name, it reads "commit the try-to-unmap of a lazyfree folio". The "commit" comes because the pte clearing has already happened, so now we are deciding if at all to back-off and restore the ptes. > anything... > >> + struct folio *folio, unsigned long address, pte_t *ptep, >> + pte_t pteval, long nr_pages) > > That long nr_pages is really grating now... Reading the discussion on patch 1, I'll convert this to unsigned long. > >> +{ > > Come on Dev, it's 2026, why on earth are you returning an integer and not a > bool? > > Also it would make sense for this to return false if something breaks, otherwise > true. Yes I was confused on which one of the options to choose :). Since the function does a lot more than just test some functionality (which is what boolean functions usually do) I was feeling weird when returning bool. But yeah alright, I'll convert this to bool. > >> + struct mm_struct *mm = vma->vm_mm; >> + int ref_count, map_count; >> + >> + /* >> + * Synchronize with gup_pte_range(): >> + * - clear PTE; barrier; read refcount >> + * - inc refcount; barrier; read PTE >> + */ >> + smp_mb(); >> + >> + ref_count = folio_ref_count(folio); >> + map_count = folio_mapcount(folio); >> + >> + /* >> + * Order reads for page refcount and dirty flag >> + * (see comments in __remove_mapping()). >> + */ >> + smp_rmb(); >> + >> + if (folio_test_dirty(folio) && !(vma->vm_flags & VM_DROPPABLE)) { >> + /* >> + * redirtied either using the page table or a previously >> + * obtained GUP reference. >> + */ >> + set_ptes(mm, address, ptep, pteval, nr_pages); >> + folio_set_swapbacked(folio); >> + return 1; >> + } >> + >> + if (ref_count != 1 + map_count) { >> + /* >> + * Additional reference. Could be a GUP reference or any >> + * speculative reference. GUP users must mark the folio >> + * dirty if there was a modification. This folio cannot be >> + * reclaimed right now either way, so act just like nothing >> + * happened. >> + * We'll come back here later and detect if the folio was >> + * dirtied when the additional reference is gone. >> + */ >> + set_ptes(mm, address, ptep, pteval, nr_pages); >> + return 1; >> + } >> + >> + add_mm_counter(mm, MM_ANONPAGES, -nr_pages); >> + return 0; >> +} >> + >> /* >> * @arg: enum ttu_flags will be passed to this argument >> */ >> @@ -2227,46 +2278,10 @@ static bool try_to_unmap_one(struct folio *folio, struct vm_area_struct *vma, >> >> /* MADV_FREE page check */ >> if (!folio_test_swapbacked(folio)) { >> - int ref_count, map_count; >> - >> - /* >> - * Synchronize with gup_pte_range(): >> - * - clear PTE; barrier; read refcount >> - * - inc refcount; barrier; read PTE >> - */ >> - smp_mb(); >> - >> - ref_count = folio_ref_count(folio); >> - map_count = folio_mapcount(folio); >> - >> - /* >> - * Order reads for page refcount and dirty flag >> - * (see comments in __remove_mapping()). >> - */ >> - smp_rmb(); >> - >> - if (folio_test_dirty(folio) && !(vma->vm_flags & VM_DROPPABLE)) { >> - /* >> - * redirtied either using the page table or a previously >> - * obtained GUP reference. >> - */ >> - set_ptes(mm, address, pvmw.pte, pteval, nr_pages); >> - folio_set_swapbacked(folio); >> + if (commit_ttu_lazyfree_folio(vma, folio, address, >> + pvmw.pte, pteval, >> + nr_pages)) > > With above corrections this would be: > > if (!lazyfree_range(vma, folio, address, pvme.pte, pteval, nr_pages)) > ... > >> goto walk_abort; >> - } else if (ref_count != 1 + map_count) { >> - /* >> - * Additional reference. Could be a GUP reference or any >> - * speculative reference. GUP users must mark the folio >> - * dirty if there was a modification. This folio cannot be >> - * reclaimed right now either way, so act just like nothing >> - * happened. >> - * We'll come back here later and detect if the folio was >> - * dirtied when the additional reference is gone. >> - */ >> - set_ptes(mm, address, pvmw.pte, pteval, nr_pages); >> - goto walk_abort; >> - } >> - add_mm_counter(mm, MM_ANONPAGES, -nr_pages); >> goto discard; >> } >> >> -- >> 2.34.1 >> > > Thanks, Lorenzo >