From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932748AbcFTSfm (ORCPT ); Mon, 20 Jun 2016 14:35:42 -0400 Received: from mout.kundenserver.de ([217.72.192.75]:60918 "EHLO mout.kundenserver.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753721AbcFTSf3 (ORCPT ); Mon, 20 Jun 2016 14:35:29 -0400 From: Arnd Bergmann To: paulmck@linux.vnet.ibm.com Cc: Boqun Feng , Josh Triplett , linux-kernel@vger.kernel.org Subject: Re: [PATCH] torture: use ktime_t consistently Date: Mon, 20 Jun 2016 20:29:48 +0200 Message-ID: <7277827.7A0WjZ9kZU@wuerfel> User-Agent: KMail/5.1.3 (Linux/4.4.0-22-generic; KDE/5.18.0; x86_64; ; ) In-Reply-To: <20160620182105.GV3923@linux.vnet.ibm.com> References: <20160620155651.2497676-1-arnd@arndb.de> <20160620182105.GV3923@linux.vnet.ibm.com> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" X-Provags-ID: V03:K0:KlEnpJehZpOAqoTYyG/UeI8Fts8hTNCZdbvJ15pXoEXMwYitthG SEmQDYu9aw9XUC9SvpAh7Oy1iP+iKn2NhkSvitQ0Kj8wf+UPiFojy8O1hxOf9OsyUEroYJF yiMCA7BsIO1OjK02qH4FkvvOGymiV4z6cyFII6nLFswC5CfhNzjpZDskt10Sa90ThXhcR1B Ht1E+tL1ZVpCTEhvG/r0Q== X-UI-Out-Filterresults: notjunk:1;V01:K0:18u3khAe9ZU=:tWNOPxX/lOCIO6WrwSt7oJ 7ZQNUmpY26wCJSC2tMY5Z7L+X0Aj3QoNkYQDlTMVAxw6/k0hAq8XWbBAQgVo6T1rFs0MzUWoP bT+DsQw4/pz8rgQSPwhRYH8K0xS6q4O47vKsW6pb8lTB2e9gOhQ6AzXcBj5Hi91NZidxb+W2F 4BkyJi+yyvsu880m0o5HV1boHAKsdskgy53JhzUIGMZGR1m71OksDwVVl/mj+ontEfFXp4QR7 wH6nvGd7B1nyy6Pr+07qlTPq+WMvMtgHzXKEf24FTxt8evWhnR8QJF1il8QqX+9OBlNyTBrFJ cxqXfQR93wgGrShAjt6SjtxVLYnwVYXX2JqOwsRLu5MnuAQnr8Nyy01AFwz7Cg3VRRKGAcP+e Fz86W5+mXQpk+BVws2MVzW5Lpjya984P45HzuItSUP9fGqW0bnGneu0rdmSs1K0nIi2+Qvcjf bJ6/09mUpRCpWZ1Wz2kaf8Pj/Sm53Pq7Wiy8nJ+CscIR4lLuvBo4dYMYI53t0Gk8JDYMFKg/W 2LldaoVEQCfPxvZlNLCL68TgU60juimIbr4yIINMHxXUBmGJWNb/AGThqQjX+3qhWbct7IMks k7AEww7+z5+tyRpMEGijgn8NBVfSA4wtdGEIhZ8jXuFVJIhHwOyFVSd6n2ckTvJfOoz0NEAHt ZdER902LmVqV0UTSDauj5JW5O7bfEbJG5Di2zXAieC5v/kV7z7cbRnJLVk5tvA2/M9uXqovET nyUpQajP/v42ldnL Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Monday, June 20, 2016 11:21:05 AM CEST Paul E. McKenney wrote: > On Mon, Jun 20, 2016 at 05:56:40PM +0200, Arnd Bergmann wrote: > > @@ -446,9 +447,9 @@ EXPORT_SYMBOL_GPL(torture_shuffle_cleanup); > * Variables for auto-shutdown. This allows "lights out" torture runs > * to be fully scripted. > */ > -static int shutdown_secs; /* desired test duration in seconds. */ > +static ktime_t shutdown_ms; /* desired test duration in seconds. */ the variable name is a bit odd. > @@ -511,10 +513,10 @@ int torture_shutdown_init(int ssecs, void (*cleanup)(void)) > { > int ret = 0; > > - shutdown_secs = ssecs; > torture_shutdown_hook = cleanup; > - if (shutdown_secs > 0) { > - shutdown_time = jiffies + shutdown_secs * HZ; > + if (ssecs > 0) { > + shutdown_ms = ms_to_ktime(ssecs * 1000ULL); > + shutdown_time = ktime_add(ktime_get(), shutdown_ms); > ret = torture_create_kthread(torture_shutdown, NULL, > shutdown_task); and I picked ktime_set(ssecs, 0) instead of ms_to_ktime(ssecs * 1000ULL), but both differences are just cosmetic and should end up in exactly the same object code that I suggested. Unless we both made the same mistake, your version should be good too. Thanks, Arnd