From: Manisha Singh <masingh.linux@gmail.com>
To: Philipp Hortmann <philipp.g.hortmann@gmail.com>,
florian.c.schilhabel@googlemail.com, gregkh@linuxfoundation.org,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 1/2] staging: rtl8712: Fix style issues in rtl871x_io.c
Date: Thu, 29 Aug 2024 03:04:36 +0530 [thread overview]
Message-ID: <7423460a-ff73-44c1-864e-2dafe31b1c7c@gmail.com> (raw)
In-Reply-To: <607b86cd-d89a-4072-af36-ce2ce5c1f7fe@gmail.com>
On 8/29/24 02:38, Philipp Hortmann wrote:
> On 8/28/24 22:45, Manisha Singh wrote:
>> Remove multiple assignments from a line
>>
>> CHECK: multiple assignments should be avoided
>> + pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct
>> intf_priv),
>>
>
> Hi Manisha,
> please remove the 4 upper lines of the description. They are not
> required.
Sure.
>> Refactor the _init_intf_hdl() function to avoid multiple
>> assignments in a single statement. This change improves code readability
>> and adheres to kernel coding style guidelines.
>>
>> Signed-off-by: Manisha Singh <masingh.linux@gmail.com>
>> ---
>> Changes Since V1:
>> Broke the patch into 2 different fixes
>>
>> drivers/staging/rtl8712/rtl871x_io.c | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/staging/rtl8712/rtl871x_io.c
>> b/drivers/staging/rtl8712/rtl871x_io.c
>> index 6789a4c98564..6311ac15c581 100644
>> --- a/drivers/staging/rtl8712/rtl871x_io.c
>> +++ b/drivers/staging/rtl8712/rtl871x_io.c
>> @@ -48,10 +48,10 @@ static uint _init_intf_hdl(struct _adapter
>> *padapter,
>> set_intf_funs = &(r8712_usb_set_intf_funs);
>> set_intf_ops = &r8712_usb_set_intf_ops;
>> init_intf_priv = &r8712_usb_init_intf_priv;
>> - pintf_priv = pintf_hdl->pintfpriv = kmalloc(sizeof(struct
>> intf_priv),
>> - GFP_ATOMIC);
>> + pintf_priv = kmalloc(sizeof(struct intf_priv), GFP_ATOMIC);
>> if (!pintf_priv)
>> goto _init_intf_hdl_fail;
>
> By pushing the below statement after the "if (!pintf_priv)" you change
> the logic. Is this really wanted? Why do you think it is better? I
> would avoid this and it would be a separate patch anyhow.
>
>> + pintf_hdl->pintfpriv = pintf_priv;
>
> Thanks for your support.
>
> Bye Philipp
Yeah, I shouldn't have changed the logic. I don't have hardware to test
it, Let's move the assignment before the condition.
Thanks,
Manisha
>
>> pintf_hdl->adapter = (u8 *)padapter;
>> set_intf_option(&pintf_hdl->intf_option);
>> set_intf_funs(pintf_hdl);
>
next prev parent reply other threads:[~2024-08-28 21:34 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-08-28 20:45 Manisha Singh
2024-08-28 20:45 ` [PATCH v2 2/2] staging: rtl8712: Calculate size from pointer Manisha Singh
2024-08-28 21:15 ` Philipp Hortmann
2024-08-28 21:31 ` Manisha Singh
2024-08-28 21:08 ` [PATCH v2 1/2] staging: rtl8712: Fix style issues in rtl871x_io.c Philipp Hortmann
2024-08-28 21:34 ` Manisha Singh [this message]
2024-08-29 9:36 ` Dan Carpenter
2024-08-29 18:59 ` Philipp Hortmann
2024-08-29 19:34 ` Dan Carpenter
2024-09-01 8:36 ` Manisha Singh
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7423460a-ff73-44c1-864e-2dafe31b1c7c@gmail.com \
--to=masingh.linux@gmail.com \
--cc=florian.c.schilhabel@googlemail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=philipp.g.hortmann@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®