From: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
To: Andrew Davis <afd@ti.com>, Markus Schneider-Pargmann <msp@baylibre.com>
Cc: Lee Jones <lee@kernel.org>, Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Siddharth Vadapalli <s-vadapalli@ti.com>,
Nishanth Menon <nm@ti.com>, Vignesh Raghavendra <vigneshr@ti.com>,
Tero Kristo <kristo@kernel.org>,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 2/5] dt-bindings: mfd: syscon: Add ti,am62-ddr-pmctrl
Date: Mon, 27 Jan 2025 13:09:49 +0100 [thread overview]
Message-ID: <74ee6d9b-fd78-4d8a-a94f-b2c4dc794b60@linaro.org> (raw)
In-Reply-To: <d6252b73-0bcc-4724-8144-d6a98c8980f8@ti.com>
On 24/01/2025 23:35, Andrew Davis wrote:
> On 1/24/25 10:48 AM, Krzysztof Kozlowski wrote:
>> On 24/01/2025 17:05, Markus Schneider-Pargmann wrote:
>>> Hi Krzysztof,
>>>
>>> On Fri, Jan 24, 2025 at 09:22:54AM +0100, Krzysztof Kozlowski wrote:
>>>> On Fri, Jan 24, 2025 at 09:19:49AM +0100, Krzysztof Kozlowski wrote:
>>>>> On Wed, Jan 22, 2025 at 11:24:33AM +0100, Markus Schneider-Pargmann wrote:
>>>>>> Add compatible for ti,am62-ddr-pmctrl to the list. There is a DDR pmctrl
>>>>>> register in the wkup-conf register space of am62a and am62p. This
>>>>>> register controls DDR power management.
>>>>>>
>>>>>> Signed-off-by: Markus Schneider-Pargmann <msp@baylibre.com>
>>>>>> ---
>>>>>> Documentation/devicetree/bindings/mfd/syscon.yaml | 2 ++
>>>>>> 1 file changed, 2 insertions(+)
>>>>>
>>>>> Acked-by: Krzysztof Kozlowski <krzysztof.kozlowski@linaro.org>
>>>>
>>>> Un-acked, I missed the point that you really speak in commit msg about
>>>> register and you really treat one register is a device. I assumed you
>>>> only need that register from this device, but no. That obviously is not
>>>> what this device is. Device is not a single register among 10000 others.
>>>> IOW, You do not have 10000 devices there.
>>>
>>> Do I understand you correctly that the whole register range of the
>>> wkup_conf node as seen in arch/arm64/boot/dts/ti/k3-am62a-wakeup.dtsi
>>> should be considered a single syscon device?
>>
>> I don't have the datasheets (and not my task to actually check this),
>> but you should probably follow datasheet. I assume it describes what is
>> the device, more or less.
>>
>> I assume entire wkup_conf is considered a device.
>>
>>>
>>> Unfortunately wkup_conf is modeled as a simple-bus with currently 5
>>> subnodes defined of which 4 of them consist of a single register. Most
>>> of them are syscon as well. So I think I can't change the simple-bus
>>> back to syscon.
>>
>> Huh... Maybe TI folks will help us understand why such design was chosen.
>>
>
> Many of the devices inside the wkup_conf are already modeled as such.
> Clocks and muxes for instance already have drivers and bindings, this
> is nothing new to TI.
>
> If we just use a blank "syscon" over the entire region we would end up
> with drivers that use phandles to the top level wkup_conf node and
> poke directly the registers they need from that space.
>
> Would you rather have
>
> some-device {
> ti,epwm_tbclk = <&wkup_conf>;
> }
>
> or
>
> some-device {
> clocks = <&epwm_tbclk 0>;
> }
How is this comparable? These are clocks. You would have clocks property
in both cases.
>
> with that epwm_tbclk being a proper clock node inside wkup_conf?
> I would much prefer the second, even though the clock node
> only uses a single register. And in the first case, we would need
> to have the offset into the wkup_conf space hard-coded in the
> driver for each new SoC. Eventually all that data would need to be
> put in tables and we end up back to machine board files..
>
> I'm not saying every magic number in all drivers should
> be offloaded into DT, but there is a line somewhere between
> that and having the DT simply contain the SoC's name compatible
That's not the question here.
> and all other data going into the kernel. That line might be a
> personal preference, so my question back is: what is wrong
> if we do want "1000 new syscons per each register" for our
> SoCs DT?
Because it is false representation of hardware. You do not have 1000
devices. You have only one device.
>
> (and the number is not 1000, scanning the kernel I can see
> the largest wkup_conf region node we have today has a grand
> total number sub-nodes of 6)
But what is being added here is device per each register, not per feature.
Best regards,
Krzysztof
next prev parent reply other threads:[~2025-01-27 12:09 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-22 10:24 [PATCH 0/5] arm64: dts: ti: k3-am62a/p: Add ddr-pmctrl, canuart-wake Markus Schneider-Pargmann
2025-01-22 10:24 ` [PATCH 1/5] dt-bindings: mfd: syscon: Add ti,j784s4-acspcie-proxy-ctrl to second list Markus Schneider-Pargmann
2025-01-22 10:34 ` Siddharth Vadapalli
2025-01-22 10:24 ` [PATCH 2/5] dt-bindings: mfd: syscon: Add ti,am62-ddr-pmctrl Markus Schneider-Pargmann
2025-01-24 8:19 ` Krzysztof Kozlowski
2025-01-24 8:22 ` Krzysztof Kozlowski
2025-01-24 16:05 ` Markus Schneider-Pargmann
2025-01-24 16:48 ` Krzysztof Kozlowski
2025-01-24 22:35 ` Andrew Davis
2025-01-27 12:09 ` Krzysztof Kozlowski [this message]
2025-02-07 14:40 ` Markus Schneider-Pargmann
2025-02-09 12:21 ` Krzysztof Kozlowski
2025-02-10 10:35 ` Markus Schneider-Pargmann
2025-02-12 19:35 ` Krzysztof Kozlowski
2025-04-09 17:39 ` Andrew Davis
2025-04-15 5:17 ` Krzysztof Kozlowski
2025-04-21 17:03 ` Andrew Davis
2025-04-22 16:12 ` David Lechner
2025-04-22 16:45 ` Andrew Davis
2025-04-23 12:07 ` Krzysztof Kozlowski
2025-04-23 14:30 ` Andrew Davis
2025-01-22 10:24 ` [PATCH 3/5] dt-bindings: mfd: syscon: Add ti,am62-canuart-wake compatible Markus Schneider-Pargmann
2025-01-24 8:21 ` Krzysztof Kozlowski
2025-01-22 10:24 ` [PATCH 4/5] arm64: dts: ti: k3-am62a-wakeup: Add ddr-pmctrl, canuart-wake Markus Schneider-Pargmann
2025-01-24 8:20 ` Krzysztof Kozlowski
2025-01-22 10:24 ` [PATCH 5/5] arm64: dts: ti: k3-am62p-j722s-common-wakeup: " Markus Schneider-Pargmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=74ee6d9b-fd78-4d8a-a94f-b2c4dc794b60@linaro.org \
--to=krzysztof.kozlowski@linaro.org \
--cc=afd@ti.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=kristo@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=lee@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=msp@baylibre.com \
--cc=nm@ti.com \
--cc=robh@kernel.org \
--cc=s-vadapalli@ti.com \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®