From: "Dingyan Li" <18500469033@163.com>
To: "Alan Stern" <stern@rowland.harvard.edu>
Cc: gregkh@linuxfoundation.org, hdegoede@redhat.com,
xiaofanc@gmail.com, oneukum@suse.com, lists.tormod@gmail.com,
sebastian.reichel@collabora.com, linux-usb@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re:Re: [PATCH v2] USB: Support 20Gbps speed for ioctl USBDEVFS_GET_SPEED
Date: Sun, 20 Aug 2023 13:29:11 +0800 (CST) [thread overview]
Message-ID: <75cfc7cb.b4c.18a116b2e2e.Coremail.18500469033@163.com> (raw)
In-Reply-To: <07c821ae-2391-474c-aec9-65f47d3fecf2@rowland.harvard.edu>
At 2023-08-20 03:03:05, "Alan Stern" <stern@rowland.harvard.edu> wrote:
>
>This would make more sense if you kept very clear the distinction
>between the overall speed and the physical communication mechanism. In
>other words, 10000 bps is 10000 bps, no matter whether the underlying
>technology uses one lane carrying 10000 bits per second or two lanes
>each carrying 5000 bits per second.
>
>I'm not sure if anything in the kernel or userspace really cares about
>the number of lanes, as opposed to the total speed. If it turns out
>that nothing does, the usb_ssp_rate enumeration could be removed.
>Besides, it should named something else, like usb_ssp_gen or
>usb_sp_generation, since it isn't just a rate designation. (Whereas as
>enum usb_device_speed _is_ just a rate designation.)
It seems that dwc3 code has a slightly different behaviors between
GEN_1x2 and GEN_2x1, so it's better to keep it. But I agree with you.
In enum usb_device_speed, we only care about overall speed instead of
physical links. And we could rename usb_ssp_rate to a more proper name.
>Regardless of what happens to usb_ssp_rate, usb_device_speed should be
>enlarged to encompass all possible existing speeds. That would
>immediately fix the ioctl problem. Doing this in an upward-compatible
>way might end up being a little awkward but it ought to be possible.
Thanks for the detailed explanation, which makes things more clear.
I'll take your suggestions and try again.
Regards,
Dingyan
next prev parent reply other threads:[~2023-08-20 6:03 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-07-21 8:40 [PATCH] USB: add usbfs ioctl to get specific superspeedplus rates Dingyan Li
2023-07-21 11:04 ` Greg KH
[not found] ` <550dbb46.5bc4.189785b0360.Coremail.18500469033@163.com>
2023-07-21 12:11 ` Greg KH
2023-07-21 12:35 ` Dingyan Li
2023-07-21 14:51 ` Greg KH
2023-07-21 15:43 ` Dingyan Li
2023-07-21 17:26 ` Alan Stern
2023-07-24 9:47 ` Oliver Neukum
2023-07-25 13:24 ` Greg KH
2023-07-25 13:54 ` Dingyan Li
2023-07-25 14:08 ` Oliver Neukum
2023-07-25 14:40 ` Dingyan Li
2023-07-25 15:12 ` Greg KH
2023-07-25 16:11 ` Dingyan Li
2023-07-26 8:33 ` Oliver Neukum
2023-07-26 9:36 ` Dingyan Li
2023-07-26 9:49 ` Oliver Neukum
2023-07-26 10:10 ` Dingyan Li
2023-07-26 1:37 ` Xiaofan Chen
2023-07-26 9:38 ` Oliver Neukum
2023-07-26 3:20 ` Xiaofan Chen
2023-07-26 14:39 ` Hans de Goede
2023-08-03 6:13 ` Dingyan Li
2023-08-03 15:10 ` Alan Stern
2023-08-03 15:39 ` Hans de Goede
2023-08-03 16:06 ` Dingyan Li
2023-08-03 17:56 ` Alan Stern
2023-08-04 4:16 ` Dingyan Li
2023-08-04 14:55 ` Alan Stern
2023-08-19 4:32 ` Dingyan Li
2023-08-19 5:46 ` [PATCH v2] USB: Support 20Gbps speed for ioctl USBDEVFS_GET_SPEED Dingyan Li
2023-08-19 19:03 ` Alan Stern
2023-08-20 5:29 ` Dingyan Li [this message]
2023-08-19 18:46 ` Re: Re: Re: [PATCH] USB: add usbfs ioctl to get specific superspeedplus rates Alan Stern
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=75cfc7cb.b4c.18a116b2e2e.Coremail.18500469033@163.com \
--to=18500469033@163.com \
--cc=gregkh@linuxfoundation.org \
--cc=hdegoede@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=lists.tormod@gmail.com \
--cc=oneukum@suse.com \
--cc=sebastian.reichel@collabora.com \
--cc=stern@rowland.harvard.edu \
--cc=xiaofanc@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®