From: Konrad Dybcio <konrad.dybcio@linaro.org>
To: Neil Armstrong <neil.armstrong@linaro.org>,
Andy Gross <agross@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Mathieu Poirier <mathieu.poirier@linaro.org>,
Rob Herring <robh+dt@kernel.org>,
Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
Conor Dooley <conor+dt@kernel.org>,
Manivannan Sadhasivam <mani@kernel.org>
Cc: linux-arm-msm@vger.kernel.org, linux-remoteproc@vger.kernel.org,
devicetree@vger.kernel.org, linux-kernel@vger.kernel.org,
Mukesh Ojha <quic_mojha@quicinc.com>
Subject: Re: [PATCH v4 2/3] remoteproc: qcom: pas: make region assign more generic
Date: Sat, 9 Dec 2023 19:06:12 +0100 [thread overview]
Message-ID: <76f18323-a59e-4724-96ec-6306e5dcd2dc@linaro.org> (raw)
In-Reply-To: <20231208-topic-sm8650-upstream-remoteproc-v4-2-a96c3e5f0913@linaro.org>
On 8.12.2023 16:04, Neil Armstrong wrote:
> The current memory region assign only supports a single
> memory region.
>
> But new platforms introduces more regions to make the
> memory requirements more flexible for various use cases.
> Those new platforms also shares the memory region between the
> DSP and HLOS.
>
> To handle this, make the region assign more generic in order
> to support more than a single memory region and also permit
> setting the regions permissions as shared.
>
> Reviewed-by: Mukesh Ojha <quic_mojha@quicinc.com>
> Signed-off-by: Neil Armstrong <neil.armstrong@linaro.org>
> ---
[...]
> + for (offset = 0; offset < adsp->region_assign_count; ++offset) {
> + struct reserved_mem *rmem = NULL;
> +
> + node = of_parse_phandle(adsp->dev->of_node, "memory-region",
> + adsp->region_assign_idx + offset);
> + if (node)
> + rmem = of_reserved_mem_lookup(node);
> + of_node_put(node);
Shouldn't this only be called when parse_phandle succeeds? (separate
patch with a fix + cc stable if so?)
> + if (!rmem) {
> + dev_err(adsp->dev, "unable to resolve shareable memory-region index %d\n",
> + offset);
> + return -EINVAL;
> + }
>
> - perm.vmid = QCOM_SCM_VMID_MSS_MSA;
> - perm.perm = QCOM_SCM_PERM_RW;
> + if (adsp->region_assign_shared) {
> + perm[0].vmid = QCOM_SCM_VMID_HLOS;
> + perm[0].perm = QCOM_SCM_PERM_RW;
> + perm[1].vmid = adsp->region_assign_vmid;
> + perm[1].perm = QCOM_SCM_PERM_RW;
> + perm_size = 2;
> + } else {
> + perm[0].vmid = adsp->region_assign_vmid;
> + perm[0].perm = QCOM_SCM_PERM_RW;
> + perm_size = 1;
> + }
>
> - adsp->region_assign_phys = rmem->base;
> - adsp->region_assign_size = rmem->size;
> - adsp->region_assign_perms = BIT(QCOM_SCM_VMID_HLOS);
> + adsp->region_assign_phys[offset] = rmem->base;
> + adsp->region_assign_size[offset] = rmem->size;
> + adsp->region_assign_perms[offset] = BIT(QCOM_SCM_VMID_HLOS);
>
> - ret = qcom_scm_assign_mem(adsp->region_assign_phys,
> - adsp->region_assign_size,
> - &adsp->region_assign_perms,
I think this should be renamed to region_assign_owner(s)
> - &perm, 1);
> - if (ret < 0) {
> - dev_err(adsp->dev, "assign memory failed\n");
> - return ret;
> + ret = qcom_scm_assign_mem(adsp->region_assign_phys[offset],
> + adsp->region_assign_size[offset],
> + &adsp->region_assign_perms[offset],
> + perm, perm_size);
> + if (ret < 0) {
> + dev_err(adsp->dev, "assign memory %d failed\n", offset);
> + return ret;
> + }
> }
>
> return 0;
> @@ -629,20 +653,23 @@ static int adsp_assign_memory_region(struct qcom_adsp *adsp)
> static void adsp_unassign_memory_region(struct qcom_adsp *adsp)
> {
> struct qcom_scm_vmperm perm;
> + int offset;
> int ret;
>
> - if (!adsp->region_assign_idx)
> + if (!adsp->region_assign_idx || adsp->region_assign_shared)
So when it's *shared*, we don't want to un-assign it?
Konrad
next prev parent reply other threads:[~2023-12-09 18:14 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-08 15:04 [PATCH v4 0/3] remoteproc: qcom: Introduce DSP support for SM8650 Neil Armstrong
2023-12-08 15:04 ` [PATCH v4 1/3] dt-bindings: remoteproc: qcom,sm8550-pas: document the SM8650 PAS Neil Armstrong
2023-12-08 15:04 ` [PATCH v4 2/3] remoteproc: qcom: pas: make region assign more generic Neil Armstrong
2023-12-09 18:06 ` Konrad Dybcio [this message]
2023-12-11 9:37 ` Neil Armstrong
2023-12-11 9:54 ` Konrad Dybcio
2023-12-11 11:19 ` neil.armstrong
2023-12-08 15:04 ` [PATCH v4 3/3] remoteproc: qcom: pas: Add SM8650 remoteproc support Neil Armstrong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=76f18323-a59e-4724-96ec-6306e5dcd2dc@linaro.org \
--to=konrad.dybcio@linaro.org \
--cc=agross@kernel.org \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=krzysztof.kozlowski+dt@linaro.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-remoteproc@vger.kernel.org \
--cc=mani@kernel.org \
--cc=mathieu.poirier@linaro.org \
--cc=neil.armstrong@linaro.org \
--cc=quic_mojha@quicinc.com \
--cc=robh+dt@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®