From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752193AbdATPA6 (ORCPT ); Fri, 20 Jan 2017 10:00:58 -0500 Received: from mx2.suse.de ([195.135.220.15]:60618 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752352AbdATPA4 (ORCPT ); Fri, 20 Jan 2017 10:00:56 -0500 Subject: Re: [PATCH] md/bitmap: use i_blocksize() To: Geliang Tang , Shaohua Li References: <0a58b38c7ddfbbc8f56cb8d815114bd4357a6016.1484895399.git.geliangtang@gmail.com> <2e7ac27f6ca34bfa01f3b6906fdf409c348e9187.1484895660.git.geliangtang@gmail.com> Cc: linux-raid@vger.kernel.org, linux-kernel@vger.kernel.org From: Coly Li Message-ID: <775e1272-2746-9a45-01ef-7d35eff8dbdb@suse.de> Date: Fri, 20 Jan 2017 23:00:39 +0800 User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:45.0) Gecko/20100101 Thunderbird/45.6.0 MIME-Version: 1.0 In-Reply-To: <2e7ac27f6ca34bfa01f3b6906fdf409c348e9187.1484895660.git.geliangtang@gmail.com> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2017/1/20 下午10:29, Geliang Tang wrote: > Since i_blocksize() helper has been defined in fs.h, use it instead > of open-coding. > > Signed-off-by: Geliang Tang > --- > drivers/md/bitmap.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/md/bitmap.c b/drivers/md/bitmap.c > index 9fb2cca..30b1b89 100644 > --- a/drivers/md/bitmap.c > +++ b/drivers/md/bitmap.c > @@ -367,7 +367,7 @@ static int read_page(struct file *file, unsigned long index, > pr_debug("read bitmap file (%dB @ %llu)\n", (int)PAGE_SIZE, > (unsigned long long)index << PAGE_SHIFT); > > - bh = alloc_page_buffers(page, 1<i_blkbits, 0); > + bh = alloc_page_buffers(page, i_blocksize(inode), 0); > if (!bh) { > ret = -ENOMEM; > goto out; > @@ -385,10 +385,10 @@ static int read_page(struct file *file, unsigned long index, > goto out; > } > bh->b_bdev = inode->i_sb->s_bdev; > - if (count < (1<i_blkbits)) > + if (count < i_blocksize(inode)) > count = 0; > else > - count -= (1<i_blkbits); > + count -= i_blocksize(inode); > > bh->b_end_io = end_bitmap_write; > bh->b_private = bitmap; > Acked-by: Coly Li I agree with this. Thanks. Coly