From: Kumar Gala <galak@kernel.crashing.org>
To: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Cc: beckyb@kernel.crashing.org, linux-kernel@vger.kernel.org,
mingo@elte.hu, jeremy@goop.org, ian.campbell@citrix.com
Subject: Re: [PATCH 5/7] swiotlb: (re)Create swiotlb_unmap_single
Date: Tue, 7 Apr 2009 11:50:56 -0500 [thread overview]
Message-ID: <77EA4458-602F-4DA9-B7E7-E48B5B0DCF91@kernel.crashing.org> (raw)
In-Reply-To: <20090408013700L.fujita.tomonori@lab.ntt.co.jp>
On Apr 7, 2009, at 11:37 AM, FUJITA Tomonori wrote:
> On Tue, 7 Apr 2009 10:32:20 -0500
> Kumar Gala <galak@kernel.crashing.org> wrote:
>
>>
>> On Apr 7, 2009, at 4:09 AM, FUJITA Tomonori wrote:
>>
>>> On Tue, 7 Apr 2009 01:34:44 -0500
>>> Kumar Gala <galak@kernel.crashing.org> wrote:
>>>
>>>>
>>>> On Apr 6, 2009, at 9:24 PM, FUJITA Tomonori wrote:
>>>>
>>>>> On Fri, 3 Apr 2009 20:56:47 -0500
>>>>> Becky Bruce <beckyb@kernel.crashing.org> wrote:
>>>>>
>>>>>> This mirrors the current swiotlb_sync_single() setup
>>>>>> where the swiotlb_unmap_single() function is static to this
>>>>>> file and contains the logic required to determine if we need
>>>>>> to call actual sync_single. Previously, swiotlb_unmap_page
>>>>>> and swiotlb_unmap_sg were duplicating very similar code.
>>>>>> The duplicated code has also been reformatted for
>>>>>> readability.
>>>>>>
>>>>>> Note that the swiotlb_unmap_sg code was previously doing
>>>>>> a complicated comparison to determine if an addresses needed
>>>>>> to be unmapped where a simple is_swiotlb_buffer() call
>>>>>> would have sufficed.
>>>>>>
>>>>>> Signed-off-by: Becky Bruce <beckyb@kernel.crashing.org>
>>>>>> ---
>>>>>> lib/swiotlb.c | 36 +++++++++++++++++++++++-------------
>>>>>> 1 files changed, 23 insertions(+), 13 deletions(-)
>>>>>>
>>>>>> diff --git a/lib/swiotlb.c b/lib/swiotlb.c
>>>>>> index af2ec25..602315b 100644
>>>>>> --- a/lib/swiotlb.c
>>>>>> +++ b/lib/swiotlb.c
>>>>>
>>>>> I don't think 'swiotlb_unmap_single' name is appropriate.
>>>>>
>>>>> swiotlb_unmap_single sounds like an exported function that IOMMUs
>>>>> can
>>>>> use (and it was) however it should not be.
>>>>
>>>> What do you suggest we call it? __swiotlb_unmap_single.
>>>
>>> I think that __swiotlb_unmap_single is better because the name
>>> implies
>>> that it's an internal function. It's fine by me.
>>>
>>> If it is odd that __swiotlb_unmap_single() is just a wrapper
>>> function
>>> of unmap_single(), which does the real job to unmap a dma mapping,
>>> it
>>> might be another possible option to rename unmap_single to
>>> do_unamp_single and use unmap_single.
>>
>> I think you lost me here. I'd prefer to just use
>> __swiotlb_unmap_single at this point and get this code into the tree
>> and work on such renaming after the fact (if that's ok).
>
> If you are rushing to merge this right now, the original patchset is
> fine by me (I thought that you missed this merge window). I'll rename
> it later.
We probably did, but one can never tell with these things. It seemed
like Ingo merged and pushed some swiotlb changes late in the game for .
29
I'm still not clear on what you are suggesting... "rename unmap_single
to do_unamp_single and use unmap_single".
- k
next prev parent reply other threads:[~2009-04-07 16:52 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-04 1:56 [PATCH V2 0/7] swiotlb: changes for powerpc/highmem Becky Bruce
2009-04-04 1:56 ` [PATCH 1/7] swiotlb: comment corrections (no code changes) Becky Bruce
2009-04-04 1:56 ` [PATCH 2/7] swiotlb: fix compile warning Becky Bruce
2009-04-04 1:56 ` [PATCH 3/7] swiotlb: map_page fix for highmem systems Becky Bruce
2009-04-04 1:56 ` [PATCH 4/7] swiotlb: Allow arch override of address_needs_mapping Becky Bruce
2009-04-04 1:56 ` [PATCH 5/7] swiotlb: (re)Create swiotlb_unmap_single Becky Bruce
2009-04-04 1:56 ` [PATCH 6/7] swiotlb: Use swiotlb_sync_single instead of duplicating code Becky Bruce
2009-04-04 1:56 ` [PATCH 7/7] swiotlb: Change swiotlb_bus_to[phys,virt] prototypes Becky Bruce
2009-04-07 2:24 ` [PATCH 5/7] swiotlb: (re)Create swiotlb_unmap_single FUJITA Tomonori
2009-04-07 6:34 ` Kumar Gala
2009-04-07 9:09 ` FUJITA Tomonori
2009-04-07 15:32 ` Kumar Gala
2009-04-07 16:37 ` FUJITA Tomonori
2009-04-07 16:50 ` Kumar Gala [this message]
2009-04-07 17:22 ` FUJITA Tomonori
2009-04-07 17:32 ` Kumar Gala
2009-04-07 18:18 ` FUJITA Tomonori
2009-04-08 12:43 ` Ingo Molnar
2009-04-08 13:35 ` Kumar Gala
2009-04-08 14:05 ` Ingo Molnar
2009-04-08 14:10 ` Kumar Gala
2009-04-07 2:24 ` [PATCH V2 0/7] swiotlb: changes for powerpc/highmem FUJITA Tomonori
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=77EA4458-602F-4DA9-B7E7-E48B5B0DCF91@kernel.crashing.org \
--to=galak@kernel.crashing.org \
--cc=beckyb@kernel.crashing.org \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=ian.campbell@citrix.com \
--cc=jeremy@goop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®