From: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
To: Oleksij Rempel <o.rempel@pengutronix.de>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Andrew Lunn <andrew+netdev@lunn.ch>,
Heiner Kallweit <hkallweit1@gmail.com>,
"Jonathan Corbet" <corbet@lwn.net>
Cc: <kernel@pengutronix.de>, <linux-kernel@vger.kernel.org>,
<netdev@vger.kernel.org>, Simon Horman <horms@kernel.org>,
Russell King <linux@armlinux.org.uk>,
Maxime Chevallier <maxime.chevallier@bootlin.com>,
<linux-doc@vger.kernel.org>
Subject: Re: [PATCH net-next v1 1/1] net: phy: Move callback comments from struct to kernel-doc section
Date: Tue, 10 Dec 2024 13:03:44 +0100 [thread overview]
Message-ID: <7801c223-b45f-4f21-9ba1-bddce2ab0d9e@intel.com> (raw)
In-Reply-To: <20241206113952.406311-1-o.rempel@pengutronix.de>
On 12/6/2024 12:39 PM, Oleksij Rempel wrote:
> Relocate all callback-related comments from the `struct phy_driver`
> definition to a dedicated `kernel-doc` section. This improves code
> readability by decluttering the structure definition and consolidating
> callback documentation in a central place for kernel-doc generation.
>
> No functional changes are introduced by this patch.
>
> Signed-off-by: Oleksij Rempel <o.rempel@pengutronix.de>
> ---
> include/linux/phy.h | 705 ++++++++++++++++++++++++++++++++------------
> 1 file changed, 522 insertions(+), 183 deletions(-)
[...]
Nice cleanup! The only nitpick is about the "Returns" statement in
functions. According to the kdoc it should be "Return:" . But
nevertheless it looks good, so:
Reviewed-by: Mateusz Polchlopek <mateusz.polchlopek@intel.com>
prev parent reply other threads:[~2024-12-10 12:04 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-12-06 11:39 Oleksij Rempel
2024-12-06 12:14 ` Russell King (Oracle)
2024-12-07 20:38 ` Andrew Lunn
2024-12-10 11:56 ` Paolo Abeni
2024-12-10 14:02 ` Russell King (Oracle)
2024-12-10 14:37 ` Jakub Kicinski
2024-12-16 12:20 ` Oleksij Rempel
2024-12-17 1:53 ` Jakub Kicinski
2024-12-17 5:40 ` Oleksij Rempel
2024-12-17 15:03 ` Jakub Kicinski
2025-01-02 16:56 ` Russell King (Oracle)
2025-01-02 18:01 ` Jonathan Corbet
2025-01-02 18:28 ` Russell King (Oracle)
2024-12-10 12:03 ` Mateusz Polchlopek [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7801c223-b45f-4f21-9ba1-bddce2ab0d9e@intel.com \
--to=mateusz.polchlopek@intel.com \
--cc=andrew+netdev@lunn.ch \
--cc=corbet@lwn.net \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=hkallweit1@gmail.com \
--cc=horms@kernel.org \
--cc=kernel@pengutronix.de \
--cc=kuba@kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=maxime.chevallier@bootlin.com \
--cc=netdev@vger.kernel.org \
--cc=o.rempel@pengutronix.de \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®