mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Yury Norov <ynorov@caviumnetworks.com>
Cc: agk@redhat.com, Mike Snitzer <snitzer@redhat.com>,
	dm-devel@redhat.com, shli@kernel.org, linux-raid@vger.kernel.org,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	linux-input <linux-input@vger.kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Mika Westerberg <mika.westerberg@linux.intel.com>
Subject: Re: [PATCH v2 5/5] Input: evdev - Switch to bitmap_zalloc()
Date: Mon, 18 Jun 2018 08:49:37 -0700	[thread overview]
Message-ID: <780cba4e119110f2d2a81e237874592cff4d7868.camel@perches.com> (raw)
In-Reply-To: <8cfbdf809f531f8aa315fe1679c3273858038f41.camel@linux.intel.com>

On Mon, 2018-06-18 at 15:02 +0300, Andy Shevchenko wrote:
> On Sat, 2018-06-16 at 12:16 -0700, Joe Perches wrote:
> > On Sat, 2018-06-16 at 21:45 +0300, Andy Shevchenko wrote:
> > > On Sat, Jun 16, 2018 at 12:46 AM Yury Norov <ynorov@caviumnetworks.c
> > > om> wrote:
> > > > On Fri, Jun 15, 2018 at 04:20:17PM +0300, Andy Shevchenko wrote:
> > > > > Switch to bitmap_zalloc() to show clearly what we are
> > > > > allocating.
> > > > > Besides that it returns pointer of bitmap type instead of opaque
> > > > > void *.
> > > 
> > > 
> > > > > +       mem = bitmap_alloc(maxbit, GFP_KERNEL);
> > > > >         if (!mem)
> > > > >                 return -ENOMEM;
> > > > 
> > > > But in commit message you say you switch to bitmap_zalloc(). IIUC
> > > > bitmap_alloc() is OK here. But could you please update comment to
> > > > avoid confusing.
> > > 
> > > There are two places, one with alloc, another with zalloc.
> > > I will clarify this in commit message of next version.
> > > 
> > > > > +       mask = bitmap_zalloc(cnt, GFP_KERNEL);
> > > > >         if (!mask)
> > > > >                 return -ENOMEM;
> > > > > 
> > > > >         error = bits_from_user(mask, cnt - 1, codes_size, codes,
> > > > > compat);
> > > > 
> > > > If my understanding of bits_from_user() correct, here you can also
> > > > use
> > > > bitmap_alloc(), true?
> > 
> > Also it might be useful to have a separate bitmap_from_user
> > to alloc and copy.
> 
> Maybe. I didn't check if there are such users except this driver.
> 
> Anyway, it's out of scope of the series.

That seems incorrect as you are introducing alloc/free helpers.

Perhaps bitmap_dup_user [or some better name] could or should
be one of the helpers.


  reply	other threads:[~2018-06-18 15:49 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-06-15 13:20 [PATCH v2 0/5] bitmap: Introduce alloc/free helpers Andy Shevchenko
2018-06-15 13:20 ` [PATCH v2 1/5] md: Avoid namespace collision with bitmap API Andy Shevchenko
2018-06-15 15:09   ` kbuild test robot
2018-06-15 14:58     ` Andy Shevchenko
2018-06-18 13:36       ` Mike Snitzer
2018-06-15 15:19   ` kbuild test robot
2018-06-15 13:20 ` [PATCH v2 2/5] bitmap: Drop unnecessary 0 check for u32 array operations Andy Shevchenko
2018-06-15 13:20 ` [PATCH v2 3/5] bitmap: Add bitmap_alloc(), bitmap_zalloc() and bitmap_free() Andy Shevchenko
2018-06-15 22:23   ` Yury Norov
2018-06-16 18:42     ` Andy Shevchenko
2018-06-15 13:20 ` [PATCH v2 4/5] Input: gpio-keys - Switch to bitmap_zalloc() Andy Shevchenko
2018-06-15 22:06   ` Yury Norov
2018-06-16 18:50     ` Andy Shevchenko
2018-06-15 13:20 ` [PATCH v2 5/5] Input: evdev " Andy Shevchenko
2018-06-15 21:42   ` Yury Norov
2018-06-16 18:45     ` Andy Shevchenko
2018-06-16 19:16       ` Joe Perches
2018-06-18 12:02         ` Andy Shevchenko
2018-06-18 15:49           ` Joe Perches [this message]
2018-06-18 19:56             ` Andy Shevchenko
2018-06-18 20:40               ` Joe Perches
2018-06-19 18:33     ` Dmitry Torokhov
2018-06-20  8:13       ` Yury Norov
2018-06-20 20:26         ` Dmitry Torokhov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=780cba4e119110f2d2a81e237874592cff4d7868.camel@perches.com \
    --to=joe@perches.com \
    --cc=agk@redhat.com \
    --cc=akpm@linux-foundation.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=dm-devel@redhat.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=shli@kernel.org \
    --cc=snitzer@redhat.com \
    --cc=ynorov@caviumnetworks.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®