From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from foss.arm.com (foss.arm.com [217.140.110.172]) by smtp.subspace.kernel.org (Postfix) with ESMTP id 4565633C536 for ; Fri, 20 Feb 2026 10:38:28 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=217.140.110.172 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1771583910; cv=none; b=g3ZKHIKcG4hhjkKV/KQDUBMs1V80jkDfsHcoB6UOIKQAT1OTftuai/I4LucsBcr2wG+B0nQgsRygqRgQN6Gg51QgdFEUxX38edv2ISMQnzgW6QzAsW9lvhqcxmirf49B0jtsMnLYNf1AKpi8s9eeQVyDHlfywqgz1o+FvkRgFpg= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1771583910; c=relaxed/simple; bh=ycDE0IjRw6ohhP0he0RshLiDf9crCx+eyMTsO6S+Xp0=; h=Message-ID:Date:MIME-Version:Subject:To:Cc:References:From: In-Reply-To:Content-Type; b=X3Wl7XG4G88flDsqfGriooWemrUtqADX6zo2tiZOey7e2dbx9q9XUSeKtlwbskgi5v0hbPoG/XWZk36H13wp3mnp0/CHvErXootIz+FDTyJx5P5hH8BmBg1x5PJa+ffKHiz0mPLmx8YTLBIs1O5dSrzXcDVQVPUPXASH62/k1Wg= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com; spf=pass smtp.mailfrom=arm.com; arc=none smtp.client-ip=217.140.110.172 Authentication-Results: smtp.subspace.kernel.org; dmarc=pass (p=none dis=none) header.from=arm.com Authentication-Results: smtp.subspace.kernel.org; spf=pass smtp.mailfrom=arm.com Received: from usa-sjc-imap-foss1.foss.arm.com (unknown [10.121.207.14]) by usa-sjc-mx-foss1.foss.arm.com (Postfix) with ESMTP id 655DE497; Fri, 20 Feb 2026 02:38:21 -0800 (PST) Received: from [10.164.148.40] (unknown [10.164.148.40]) by usa-sjc-imap-foss1.foss.arm.com (Postfix) with ESMTPSA id 1EB303F62B; Fri, 20 Feb 2026 02:38:12 -0800 (PST) Message-ID: <784588bc-2071-4418-825b-9072cc3659e2@arm.com> Date: Fri, 20 Feb 2026 16:08:10 +0530 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Subject: Re: [PATCH mm-unstable v1 2/5] mm: introduce is_pmd_order helper To: Nico Pache , linux-kernel@vger.kernel.org, linux-mm@kvack.org Cc: aarcange@redhat.com, akpm@linux-foundation.org, anshuman.khandual@arm.com, apopple@nvidia.com, baohua@kernel.org, baolin.wang@linux.alibaba.com, byungchul@sk.com, catalin.marinas@arm.com, cl@gentwo.org, corbet@lwn.net, dave.hansen@linux.intel.com, david@kernel.org, gourry@gourry.net, hannes@cmpxchg.org, hughd@google.com, jackmanb@google.com, jack@suse.cz, jannh@google.com, jglisse@google.com, joshua.hahnjy@gmail.com, kas@kernel.org, lance.yang@linux.dev, Liam.Howlett@oracle.com, lorenzo.stoakes@oracle.com, mathieu.desnoyers@efficios.com, matthew.brost@intel.com, mhiramat@kernel.org, mhocko@suse.com, peterx@redhat.com, pfalcato@suse.de, rakie.kim@sk.com, raquini@redhat.com, rdunlap@infradead.org, richard.weiyang@gmail.com, rientjes@google.com, rostedt@goodmis.org, rppt@kernel.org, ryan.roberts@arm.com, shivankg@amd.com, sunnanyong@huawei.com, surenb@google.com, thomas.hellstrom@linux.intel.com, tiwai@suse.de, usamaarif642@gmail.com, vbabka@suse.cz, vishal.moola@gmail.com, wangkefeng.wang@huawei.com, will@kernel.org, willy@infradead.org, yang@os.amperecomputing.com, ying.huang@linux.alibaba.com, ziy@nvidia.com, zokeefe@google.com References: <20260212021835.17755-1-npache@redhat.com> <20260212021835.17755-3-npache@redhat.com> Content-Language: en-US From: Dev Jain In-Reply-To: <20260212021835.17755-3-npache@redhat.com> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit On 12/02/26 7:48 am, Nico Pache wrote: > In order to add mTHP support to khugepaged, we will often be checking if a > given order is (or is not) a PMD order. Some places in the kernel already > use this check, so lets create a simple helper function to keep the code > clean and readable. > > Reviewed-by: Lorenzo Stoakes > Suggested-by: Lorenzo Stoakes > Signed-off-by: Nico Pache > > arches# pick b3ace8be204f # mm/khugepaged: rename hpage_collapse_* to collapse_* > --- Thanks, this is useful. In drivers/dax/device.c and fs/dax.c, we have order == PMD_ORDER check, not HPAGE_PMD_ORDER. Therefore, 1) Do we have a bug here, in that these codepaths are fault handlers, therefore should be using HPAGE_PMD_ORDER since the definition of this macro zeroes out on !CONFIG_PGTABLE_HAS_HUGE_LEAVES? 2) If the distinction between HPAGE_PMD_ORDER and PMD_ORDER is real, then the helper should be named is_hpage_pmd_order? > include/linux/huge_mm.h | 5 +++++ > mm/huge_memory.c | 2 +- > mm/khugepaged.c | 4 ++-- > mm/mempolicy.c | 2 +- > mm/page_alloc.c | 2 +- > 5 files changed, 10 insertions(+), 5 deletions(-) > > diff --git a/include/linux/huge_mm.h b/include/linux/huge_mm.h > index a4d9f964dfde..bd7f0e1d8094 100644 > --- a/include/linux/huge_mm.h > +++ b/include/linux/huge_mm.h > @@ -771,6 +771,11 @@ static inline bool pmd_is_huge(pmd_t pmd) > } > #endif /* CONFIG_TRANSPARENT_HUGEPAGE */ > > +static inline bool is_pmd_order(unsigned int order) > +{ > + return order == HPAGE_PMD_ORDER; > +} > + > static inline int split_folio_to_list_to_order(struct folio *folio, > struct list_head *list, int new_order) > { > diff --git a/mm/huge_memory.c b/mm/huge_memory.c > index 44ff8a648afd..5eae85818635 100644 > --- a/mm/huge_memory.c > +++ b/mm/huge_memory.c > @@ -4097,7 +4097,7 @@ static int __folio_split(struct folio *folio, unsigned int new_order, > i_mmap_unlock_read(mapping); > out: > xas_destroy(&xas); > - if (old_order == HPAGE_PMD_ORDER) > + if (is_pmd_order(old_order)) > count_vm_event(!ret ? THP_SPLIT_PAGE : THP_SPLIT_PAGE_FAILED); > count_mthp_stat(old_order, !ret ? MTHP_STAT_SPLIT : MTHP_STAT_SPLIT_FAILED); > return ret; > diff --git a/mm/khugepaged.c b/mm/khugepaged.c > index fa1e57fd2c46..c362b3b2e08a 100644 > --- a/mm/khugepaged.c > +++ b/mm/khugepaged.c > @@ -2000,7 +2000,7 @@ static enum scan_result collapse_file(struct mm_struct *mm, unsigned long addr, > * we locked the first folio, then a THP might be there already. > * This will be discovered on the first iteration. > */ > - if (folio_order(folio) == HPAGE_PMD_ORDER && > + if (is_pmd_order(folio_order(folio)) && > folio->index == start) { > /* Maybe PMD-mapped */ > result = SCAN_PTE_MAPPED_HUGEPAGE; > @@ -2329,7 +2329,7 @@ static enum scan_result hpage_collapse_scan_file(struct mm_struct *mm, unsigned > continue; > } > > - if (folio_order(folio) == HPAGE_PMD_ORDER && > + if (is_pmd_order(folio_order(folio)) && > folio->index == start) { > /* Maybe PMD-mapped */ > result = SCAN_PTE_MAPPED_HUGEPAGE; > diff --git a/mm/mempolicy.c b/mm/mempolicy.c > index dbd48502ac24..3802e52b01fc 100644 > --- a/mm/mempolicy.c > +++ b/mm/mempolicy.c > @@ -2450,7 +2450,7 @@ static struct page *alloc_pages_mpol(gfp_t gfp, unsigned int order, > > if (IS_ENABLED(CONFIG_TRANSPARENT_HUGEPAGE) && > /* filter "hugepage" allocation, unless from alloc_pages() */ > - order == HPAGE_PMD_ORDER && ilx != NO_INTERLEAVE_INDEX) { > + is_pmd_order(order) && ilx != NO_INTERLEAVE_INDEX) { > /* > * For hugepage allocation and non-interleave policy which > * allows the current node (or other explicitly preferred > diff --git a/mm/page_alloc.c b/mm/page_alloc.c > index c2e96ac35636..2acf22f97ae5 100644 > --- a/mm/page_alloc.c > +++ b/mm/page_alloc.c > @@ -719,7 +719,7 @@ static inline bool pcp_allowed_order(unsigned int order) > if (order <= PAGE_ALLOC_COSTLY_ORDER) > return true; > #ifdef CONFIG_TRANSPARENT_HUGEPAGE > - if (order == HPAGE_PMD_ORDER) > + if (is_pmd_order(order)) > return true; > #endif > return false;