From: Casey Schaufler <casey@schaufler-ca.com>
To: Kees Cook <keescook@chromium.org>,
John Stultz <john.stultz@linaro.org>,
James Morris <jmorris@namei.org>
Cc: Nick Kralevich <nnk@google.com>,
lkml <linux-kernel@vger.kernel.org>,
"Serge E. Hallyn" <serge@hallyn.com>,
Andrew Morton <akpm@linux-foundation.org>,
Thomas Gleixner <tglx@linutronix.de>,
Arjan van de Ven <arjan@linux.intel.com>,
Oren Laadan <orenl@cellrox.com>,
Ruchi Kandoi <kandoiruchi@google.com>,
Rom Lemarchand <romlem@android.com>, Todd Kjos <tkjos@google.com>,
Colin Cross <ccross@android.com>,
Dmitry Shmidt <dimitrysh@google.com>,
Elliott Hughes <enh@google.com>,
Android Kernel Team <kernel-team@android.com>,
LSM List <linux-security-module@vger.kernel.org>,
SELinux <selinux@tycho.nsa.gov>
Subject: Re: [RFC][PATCH 1/2 v2] proc: Relax /proc/<tid>/timerslack_ns capability requirements
Date: Fri, 15 Jul 2016 13:17:28 -0700 [thread overview]
Message-ID: <78837e66-e905-4d8f-3b41-c3ac0e86e67d@schaufler-ca.com> (raw)
In-Reply-To: <CAGXu5jKPu2pwgPdGmRdTad3eLrDPYSkj8u2VT7CCk5zNSexQTw@mail.gmail.com>
On 7/15/2016 11:56 AM, Kees Cook wrote:
> On Fri, Jul 15, 2016 at 11:42 AM, John Stultz <john.stultz@linaro.org> wrote:
>> On Fri, Jul 15, 2016 at 10:51 AM, Nick Kralevich <nnk@google.com> wrote:
>>> On Fri, Jul 15, 2016 at 10:24 AM, John Stultz <john.stultz@linaro.org> wrote:
>>>> + if (!capable(CAP_SYS_NICE))
>>>> + return -EPERM;
>>>> +
>>> Since you're going the LSM route (from your second patch of this
>> Well, you suggested it, so I sent out an RFC. I'm not married to it yet. :)
>>
>>
>>> series), the capability check above should be moved to the LSM hook in
>>> security/commoncap.c. Only one security call to
>>> security_task_settimerslack is needed, which will cover the standard
>>> capabilities check as well as the SELinux check.
>> Huh. Ok. I was looking at the implementation of nice(), which does:
>>
>> if (increment < 0 && !can_nice(current, nice))
>> return -EPERM;
>> retval = security_task_setnice(current, nice);
>> if (retval)
>> ...
>>
>> Which made it seem like standard checks are done first, then finer
>> grain lsm checks second.
> I'm on the fence about this: it can be argued that if it's a cap check
> it should live in the commoncap.c checks, but most of our cap checks
> for these kinds of access controls are directly in the function, prior
> the the security_* calls. I've added James and Casey who may have a
> more well constructed rationale for doing this one way or the other.
Let's say that at some point in the future someone wanted to replace
POSIX capabilities with some other privilege scheme[1]. Having as much
of the capability checking hooked in via the LSM infrastructure would
be a big help. On the other hand, there's a lot to be said for locality
of reference, and having the capability check off in another place may
make it harder to understand what's going on.
I don't object to either approach. If I have a recommendation it's to
put it in commoncap.c and hook it in on the off chance that the capability
model will implode after the next round of "improvements". Or if someone
comes up with a really spiffy alternative.
[1] Some years ago I offered to make a proposal for a customizable
privilege scheme, but failed to deliver. Could it be as simple
as providing a replacement for commoncap.c? I don't think so,
because the cap calls are not positioned generically, they are
placed based on the assumptions of the capability mechanism.
On the other hand, A little hard work goes a long way to fixing
that sort of problem.
>
>> (...and now you can guess where my accidental "current" usage in the
>> next patch came from :)
>>
>>
>>>> p = get_proc_task(inode);
>>>> if (!p)
>>>> return -ESRCH;
>>>>
>>> Per your patch #2, you'd call security_task_settimerslack here. This
>>> would call into the capability LSM hook you added in
>>> security/commoncap.c
>> Though I was hoping to keep the CAP_SYS_PTRACE -> CAP_SYS_NICE change
>> first, then add the LSM hooks, as it makes the needed ABI change more
>> obvious. I worry swapping it around with the LSM hook being added
>> first makes it significantly less obvious, as (at least for me) the
>> security_task_* functions get indirect and difficult to follow quickly
>> ("wait, why are we checking SETSCHED for nice?").
>>
>> A side curiosity: why does "git grep PROCESS__SETSCHED" miss the
>> definition? Is the av_permissions.h file somehow caught by .gitignore?
>>
>> thanks
>> -john
> -Kees
>
next prev parent reply other threads:[~2016-07-15 20:17 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-07-15 17:24 John Stultz
2016-07-15 17:24 ` [RFC][PATCH 2/2 v2] security: Add task_settimerslack LSM hook John Stultz
2016-07-15 17:51 ` Nick Kralevich
2016-07-15 18:10 ` John Stultz
2016-07-15 17:51 ` [RFC][PATCH 1/2 v2] proc: Relax /proc/<tid>/timerslack_ns capability requirements Nick Kralevich
2016-07-15 18:42 ` John Stultz
2016-07-15 18:56 ` Kees Cook
2016-07-15 20:17 ` Casey Schaufler [this message]
2016-07-15 19:55 ` Nick Kralevich
2016-07-15 20:03 ` John Stultz
2016-07-15 20:20 ` Nick Kralevich
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=78837e66-e905-4d8f-3b41-c3ac0e86e67d@schaufler-ca.com \
--to=casey@schaufler-ca.com \
--cc=akpm@linux-foundation.org \
--cc=arjan@linux.intel.com \
--cc=ccross@android.com \
--cc=dimitrysh@google.com \
--cc=enh@google.com \
--cc=jmorris@namei.org \
--cc=john.stultz@linaro.org \
--cc=kandoiruchi@google.com \
--cc=keescook@chromium.org \
--cc=kernel-team@android.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-security-module@vger.kernel.org \
--cc=nnk@google.com \
--cc=orenl@cellrox.com \
--cc=romlem@android.com \
--cc=selinux@tycho.nsa.gov \
--cc=serge@hallyn.com \
--cc=tglx@linutronix.de \
--cc=tkjos@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®