From: Kirti Wankhede <kwankhede@nvidia.com>
To: Gerd Hoffmann <kraxel@redhat.com>,
Alex Williamson <alex.williamson@redhat.com>
Cc: Xiaoguang Chen <xiaoguang.chen@intel.com>,
<chris@chris-wilson.co.uk>, <intel-gfx@lists.freedesktop.org>,
<linux-kernel@vger.kernel.org>, <zhenyuw@linux.intel.com>,
<zhiyuan.lv@intel.com>, <intel-gvt-dev@lists.freedesktop.org>,
<zhi.a.wang@intel.com>, <kevin.tian@intel.com>
Subject: Re: [PATCH v9 5/7] vfio: Define vfio based dma-buf operations
Date: Tue, 20 Jun 2017 19:25:31 +0530 [thread overview]
Message-ID: <791b0316-1c83-622c-9cef-d54dae1209f9@nvidia.com> (raw)
In-Reply-To: <1497947703.16795.4.camel@redhat.com>
On 6/20/2017 2:05 PM, Gerd Hoffmann wrote:
> Hi,
>
>>> Hmm, plane isn't really an ID, it is a type, with type being either
>>> DRM_PLANE_TYPE_PRIMARY or DRM_PLANE_TYPE_CURSOR, so I don't think
>>> the
>>> flage above make sense.
>>
>> The intention was that ..._REGION_ID and ...PLANE_ID are describing
>> what the vfio_device_query_gfx_plane.id field represents, either a
>> region index or a plane identifier. The type of plane would be
>> represented within the vfio_device_gfx_plane_info struct.
>
> The planes don't really have an id, we should rename that to
> plane_type, or maybe drm_plane_type (simliar to the drm_format_*
> fields), to avoid that confusion.
>
> plane_type is set by userspace to specify what kind of plane it asks
> for.
>
Ok. so there should be two fields:
- plane type : DRM_PLANE_TYPE_PRIMARY or DRM_PLANE_TYPE_CURSOR
- id : fd for dmabuf or region index for region type
Adding reply to Gerd's question from earlier mail:
> What are the nvidia plane for cursor support btw?
We don't support cursor for console vnc. Ideally console vnc should be
used by admin for configuration or during maintenance, which refresh
primary surface at low refresh rate, 10 fps. We recommend to use
remoting solution for actual use.
>>> Also I think it would be useful to have some way to figure the
>>> device
>>> capabilities as the userspace workflow will look quite different
>>> for
>>> the two cases.
>>
>> In the region case, VFIO_DEVICE_GET_REGION_INFO would include a
>> device
>> specific region with a hopefully common identifier to identify it as
>> a
>> graphics framebuffer.
>
> Ok, that should work to figure whenever the mdev supports a plane
> region or not.
>
>> In the dmabuf case,VFIO_DEVICE_QUERY_GFX_PLANE would indicate the
>> plane as a "plane ID" and some sort of
>> VFIO_DEVICE_GET_GFX_PLANE(VFIO_GFX_TYPE_DMABUF) ioctl would be
>> necessary to get a file descriptor to that plane.
>>
>> What else are you thinking we need? Thanks,
>
> I need to know whenever the mdev supports dmabufs or not, at device
> initialization time (because dmabufs require opengl support), when
> VFIO_DEVICE_QUERY_GFX_PLANE doesn't work due to the guest not having
> the device initialized yet.
>
> Maybe we should have a error field in the ioctl struct, or we need to
> clearly define error codes so the kernel doesn't just throw EINVAL in
> all cases.
>
> Or just a VFIO_DEVICE_GFX_CAPS ioctl which returns NONE, REGION or
> DMABUF.
>
Right we need to know this at device initialization time for both cases
to initialize VGACommonState structure for that device and also need
NONE to decide whether to init console vnc or not. We have a mechanism
to disable console vnc path and we recommend to disable it for better
performance.
Thanks,
Kirti
> cheers,
> Gerd
>
next prev parent reply other threads:[~2017-06-20 13:55 UTC|newest]
Thread overview: 55+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-06-15 8:00 [PATCH v9 0/7] drm/i915/gvt: Dma-buf support for GVT-g Xiaoguang Chen
2017-06-15 8:00 ` [PATCH v9 1/7] drm/i915/gvt: Extend the GVT-g architecture Xiaoguang Chen
2017-06-15 8:00 ` [PATCH v9 2/7] drm/i915/gvt: OpRegion support for GVT-g Xiaoguang Chen
2017-06-15 8:00 ` [PATCH v9 3/7] drm: Extend the drm format Xiaoguang Chen
2017-06-15 10:21 ` [Intel-gfx] " Ville Syrjälä
2017-06-20 9:01 ` Zhang, Tina
2017-06-15 8:00 ` [PATCH v9 4/7] drm/i915/gvt: Frame buffer decoder support for GVT-g Xiaoguang Chen
2017-06-15 8:00 ` [PATCH v9 5/7] vfio: Define vfio based dma-buf operations Xiaoguang Chen
2017-06-15 14:51 ` Kirti Wankhede
2017-06-15 16:00 ` Gerd Hoffmann
2017-06-15 20:38 ` Alex Williamson
2017-06-16 10:24 ` Gerd Hoffmann
2017-06-16 12:52 ` Alex Williamson
2017-06-16 13:32 ` Kirti Wankhede
2017-06-16 16:39 ` Alex Williamson
2017-06-16 18:28 ` Kirti Wankhede
2017-06-19 6:34 ` Gerd Hoffmann
2017-06-19 14:54 ` Alex Williamson
2017-06-20 8:35 ` Gerd Hoffmann
2017-06-20 13:55 ` Kirti Wankhede [this message]
2017-06-21 7:22 ` Gerd Hoffmann
2017-07-12 13:18 ` Kirti Wankhede
2017-07-14 9:58 ` Gerd Hoffmann
2017-06-19 6:38 ` Gerd Hoffmann
2017-06-19 14:55 ` Alex Williamson
2017-06-20 8:41 ` [Intel-gfx] " Zhang, Tina
2017-06-20 10:57 ` Gerd Hoffmann
2017-06-20 15:00 ` Alex Williamson
2017-06-20 17:07 ` Kirti Wankhede
2017-06-20 23:01 ` Zhang, Tina
2017-06-20 23:22 ` Alex Williamson
2017-06-21 9:20 ` Zhang, Tina
2017-06-21 11:03 ` Gerd Hoffmann
2017-06-21 18:59 ` Alex Williamson
2017-06-22 8:30 ` Gerd Hoffmann
2017-06-22 18:54 ` Alex Williamson
2017-06-23 7:26 ` Gerd Hoffmann
2017-06-23 7:49 ` Zhi Wang
2017-06-23 8:31 ` Gerd Hoffmann
2017-06-23 16:40 ` Alex Williamson
2017-06-23 17:15 ` Alex Williamson
2017-06-26 6:17 ` Gerd Hoffmann
2017-06-22 0:21 ` Zhang, Tina
2017-06-21 7:34 ` Gerd Hoffmann
2017-06-23 21:58 ` Zhang, Tina
2017-06-26 6:39 ` Gerd Hoffmann
2017-06-26 17:28 ` Alex Williamson
2017-06-27 6:12 ` Gerd Hoffmann
2017-06-28 12:48 ` Zhang, Tina
2017-06-29 6:41 ` Gerd Hoffmann
2017-06-29 8:39 ` Daniel Vetter
2017-07-04 0:47 ` Zhang, Tina
2017-06-20 13:35 ` Kirti Wankhede
2017-06-15 8:00 ` [PATCH v9 6/7] drm/i915/gvt: Dmabuf support for GVT-g Xiaoguang Chen
2017-06-15 8:00 ` [PATCH v9 7/7] drm/i915/gvt: Adding user interface for dma-buf Xiaoguang Chen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=791b0316-1c83-622c-9cef-d54dae1209f9@nvidia.com \
--to=kwankhede@nvidia.com \
--cc=alex.williamson@redhat.com \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=intel-gvt-dev@lists.freedesktop.org \
--cc=kevin.tian@intel.com \
--cc=kraxel@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=xiaoguang.chen@intel.com \
--cc=zhenyuw@linux.intel.com \
--cc=zhi.a.wang@intel.com \
--cc=zhiyuan.lv@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®