From: David Lechner <dlechner@baylibre.com>
To: Francesco Lavra <flavra@baylibre.com>,
Andy Shevchenko <andy.shevchenko@gmail.com>,
Jonathan Cameron <jic23@kernel.org>
Cc: "Andy Shevchenko" <andriy.shevchenko@intel.com>,
"Lorenzo Bianconi" <lorenzo@kernel.org>,
"Nuno Sá" <nuno.sa@analog.com>,
"Andy Shevchenko" <andy@kernel.org>,
linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/9] iio: imu: st_lsm6dsx: remove event_threshold field from hw struct
Date: Mon, 3 Nov 2025 08:53:44 -0600 [thread overview]
Message-ID: <798a41fa-eda6-4f27-955c-82fdb61c2083@baylibre.com> (raw)
In-Reply-To: <25732d2be08156b4f55e97f5306d1fd080255ae7.camel@baylibre.com>
On 11/3/25 3:34 AM, Francesco Lavra wrote:
> On Sun, 2025-11-02 at 15:45 +0200, Andy Shevchenko wrote:
>> On Sun, Nov 2, 2025 at 1:30 PM Jonathan Cameron <jic23@kernel.org> wrote:
>>> On Thu, 30 Oct 2025 15:49:37 +0200
>>> Andy Shevchenko <andriy.shevchenko@intel.com> wrote:
>>>> On Thu, Oct 30, 2025 at 12:10:08PM +0100, Francesco Lavra wrote:
>>>>> On Thu, 2025-10-30 at 10:01 +0200, Andy Shevchenko wrote:
>>>>>> On Thu, Oct 30, 2025 at 08:27:49AM +0100, Francesco Lavra wrote:
>>
>> ...
>>
>>>>>>> + *val = (data & reg->mask) >> __ffs(reg->mask);
>>>>>>
>>>>>> Seems like yet another candidate for field_get() macro.
>>>>>
>>>>> FIELD_GET() can only be used with compile-time constant masks.
>>>>> And apparently this is the case with u8_get_bits() too, because you
>>>>> get a
>>>>> "bad bitfield mask" compiler error if you try to use u8_get_bits().
>>>>
>>>> We are talking about different things.
>>>> Here are the pointers to what I'm talking:
>>>>
>>>> - git grep -n -w 'field_get'
>>>> -
>>>> https://lore.kernel.org/linux-gpio/cover.1761588465.git.geert+renesas@glider.be/
>>>>
>>> True that it will be a usecase for that, but given plan is to merge
>>> that through
>>> a different tree in next merge window, it's not available for us yet.
>>> Hence would
>>> be a follow up patch next cycle.
>>
>> Yes, but we can still define them here. Dunno either with #under or
>> under (namespaced) names, but still possible to use now.
>
> OK, I will define an ST_LSM6DSX_FIELD_GET() macro.
The macro should be named exactly `field_get()`, otherwise we will
have to rename all of the callers later after the series adding it
to linux/bitfield.h is merged. And it should have an
`#undef field_get` just like the other patches that series. Then
later, we only need to remove the #undef and #def lines and not
change the rest of the code.
next prev parent reply other threads:[~2025-11-03 14:53 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-30 7:27 [PATCH 0/9] st_lsm6dsx: add tap event detection Francesco Lavra
2025-10-30 7:27 ` [PATCH 1/9] iio: imu: st_lsm6dsx: dynamically initialize iio_chan_spec data Francesco Lavra
2025-10-30 7:57 ` Andy Shevchenko
2025-10-30 11:03 ` Francesco Lavra
2025-10-30 16:42 ` Lorenzo Bianconi
2025-10-31 8:04 ` Francesco Lavra
2025-10-31 8:09 ` Andy Shevchenko
2025-10-31 8:26 ` Francesco Lavra
2025-10-31 8:32 ` Andy Shevchenko
2025-10-31 11:43 ` Francesco Lavra
2025-11-02 11:16 ` Jonathan Cameron
2025-11-03 9:24 ` Francesco Lavra
2025-11-09 13:32 ` Jonathan Cameron
2025-10-30 7:27 ` [PATCH 2/9] iio: imu: st_lsm6dsx: make event_settings more generic Francesco Lavra
2025-10-30 16:44 ` Lorenzo Bianconi
2025-10-31 8:08 ` Francesco Lavra
2025-10-30 7:27 ` [PATCH 3/9] iio: imu: st_lsm6dsx: move wakeup event enable mask to event_src Francesco Lavra
2025-10-30 7:59 ` Andy Shevchenko
2025-10-30 7:27 ` [PATCH 4/9] iio: imu: st_lsm6dsx: dynamically allocate iio_event_spec structs Francesco Lavra
2025-11-02 11:22 ` Jonathan Cameron
2025-10-30 7:27 ` [PATCH 5/9] iio: imu: st_lsm6dsx: rework code to check for enabled events Francesco Lavra
2025-10-30 7:27 ` [PATCH 6/9] iio: imu: st_lsm6dsx: remove event_threshold field from hw struct Francesco Lavra
2025-10-30 8:01 ` Andy Shevchenko
2025-10-30 11:10 ` Francesco Lavra
2025-10-30 13:49 ` Andy Shevchenko
2025-11-02 11:29 ` Jonathan Cameron
2025-11-02 13:45 ` Andy Shevchenko
2025-11-03 9:34 ` Francesco Lavra
2025-11-03 9:40 ` Andy Shevchenko
2025-11-03 14:53 ` David Lechner [this message]
2025-11-09 13:31 ` Jonathan Cameron
2025-10-30 7:27 ` [PATCH 7/9] iio: imu: st_lsm6dsx: make event management functions generic Francesco Lavra
2025-10-30 8:15 ` Andy Shevchenko
2025-10-30 11:17 ` Francesco Lavra
2025-10-30 13:36 ` Andy Shevchenko
2025-11-02 11:33 ` Jonathan Cameron
2025-10-30 7:27 ` [PATCH 8/9] iio: imu: st_lsm6dsx: add event configurability on a per axis basis Francesco Lavra
2025-10-30 8:24 ` Andy Shevchenko
2025-10-30 11:23 ` Francesco Lavra
2025-10-30 13:56 ` Andy Shevchenko
2025-11-17 19:23 ` Francesco Lavra
2025-11-18 10:44 ` Andy Shevchenko
2025-11-18 11:01 ` Francesco Lavra
2025-11-20 9:05 ` Andy Shevchenko
2025-11-20 11:43 ` Francesco Lavra
2025-11-20 13:59 ` Andy Shevchenko
2025-11-20 18:31 ` Andy Shevchenko
2025-11-21 9:14 ` Francesco Lavra
2025-11-21 9:31 ` Andy Shevchenko
2025-11-21 14:57 ` Francesco Lavra
2025-12-07 15:11 ` Jonathan Cameron
2025-10-30 7:27 ` [PATCH 9/9] iio: imu: st_lsm6dsx: add tap event detection Francesco Lavra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=798a41fa-eda6-4f27-955c-82fdb61c2083@baylibre.com \
--to=dlechner@baylibre.com \
--cc=andriy.shevchenko@intel.com \
--cc=andy.shevchenko@gmail.com \
--cc=andy@kernel.org \
--cc=flavra@baylibre.com \
--cc=jic23@kernel.org \
--cc=linux-iio@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=lorenzo@kernel.org \
--cc=nuno.sa@analog.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®