From: Dan Carpenter <dan.carpenter@linaro.org>
To: Su Hui <suhui@nfschina.com>
Cc: chuck.lever@oracle.com, jlayton@kernel.org, neil@brown.name,
okorniev@redhat.com, Dai.Ngo@oracle.com, tom@talpey.com,
linux-nfs@vger.kernel.org, linux-kernel@vger.kernel.org,
kernel-janitors@vger.kernel.org
Subject: Re: [PATCH] nfsd: Using guard() to simplify nfsd_cache_lookup()
Date: Tue, 24 Jun 2025 17:49:41 +0300 [thread overview]
Message-ID: <7a156b03-c522-4e18-85ec-2c7ebfd97a42@suswa.mountain> (raw)
In-Reply-To: <7975be21-045e-4b2b-9c73-79aba5b683db@nfschina.com>
On Tue, Jun 24, 2025 at 09:45:27AM +0800, Su Hui wrote:
> On 2025/6/23 23:47, Dan Carpenter wrote:
> > On Mon, Jun 23, 2025 at 08:22:27PM +0800, Su Hui wrote:
> > > Using guard() to replace *unlock* label. guard() makes lock/unlock code
> > > more clear. Change the order of the code to let all lock code in the
> > > same scope. No functional changes.
> > >
> > > Signed-off-by: Su Hui <suhui@nfschina.com>
> > > ---
> > > fs/nfsd/nfscache.c | 99 ++++++++++++++++++++++------------------------
> > > 1 file changed, 48 insertions(+), 51 deletions(-)
> > >
> > > diff --git a/fs/nfsd/nfscache.c b/fs/nfsd/nfscache.c
> > > index ba9d326b3de6..2d92adf3e6b0 100644
> > > --- a/fs/nfsd/nfscache.c
> > > +++ b/fs/nfsd/nfscache.c
> > > @@ -489,7 +489,7 @@ int nfsd_cache_lookup(struct svc_rqst *rqstp, unsigned int start,
> > > if (type == RC_NOCACHE) {
> > > nfsd_stats_rc_nocache_inc(nn);
> > > - goto out;
> > > + return rtn;
> > > }
> > > csum = nfsd_cache_csum(&rqstp->rq_arg, start, len);
> > > @@ -500,64 +500,61 @@ int nfsd_cache_lookup(struct svc_rqst *rqstp, unsigned int start,
> > > */
> > > rp = nfsd_cacherep_alloc(rqstp, csum, nn);
> > > if (!rp)
> > > - goto out;
> > > + return rtn;
> > > b = nfsd_cache_bucket_find(rqstp->rq_xid, nn);
> > > - spin_lock(&b->cache_lock);
> > > - found = nfsd_cache_insert(b, rp, nn);
> > > - if (found != rp)
> > > - goto found_entry;
> > > - *cacherep = rp;
> > > - rp->c_state = RC_INPROG;
> > > - nfsd_prune_bucket_locked(nn, b, 3, &dispose);
> > > - spin_unlock(&b->cache_lock);
> > > + scoped_guard(spinlock, &b->cache_lock) {
> > > + found = nfsd_cache_insert(b, rp, nn);
> > > + if (found == rp) {
> > > + *cacherep = rp;
> > > + rp->c_state = RC_INPROG;
> > > + nfsd_prune_bucket_locked(nn, b, 3, &dispose);
> > > + goto out;
> > It took me a while to figure out why we've added a goto here. In the
> > original code this "goto out;" was a "spin_unlock(&b->cache_lock);".
> > The spin_unlock() is more readable because you can immediately see that
> > it's trying to drop the lock where a "goto out;" is less obvious about
> > the intention.
>
> Does "break;" be better in this place? Meaning Break this lock guard scope.
>
Yeah, probably break is better.
regards,
dan carpenter
next prev parent reply other threads:[~2025-06-24 14:49 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-06-23 12:22 Su Hui
2025-06-23 15:47 ` Dan Carpenter
2025-06-24 1:45 ` Su Hui
2025-06-24 14:49 ` Dan Carpenter [this message]
2025-06-24 0:19 ` NeilBrown
2025-06-24 1:31 ` Su Hui
2025-06-24 13:41 ` Chuck Lever
2025-06-24 14:21 ` Su Hui
2025-06-24 15:07 ` Chuck Lever
2025-06-24 22:15 ` NeilBrown
2025-06-25 11:51 ` Su Hui
2025-07-11 14:22 ` Chuck Lever
2025-07-11 17:20 ` Tom Talpey
2025-07-13 23:33 ` NeilBrown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7a156b03-c522-4e18-85ec-2c7ebfd97a42@suswa.mountain \
--to=dan.carpenter@linaro.org \
--cc=Dai.Ngo@oracle.com \
--cc=chuck.lever@oracle.com \
--cc=jlayton@kernel.org \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nfs@vger.kernel.org \
--cc=neil@brown.name \
--cc=okorniev@redhat.com \
--cc=suhui@nfschina.com \
--cc=tom@talpey.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®