mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Robin Murphy <robin.murphy@arm.com>
To: Christoph Hellwig <hch@lst.de>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: iommu@lists.linux-foundation.org,
	Marek Szyprowski <m.szyprowski@samsung.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org
Subject: Re: [PATCH 5/5] dma-direct: always allow dma mask <= physiscal memory size
Date: Thu, 27 Sep 2018 16:07:50 +0100	[thread overview]
Message-ID: <7a34c74f-7c83-84bb-441b-a729adce2beb@arm.com> (raw)
In-Reply-To: <20180927134954.GB8281@lst.de>

[ oops, I should have looked at the replies first, now I see Ben already 
had the same thing to say about #3... ]

On 27/09/18 14:49, Christoph Hellwig wrote:
> On Thu, Sep 27, 2018 at 11:50:14AM +1000, Benjamin Herrenschmidt wrote:
>>> -	 * to be able to satisfy them - either by not supporting more physical
>>> -	 * memory, or by providing a ZONE_DMA32.  If neither is the case, the
>>> -	 * architecture needs to use an IOMMU instead of the direct mapping.
>>> -	 */
>>> -	if (mask < phys_to_dma(dev, DMA_BIT_MASK(32)))
>>> +	u64 min_mask;
>>> +
>>> +	if (IS_ENABLED(CONFIG_ZONE_DMA))
>>> +		min_mask = DMA_BIT_MASK(ARCH_ZONE_DMA_BITS);
>>> +	else
>>> +		min_mask = min_t(u64, DMA_BIT_MASK(32),
>>> +				 (max_pfn - 1) << PAGE_SHIFT);
>>> +
>>> +	if (mask >= phys_to_dma(dev, min_mask))
>>>   		return 0;
>>
>> nitpick ... to be completely "correct", I would have written
>>
>> 	if (IS_ENABLED(CONFIG_ZONE_DMA))
>> 		min_mask = DMA_BIT_MASK(ARCH_ZONE_DMA_BITS);
>> 	else
>> 		min_mask = DMA_BIT_MASK(32);
>>
>> 	min_mask = min_t(u64, min_mask,	(max_pfn - 1) << PAGE_SHIFT);
>>
>> In "theory" it's also ok to have a mask < ZONE_DMA_BITS as long as it's
>> big enough to fit all memory :-)
> 
> Yeah, we could do that.

FWIW I like it even if just for looking slightly more readable. With 
that fixup,

Reviewed-by: Robin Murphy <robin.murphy@arm.com>

  reply	other threads:[~2018-09-27 15:07 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-20 18:52 dma mask related fixups (including full bus_dma_mask support) Christoph Hellwig
2018-09-20 18:52 ` [PATCH 1/5] dma-mapping: make the get_required_mask method available unconditionally Christoph Hellwig
2018-09-27  1:28   ` Benjamin Herrenschmidt
2018-09-20 18:52 ` [PATCH 2/5] dma-direct: add an explicit dma_direct_get_required_mask Christoph Hellwig
2018-09-27  1:31   ` Benjamin Herrenschmidt
2018-09-27 14:12   ` Robin Murphy
2018-09-27 15:28     ` Christoph Hellwig
2018-09-27 15:35       ` Robin Murphy
2018-09-20 18:52 ` [PATCH 3/5] dma-direct: refine dma_direct_alloc zone selection Christoph Hellwig
2018-09-27  1:45   ` Benjamin Herrenschmidt
2018-09-27 13:49     ` Christoph Hellwig
2018-09-28  0:06       ` Benjamin Herrenschmidt
2018-09-28 15:46         ` Christoph Hellwig
2018-09-27 14:30   ` Robin Murphy
2018-09-27 15:30     ` Christoph Hellwig
2018-09-27 15:38       ` Robin Murphy
2018-09-27 15:41         ` Christoph Hellwig
2018-09-20 18:52 ` [PATCH 4/5] dma-direct: implement complete bus_dma_mask handling Christoph Hellwig
2018-09-27 14:58   ` Robin Murphy
2018-09-27 15:32     ` Christoph Hellwig
2018-09-27 16:14       ` Robin Murphy
2018-09-27 16:27         ` Christoph Hellwig
2018-09-27 16:41           ` Robin Murphy
2018-09-20 18:52 ` [PATCH 5/5] dma-direct: always allow dma mask <= physiscal memory size Christoph Hellwig
2018-09-27  1:50   ` Benjamin Herrenschmidt
2018-09-27 13:49     ` Christoph Hellwig
2018-09-27 15:07       ` Robin Murphy [this message]
2018-09-27 22:35 dma mask related fixups (including full bus_dma_mask support) v2 Christoph Hellwig
2018-09-27 22:35 ` [PATCH 5/5] dma-direct: always allow dma mask <= physiscal memory size Christoph Hellwig
2018-10-03 23:10   ` Alexander Duyck
2018-10-09  5:01     ` Benjamin Herrenschmidt
2018-11-19 14:18       ` Ramon Fried
2018-11-19 15:50         ` Robin Murphy
2018-11-20  7:38           ` Ramon Fried

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7a34c74f-7c83-84bb-441b-a729adce2beb@arm.com \
    --to=robin.murphy@arm.com \
    --cc=benh@kernel.crashing.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=hch@lst.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=m.szyprowski@samsung.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®