From: Reinette Chatre <reinette.chatre@intel.com>
To: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: <linux-kselftest@vger.kernel.org>,
Fenghua Yu <fenghua.yu@intel.com>, Shuah Khan <shuah@kernel.org>,
LKML <linux-kernel@vger.kernel.org>,
"Shaopeng Tan" <tan.shaopeng@jp.fujitsu.com>
Subject: Re: [PATCH v2 10/24] selftests/resctrl: Split run_fill_buf() to alloc, work, and dealloc helpers
Date: Mon, 24 Apr 2023 09:32:58 -0700 [thread overview]
Message-ID: <7a760f74-6a0b-49ad-225a-f9f0d995fdd5@intel.com> (raw)
In-Reply-To: <a38cba17-77c3-3f81-d4c9-fca839a46444@linux.intel.com>
Hi Ilpo,
On 4/24/2023 9:01 AM, Ilpo Järvinen wrote:
> On Fri, 21 Apr 2023, Reinette Chatre wrote:
>> On 4/18/2023 4:44 AM, Ilpo Järvinen wrote:
>>>
...
>>> static void sb(void)
>>> {
>>> #if defined(__i386) || defined(__x86_64)
>>> @@ -138,36 +143,53 @@ static int fill_cache_write(unsigned char *start_ptr, unsigned char *end_ptr,
>>> return 0;
>>> }
>>>
>>> -static int
>>> -fill_cache(unsigned long long buf_size, int memflush, int op, char *resctrl_val)
>>> +int alloc_buffer(unsigned long long buf_size, int memflush)
>>> {
>>
>> This can be an allocation function that returns a pointer to
>> allocated buffer, NULL if error.
>>
>>> - unsigned char *start_ptr, *end_ptr;
>>> - int ret;
>>> + unsigned char *start_ptr;
>>>
>>> start_ptr = malloc_and_init_memory(buf_size);
>>> if (!start_ptr)
>>> return -1;
>>>
>>> startptr = start_ptr;
>>> - end_ptr = start_ptr + buf_size;
>>>
>>> /* Flush the memory before using to avoid "cache hot pages" effect */
>>> if (memflush)
>>> mem_flush(start_ptr, buf_size);
>>>
>>> + return 0;
>>> +}
>>> +
>>> +int use_buffer(unsigned long long buf_size, int op, char *resctrl_val)
>>> +{
>>> + unsigned char *end_ptr;
>>> + int ret;
>>> +
>>> + end_ptr = startptr + buf_size;
>>> if (op == 0)
>>> - ret = fill_cache_read(start_ptr, end_ptr, resctrl_val);
>>> + ret = fill_cache_read(startptr, end_ptr, resctrl_val);
>>> else
>>> - ret = fill_cache_write(start_ptr, end_ptr, resctrl_val);
>>> + ret = fill_cache_write(startptr, end_ptr, resctrl_val);
>>>
>>> - if (ret) {
>>> + if (ret)
>>> printf("\n Error in fill cache read/write...\n");
>>> - return -1;
>>> - }
>>>
>>> - free(startptr);
>>> + return ret;
>>> +}
>>>
>>
>> This seems like an unnecessary level of abstraction to me. Could
>> callers not just call fill_cache_read()/fill_cache_write() directly?
>> I think doing so will make tests easier to understand. Looking ahead
>> at how cat_val() turns out in the final patch I do think a call
>> to fill_cache_read() is easier to follow than this abstraction.
>
> Passing a custom benchmark command with -b would lose some functionality
> if this abstraction is removed. CAT test could make a direct call though
> as it doesn't care about the benchmark command.
>
> How useful that -b functionality is for selftesting is somewhat
> questionable though.
I do not think we are speaking about the same thing here. I think that
use_buffer() is unnecessary. fill_cache() can just call fill_cache_read()
or fill_cache_write() directly, depending on the op value. Could you please
elaborate how that impacts the custom benchmark?
Looking ahead at patch 24/24: "selftests/resctrl: Rewrite Cache Allocation
Technology (CAT) test" I feel more strongly that use_buffer() is unnecessary
since it adds an unnecessary layer and makes it harder to see what the test
does.
Reinette
next prev parent reply other threads:[~2023-04-24 16:33 UTC|newest]
Thread overview: 72+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-04-18 11:44 [PATCH v2 00/24] selftests/resctrl: Fixes, cleanups, and rewritten CAT test Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 01/24] selftests/resctrl: Add resctrl.h into build deps Ilpo Järvinen
2023-04-22 0:07 ` Reinette Chatre
2023-04-18 11:44 ` [PATCH v2 02/24] selftests/resctrl: Check also too low values for CBM bits Ilpo Järvinen
2023-04-22 0:08 ` Reinette Chatre
2023-04-24 10:46 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 03/24] selftests/resctrl: Move resctrl FS mount/umount to higher level Ilpo Järvinen
2023-04-22 0:09 ` Reinette Chatre
2023-04-24 14:58 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 04/24] selftests/resctrl: Remove mum_resctrlfs Ilpo Järvinen
2023-04-22 0:11 ` Reinette Chatre
2023-04-24 14:55 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 05/24] selftests/resctrl: Make span unsigned long everywhere Ilpo Järvinen
2023-04-22 0:12 ` Reinette Chatre
2023-04-24 15:05 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 06/24] selftests/resctrl: Express span in bytes Ilpo Järvinen
2023-04-22 0:12 ` Reinette Chatre
2023-04-24 15:31 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 07/24] selftests/resctrl: Remove duplicated preparation for span arg Ilpo Järvinen
2023-04-22 0:14 ` Reinette Chatre
2023-04-24 15:41 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 08/24] selftests/resctrl: Don't use variable argument list for ->setup() Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 09/24] selftests/resctrl: Remove "malloc_and_init_memory" param from run_fill_buf() Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 10/24] selftests/resctrl: Split run_fill_buf() to alloc, work, and dealloc helpers Ilpo Järvinen
2023-04-22 0:16 ` Reinette Chatre
2023-04-24 16:01 ` Ilpo Järvinen
2023-04-24 16:32 ` Reinette Chatre [this message]
2023-04-18 11:44 ` [PATCH v2 11/24] selftests/resctrl: Remove start_buf local variable from buffer alloc func Ilpo Järvinen
2023-04-22 0:16 ` Reinette Chatre
2023-04-18 11:44 ` [PATCH v2 12/24] selftests/resctrl: Don't pass test name to fill_buf Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 13/24] selftests/resctrl: Add flush_buffer() " Ilpo Järvinen
2023-04-22 0:16 ` Reinette Chatre
2023-04-18 11:44 ` [PATCH v2 14/24] selftests/resctrl: Remove test type checks from cat_val() Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 15/24] selftests/resctrl: Refactor get_cbm_mask() Ilpo Järvinen
2023-04-22 0:17 ` Reinette Chatre
2023-05-31 6:03 ` Shaopeng Tan (Fujitsu)
2023-05-31 9:24 ` Ilpo Järvinen
2023-04-18 11:44 ` [PATCH v2 16/24] selftests/resctrl: Create cache_alloc_size() helper Ilpo Järvinen
2023-04-22 0:19 ` Reinette Chatre
2023-04-24 16:28 ` Ilpo Järvinen
2023-04-24 16:45 ` Reinette Chatre
2023-04-18 11:44 ` [PATCH v2 17/24] selftests/resctrl: Replace count_bits with count_consecutive_bits() Ilpo Järvinen
2023-04-22 0:20 ` Reinette Chatre
2023-04-25 11:41 ` Ilpo Järvinen
2023-04-25 14:28 ` Reinette Chatre
2023-05-31 7:25 ` Shaopeng Tan (Fujitsu)
2023-05-31 9:35 ` Ilpo Järvinen
2023-06-01 6:20 ` Shaopeng Tan (Fujitsu)
2023-04-18 11:45 ` [PATCH v2 18/24] selftests/resctrl: Exclude shareable bits from schemata in CAT test Ilpo Järvinen
2023-04-18 11:45 ` [PATCH v2 19/24] selftests/resctrl: Pass the real number of tests to show_cache_info() Ilpo Järvinen
2023-04-22 0:20 ` Reinette Chatre
2023-04-18 11:45 ` [PATCH v2 20/24] selftests/resctrl: Move CAT/CMT test global vars to func they are used Ilpo Järvinen
2023-04-22 0:20 ` Reinette Chatre
2023-04-18 11:45 ` [PATCH v2 21/24] selftests/resctrl: Read in less obvious order to defeat prefetch optimizations Ilpo Järvinen
2023-05-31 5:33 ` Shaopeng Tan (Fujitsu)
2023-05-31 9:17 ` Ilpo Järvinen
2023-06-01 6:15 ` Shaopeng Tan (Fujitsu)
2023-06-02 13:51 ` Ilpo Järvinen
2023-06-02 14:39 ` Reinette Chatre
2023-06-14 13:02 ` Ilpo Järvinen
2023-06-16 5:30 ` Shaopeng Tan (Fujitsu)
2023-06-16 6:44 ` Ilpo Järvinen
2023-04-18 11:45 ` [PATCH v2 22/24] selftests/resctrl: Split measure_cache_vals() function Ilpo Järvinen
2023-04-22 0:21 ` Reinette Chatre
2023-04-18 11:45 ` [PATCH v2 23/24] selftests/resctrl: Split show_cache_info() to test specific and generic parts Ilpo Järvinen
2023-04-22 0:22 ` Reinette Chatre
2023-04-18 11:45 ` [PATCH v2 24/24] selftests/resctrl: Rewrite Cache Allocation Technology (CAT) test Ilpo Järvinen
2023-04-22 0:32 ` Reinette Chatre
2023-04-26 13:58 ` Ilpo Järvinen
2023-04-26 23:35 ` Reinette Chatre
2023-04-27 8:04 ` Ilpo Järvinen
2023-04-27 15:15 ` Reinette Chatre
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7a760f74-6a0b-49ad-225a-f9f0d995fdd5@intel.com \
--to=reinette.chatre@intel.com \
--cc=fenghua.yu@intel.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-kselftest@vger.kernel.org \
--cc=shuah@kernel.org \
--cc=tan.shaopeng@jp.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®