From: SF Markus Elfring <elfring@users.sourceforge.net>
To: linux-mtd@lists.infradead.org,
Boris Brezillon <boris.brezillon@free-electrons.com>,
Brian Norris <computersforpeace@gmail.com>,
Cyrille Pitchen <cyrille.pitchen@wedev4u.fr>,
David Woodhouse <dwmw2@infradead.org>,
Marek Vasut <marek.vasut@gmail.com>,
Richard Weinberger <richard@nod.at>
Cc: LKML <linux-kernel@vger.kernel.org>, kernel-janitors@vger.kernel.org
Subject: [PATCH 4/5] mtd/rfd_ftl: Return directly after a failed kmalloc() in erase_block()
Date: Sat, 6 Jan 2018 16:10:40 +0100 [thread overview]
Message-ID: <7b381eef-c54f-d2c9-7281-a90d519c22f1@users.sourceforge.net> (raw)
In-Reply-To: <a595376a-c343-33ea-8607-370b88e19c61@users.sourceforge.net>
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Sat, 6 Jan 2018 15:18:28 +0100
* Return directly after a call of the function "kmalloc" failed
at the beginning.
* Delete an initialisation for the variable "rc" and the jump label "err"
which became unnecessary with this refactoring.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/mtd/rfd_ftl.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/mtd/rfd_ftl.c b/drivers/mtd/rfd_ftl.c
index dcf1b88e1193..e3155ec4be64 100644
--- a/drivers/mtd/rfd_ftl.c
+++ b/drivers/mtd/rfd_ftl.c
@@ -323,11 +323,11 @@ static void erase_callback(struct erase_info *erase)
static int erase_block(struct partition *part, int block)
{
- int rc = -ENOMEM;
+ int rc;
struct erase_info *erase = kmalloc(sizeof(*erase), GFP_KERNEL);
if (!erase)
- goto err;
+ return -ENOMEM;
erase->mtd = part->mbd.mtd;
erase->callback = erase_callback;
@@ -346,8 +346,6 @@ static int erase_block(struct partition *part, int block)
(unsigned long long)erase->len, part->mbd.mtd->name);
kfree(erase);
}
-
-err:
return rc;
}
--
2.15.1
next prev parent reply other threads:[~2018-01-06 15:11 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-06 15:06 [PATCH 0/5] mtd/rfd_ftl: Adjustments for some function implementations SF Markus Elfring
2018-01-06 15:07 ` [PATCH 1/5] mtd/rfd_ftl: Delete an error message for a failed memory allocation in scan_header() SF Markus Elfring
2018-01-06 15:08 ` [PATCH 2/5] mtd/rfd_ftl: Less function calls in scan_header() after error detection SF Markus Elfring
2018-01-06 15:09 ` [PATCH 3/5] mtd/rfd_ftl: Improve a size determination in two functions SF Markus Elfring
2018-01-06 15:10 ` SF Markus Elfring [this message]
2018-01-06 15:11 ` [PATCH 5/5] mtd/rfd_ftl: Add some spaces for better code readability SF Markus Elfring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7b381eef-c54f-d2c9-7281-a90d519c22f1@users.sourceforge.net \
--to=elfring@users.sourceforge.net \
--cc=boris.brezillon@free-electrons.com \
--cc=computersforpeace@gmail.com \
--cc=cyrille.pitchen@wedev4u.fr \
--cc=dwmw2@infradead.org \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=marek.vasut@gmail.com \
--cc=richard@nod.at \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome