Does this look better ? I also use the USB id's for the if. On Wed, 3 Nov 2010 09:20:25 -0400 (EDT), Jiri Kosina wrote: > On Tue, 26 Oct 2010, gimli wrote: > >> This patch adds support for the new MacBookAir3,1 and 3,2 to the hid >> driver. >> >> Updated names names acording Apples kext. >> >> Signed-off-by: Edgar (gimli) Hucek > >> - trans = apple_find_translation((hid->product < 0x21d || >> + if(hid->product >= 0x023f && hid->product <= 0x0244 ) { >> + trans = >> apple_find_translation(macbookair_fn_keys, usage->code); >> + } else { >> + trans = apple_find_translation((hid->product < >> 0x21d || >> hid->product >= 0x300) ? >> powerbook_fn_keys : apple_fn_keys, >> usage->code); > > Could you please make this nicer? Having if and ternary operator both > there to chose the translation table looks really confusing. > > Thanks,