From: Suzuki K Poulose <suzuki.poulose@arm.com>
To: leo.yan@linaro.org, mathieu.poirier@linaro.org,
robh+dt@kernel.org, mark.rutland@arm.com,
alexander.shishkin@linux.intel.com, shiwanglai@hisilicon.com,
linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 3/4] dt-bindings: arm: coresight: Unify funnel DT binding
Date: Mon, 8 Apr 2019 11:51:16 +0100 [thread overview]
Message-ID: <7f63abef-76fc-a767-723d-caacc8da29ae@arm.com> (raw)
In-Reply-To: <20190406112145.15184-4-leo.yan@linaro.org>
On 04/06/2019 12:21 PM, Leo Yan wrote:
> Following the same fashion with replicator DT binding, this patch is to
> unify the DT binding for funnel to support static and dynamic modes;
> finally we get the funnel DT binding as below:
>
> Before patch:
>
> Static funnel, aka. non-configurable funnel:
> Not supported;
>
> Dynamic funnel, aka. configurable funnel:
> "arm,coresight-funnel", "arm,primecell";
>
> After patch:
>
> Static funnel:
> "arm,coresight-static-funnel";
>
> Dynamic funnel:
> "arm,coresight-funnel", "arm,primecell"; (obsolete)
> "arm,coresight-dynamic-funnel", "arm,primecell";
>
> At the end of this patch, it gives an example for static funnel DT
> binding, and updates the dynamic funnel example.
>
> Cc: Mathieu Poirier <mathieu.poirier@linaro.org>
> Cc: Suzuki K Poulose <suzuki.poulose@arm.com>
> Cc: Wanglai Shi <shiwanglai@hisilicon.com>
> Signed-off-by: Leo Yan <leo.yan@linaro.org>
> ---
> .../devicetree/bindings/arm/coresight.txt | 52 +++++++++++++++++--
> 1 file changed, 48 insertions(+), 4 deletions(-)
>
> diff --git a/Documentation/devicetree/bindings/arm/coresight.txt b/Documentation/devicetree/bindings/arm/coresight.txt
> index f8f794869af2..f8ad11a17cd5 100644
> --- a/Documentation/devicetree/bindings/arm/coresight.txt
> +++ b/Documentation/devicetree/bindings/arm/coresight.txt
> @@ -8,7 +8,8 @@ through the intermediate links connecting the source to the currently selected
> sink. Each CoreSight component device should use these properties to describe
> its hardware characteristcs.
>
> -* Required properties for all components *except* non-configurable replicators:
> +* Required properties for all components *except* non-configurable replicators
> + and non-configurable funnels:
>
> * compatible: These have to be supplemented with "arm,primecell" as
> drivers are using the AMBA bus interface. Possible values include:
> @@ -24,8 +25,11 @@ its hardware characteristcs.
> discovered at boot time when the device is probed.
> "arm,coresight-tmc", "arm,primecell";
>
> - - Trace Funnel:
> + - Trace Programmable Funnel, the compatible string
> + "arm,coresight-funnel" is obsolete, keep it to support
> + the old DT bindings:
> "arm,coresight-funnel", "arm,primecell";
> + "arm,coresight-dynamic-funnel", "arm,primecell";
Same comments as the first patch here.
> + funnel {
> + /*
> + * non-configurable funnel don't show up on the AMBA
> + * bus. As such no need to add "arm,primecell".
> + */
> + compatible = "arm,coresight-static-funnel";
> + clocks = <&crg_ctrl HI3660_PCLK>;
> + clock-names = "apb_pclk";
> +
> + out-ports {
> + port {
> + combo_funnel_out: endpoint {
> + remote-endpoint = <&top_funnel_in>;
> + };
> + };
> + };
> +
> + in-ports {
> + #address-cells = <1>;
> + #size-cells = <0>;
> +
> + port@0 {
> + reg = <0>;
> + combo_funnel_in0: endpoint {
> + remote-endpoint = <&cluster0_etf_out>;
> + };
> + };
> +
> + port@1 {
> + reg = <1>;
> + combo_funnel_in1: endpoint {
> + remote-endpoint = <&cluster1_etf_out>;
> + };
> + };
> + };
> + };
> +
> funnel@20040000 {
Should we rename this to say dynamic_funnel@2004000 { ?
> - compatible = "arm,coresight-funnel", "arm,primecell";
> + compatible = "arm,coresight-dynamic-funnel", "arm,primecell";
> reg = <0 0x20040000 0 0x1000>;
Rest looks fine to me.
Suzuki
next prev parent reply other threads:[~2019-04-08 10:49 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-04-06 11:21 [PATCH v4 0/4] CoreSight: Support static funnel with DT binding consolidation Leo Yan
2019-04-06 11:21 ` [PATCH v4 1/4] dt-bindings: arm: coresight: Add new compatible for static replicator Leo Yan
2019-04-08 10:44 ` Suzuki K Poulose
2019-04-08 14:01 ` Leo Yan
2019-04-06 11:21 ` [PATCH v4 2/4] coresight: replicator: Add new device id " Leo Yan
2019-04-08 10:46 ` Suzuki K Poulose
2019-04-06 11:21 ` [PATCH v4 3/4] dt-bindings: arm: coresight: Unify funnel DT binding Leo Yan
2019-04-06 11:29 ` Leo Yan
2019-04-08 10:51 ` Suzuki K Poulose [this message]
2019-04-08 14:07 ` Leo Yan
2019-04-06 11:21 ` [PATCH v4 4/4] coresight: funnel: Support static funnel Leo Yan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7f63abef-76fc-a767-723d-caacc8da29ae@arm.com \
--to=suzuki.poulose@arm.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=devicetree@vger.kernel.org \
--cc=leo.yan@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mathieu.poirier@linaro.org \
--cc=robh+dt@kernel.org \
--cc=shiwanglai@hisilicon.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®