From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933111AbcLIOEe (ORCPT ); Fri, 9 Dec 2016 09:04:34 -0500 Received: from mailapp01.imgtec.com ([195.59.15.196]:14994 "EHLO mailapp01.imgtec.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932214AbcLIOEd (ORCPT ); Fri, 9 Dec 2016 09:04:33 -0500 Subject: Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits To: Steven Rostedt References: <1481286352-31421-1-git-send-email-marcin.nowakowski@imgtec.com> <20161209090052.106819b2@gandalf.local.home> <20161209090316.41beafcc@gandalf.local.home> CC: Ingo Molnar , From: Marcin Nowakowski Message-ID: <80063f6e-575f-843b-c5c5-22ad7b1e24e8@imgtec.com> Date: Fri, 9 Dec 2016 15:04:30 +0100 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 MIME-Version: 1.0 In-Reply-To: <20161209090316.41beafcc@gandalf.local.home> Content-Type: text/plain; charset="windows-1252"; format=flowed Content-Transfer-Encoding: 7bit X-Originating-IP: [10.80.2.5] Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 09.12.2016 15:03, Steven Rostedt wrote: > On Fri, 9 Dec 2016 09:00:52 -0500 > Steven Rostedt wrote: > >> On Fri, 9 Dec 2016 13:25:51 +0100 >> Marcin Nowakowski wrote: >> >>> The number of probe hits is stored in a percpu variable and therefore >>> can't be read directly. Add a helper method trace_kprobe_nhit() that >>> performs the required calculation. >> >> Can you please add the "why?" to this change log. Who needs this >> functionality, and why? >> > > I should have specified, even if the next patch uses the functionality, > each patch's change log should stand on its own. In the future, when > people do git blame, they wont be seeing patch series. They will only > see the change log of the one change. Sure, I will send an updated version with a better changelog. Marcin