mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	Andi Shyti <andi@smida.it>,
	Wolfram Sang <wsa+renesas@sang-engineering.com>,
	Qianfeng Rong <rongqianfeng@vivo.com>,
	linux-i2c@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-mediatek@lists.infradead.org,
	linux-rockchip@lists.infradead.org
Cc: Khalil Blaiech <kblaiech@nvidia.com>,
	Asmaa Mnebhi <asmaa@nvidia.com>,
	Andi Shyti <andi.shyti@kernel.org>,
	Qii Wang <qii.wang@mediatek.com>,
	Matthias Brugger <matthias.bgg@gmail.com>,
	Linus Walleij <linusw@kernel.org>,
	Heiko Stuebner <heiko@sntech.de>,
	Patrice Chotard <patrice.chotard@foss.st.com>,
	Ard Biesheuvel <ardb@kernel.org>
Subject: Re: [PATCH v1 0/7] i2c: busses: Introduce and use HZ_PER_GHZ
Date: Mon, 12 Jan 2026 17:15:33 +0100	[thread overview]
Message-ID: <803c76e7-30fc-4a0d-ab30-ea779747300b@collabora.com> (raw)
In-Reply-To: <20260112134900.4142954-1-andriy.shevchenko@linux.intel.com>

Il 12/01/26 14:46, Andy Shevchenko ha scritto:
> A few drivers for I²C host controllers use HZ_PER_GHZ in numeric form.
> This is less readable and prone to subtle mistakes. Instead, introduce
> a well defined constant and use it in the drivers. No functional change
> implied except one case where 64-bit division replaced with 32-bit one.
> 
> Andy Shevchenko (7):
>    units: Add HZ_PER_GHZ
>    i2c: mlxbf: Use HZ_PER_GHZ constant instead of custom one
>    i2c: mt65xx: Use HZ_PER_GHZ constant instead of plain number
>    i2c: nomadik: Use HZ_PER_GHZ constant instead of plain number
>    i2c: rk3x: Use HZ_PER_GHZ constant instead of plain number
>    i2c: st: Use HZ_PER_GHZ constant instead of plain number
>    i2c: synquacer: Use HZ_PER_GHZ constant instead of plain number
> 
>   drivers/i2c/busses/i2c-mlxbf.c     |  5 ++---
>   drivers/i2c/busses/i2c-mt65xx.c    | 11 ++++++-----
>   drivers/i2c/busses/i2c-nomadik.c   |  7 ++++---
>   drivers/i2c/busses/i2c-rk3x.c      | 12 ++++++------
>   drivers/i2c/busses/i2c-st.c        |  3 ++-
>   drivers/i2c/busses/i2c-synquacer.c |  3 ++-
>   include/linux/units.h              |  3 +++
>   7 files changed, 25 insertions(+), 19 deletions(-)
> 

Whole series is

Reviewed-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>


  parent reply	other threads:[~2026-01-12 16:15 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-01-12 13:46 Andy Shevchenko
2026-01-12 13:46 ` [PATCH v1 1/7] units: Add HZ_PER_GHZ Andy Shevchenko
2026-01-12 15:48   ` Linus Walleij
2026-01-13 14:23   ` Andi Shyti
2026-01-12 13:46 ` [PATCH v1 2/7] i2c: mlxbf: Use HZ_PER_GHZ constant instead of custom one Andy Shevchenko
2026-01-12 13:46 ` [PATCH v1 3/7] i2c: mt65xx: Use HZ_PER_GHZ constant instead of plain number Andy Shevchenko
2026-01-12 13:46 ` [PATCH v1 4/7] i2c: nomadik: " Andy Shevchenko
2026-01-12 15:52   ` Linus Walleij
2026-01-12 13:46 ` [PATCH v1 5/7] i2c: rk3x: " Andy Shevchenko
2026-01-13 15:10   ` Heiko Stübner
2026-01-12 13:46 ` [PATCH v1 6/7] i2c: st: " Andy Shevchenko
2026-01-13 15:29   ` Patrice CHOTARD
2026-01-12 13:46 ` [PATCH v1 7/7] i2c: synquacer: " Andy Shevchenko
2026-01-12 16:15 ` AngeloGioacchino Del Regno [this message]
2026-01-13 15:28 ` [PATCH v1 0/7] i2c: busses: Introduce and use HZ_PER_GHZ Wolfram Sang
2026-01-14  7:36 ` Andi Shyti
2026-01-14  8:23   ` Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=803c76e7-30fc-4a0d-ab30-ea779747300b@collabora.com \
    --to=angelogioacchino.delregno@collabora.com \
    --cc=andi.shyti@kernel.org \
    --cc=andi@smida.it \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=ardb@kernel.org \
    --cc=asmaa@nvidia.com \
    --cc=heiko@sntech.de \
    --cc=kblaiech@nvidia.com \
    --cc=linusw@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-i2c@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=patrice.chotard@foss.st.com \
    --cc=qii.wang@mediatek.com \
    --cc=rongqianfeng@vivo.com \
    --cc=wsa+renesas@sang-engineering.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®