From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933604AbcJZPsT convert rfc822-to-8bit (ORCPT ); Wed, 26 Oct 2016 11:48:19 -0400 Received: from mga06.intel.com ([134.134.136.31]:50428 "EHLO mga06.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932174AbcJZPsS (ORCPT ); Wed, 26 Oct 2016 11:48:18 -0400 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.31,551,1473145200"; d="scan'208";a="1050535535" From: "Luck, Tony" To: Thomas Gleixner CC: "Yu, Fenghua" , "Anvin, H Peter" , Ingo Molnar , Peter Zijlstra , Stephane Eranian , "Borislav Petkov" , "Hansen, Dave" , Nilay Vaish , Shaohua Li , David Carrillo-Cisneros , "Shankar, Ravi V" , "Prakhya, Sai Praneeth" , Vikas Shivappa , linux-kernel , x86 Subject: Re: [PATCH v5 12/18] x86/intel_rdt: Add "info" files to resctrl file system Thread-Topic: [PATCH v5 12/18] x86/intel_rdt: Add "info" files to resctrl file system Thread-Index: AQHSLGcRbe4WwBOftk+oF152qQnhtaC7S9QA//+cGS0= Date: Wed, 26 Oct 2016 15:48:16 +0000 Message-ID: <80F15F82-8996-4979-8F10-57798C4F87EB@intel.com> References: <1477142405-32078-1-git-send-email-fenghua.yu@intel.com> <1477142405-32078-13-git-send-email-fenghua.yu@intel.com>, In-Reply-To: Accept-Language: en-US Content-Language: en-US X-MS-Has-Attach: X-MS-TNEF-Correlator: Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 8BIT MIME-Version: 1.0 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > >> + .mode = 0444, >> + .kf_ops = &rdtgroup_kf_single_ops, >> + .seq_show = rdt_num_closid_show, >> + }, >> + { >> + .name = "cbm_val", > > cbm_val? Is that a value? No, it's the valid bitmask which you can set. So > cmb_mask or something else which is unambiguous is what you want here. > > This is a user space interface and we really must make it as intuitive as > possible. It's a bit mask for cache resources. But this interface will also control resources that are not caches, so I'd like to avoid "cbm" in the name. Perhaps "max_val"? -Tony