From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753002AbbJOV6N (ORCPT ); Thu, 15 Oct 2015 17:58:13 -0400 Received: from mx1.redhat.com ([209.132.183.28]:51891 "EHLO mx1.redhat.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751401AbbJOV6L (ORCPT ); Thu, 15 Oct 2015 17:58:11 -0400 Organization: Red Hat UK Ltd. Registered Address: Red Hat UK Ltd, Amberley Place, 107-111 Peascod Street, Windsor, Berkshire, SI4 1TE, United Kingdom. Registered in England and Wales under Company Registration No. 3798903 From: David Howells In-Reply-To: <1444945400-31465-1-git-send-email-wuninsu@gmail.com> References: <1444945400-31465-1-git-send-email-wuninsu@gmail.com> To: Insu Yun Cc: dhowells@redhat.com, james.l.morris@oracle.com, serge@hallyn.com, keyrings@vger.kernel.org, linux-security-module@vger.kernel.org, linux-kernel@vger.kernel.org, taesoo@gatech.edu, yeongjin.jang@gatech.edu, insu@gatech.edu Subject: Re: [PATCH] keys: change member variable name MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-ID: <8108.1444946284.1@warthog.procyon.org.uk> Date: Thu, 15 Oct 2015 22:58:04 +0100 Message-ID: <8109.1444946284@warthog.procyon.org.uk> Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Insu Yun wrote: > key->description and key->index_key.description are same because > they are unioned. But, for readability, using same name for > duplication and validation seems better. > > Signed-off-by: Insu Yun I've applied this, but I've changed the subject line to: keys: Be more consistent in selection of union members used if you're okay with that. David