From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754113AbdFWBNT (ORCPT ); Thu, 22 Jun 2017 21:13:19 -0400 Received: from cloudserver094114.home.net.pl ([79.96.170.134]:43036 "EHLO cloudserver094114.home.net.pl" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753833AbdFWBNS (ORCPT ); Thu, 22 Jun 2017 21:13:18 -0400 From: "Rafael J. Wysocki" To: Mika Westerberg Cc: Linux PM , LKML , Linux PCI , Linux ACPI , Bjorn Helgaas , Greg Kroah-Hartman Subject: Re: [PATCH 2/6] ACPI / PM: Consolidate device wakeup settings code Date: Fri, 23 Jun 2017 03:05:57 +0200 Message-ID: <8111646.zzkDnlQnPE@aspire.rjw.lan> User-Agent: KMail/4.14.10 (Linux/4.12.0-rc1+; KDE/4.14.9; x86_64; ; ) In-Reply-To: <4634255.ux8TmyfYTx@aspire.rjw.lan> References: <12296383.UdE5HVtyng@aspire.rjw.lan> <20170622073937.GR629@lahna.fi.intel.com> <4634255.ux8TmyfYTx@aspire.rjw.lan> MIME-Version: 1.0 Content-Transfer-Encoding: 7Bit Content-Type: text/plain; charset="us-ascii" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thursday, June 22, 2017 04:38:49 PM Rafael J. Wysocki wrote: > On Thursday, June 22, 2017 10:39:37 AM Mika Westerberg wrote: > > On Mon, Jun 19, 2017 at 11:33:52PM +0200, Rafael J. Wysocki wrote: > > > -#ifdef CONFIG_PM_SLEEP > > > -/** > > > - * acpi_pm_device_sleep_wake - Enable or disable device to wake up the system. > > > - * @dev: Device to enable/desible to wake up the system from sleep states. > > > - * @enable: Whether to enable or disable @dev to wake up the system. > > > - */ > > > -int acpi_pm_device_sleep_wake(struct device *dev, bool enable) > > > +int acpi_pm_device_wakeup(struct device *dev, bool enable) > > > > Can we call it acpi_pm_device_enable_wakeup() and then provide > > corresponding acpi_pm_device_disable_wakeup()? I find those easier to > > understand than acpi_pm_device_wakeup() that sounds like the device > > should be woken up now. > > OK, fair enough. I'll change it this way. Well, sorry, I'd rather not to, or we'll have to add a wrapper around them in pci-acpi.c. :-) I can rename it to acpi_pm_device_set_wakeup(), though. Thanks, Rafael