mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Sander Eikelenboom <linux@eikelenboom.it>
To: konrad@kernel.org
Cc: xen-devel@lists.xenproject.org, david.vrabel@citrix.com,
	<boris.ostrovsky@oracle.com>, <linux-kernel@vger.kernel.org>
Subject: Re: [Xen-devel] [PATCH] Xen PCIbackend support for slot and bus reset (v3).
Date: Tue, 8 Jul 2014 21:15:40 +0200	[thread overview]
Message-ID: <819511949.20140708211540@eikelenboom.it> (raw)
In-Reply-To: <1404845909-13563-1-git-send-email-konrad@kernel.org>


Tuesday, July 8, 2014, 8:58:22 PM, you wrote:

> These patches had been posted in the past and had been reworked
> to address reviews. The original concerns with the patches was
> the complex logic of doing an workqueue (or thread) that would
> do the FLR/bus/slot reset outside the PCI lock. That idea proved
> buggy. The other idea of usurping the 'reset' SysFS didn't work
> either - as the the generic code will complain loudly about this.

> The best so far mechanism is to use the 'xl' toolstack usage
> of 'do_flr' and make that work in Xen pciback.

>  Documentation/ABI/testing/sysfs-driver-pciback |   95 ++++++++++++++
>  drivers/xen/xen-pciback/pci_stub.c             |  163 +++++++++++++++++++-----
>  drivers/xen/xen-pciback/xenbus.c               |    2 +-
>  3 files changed, 224 insertions(+), 36 deletions(-)

> Konrad Rzeszutek Wilk (7):
>       xen-pciback: Document the various parameters and attributes in SysFS
>       xen/pciback: Don't deadlock when unbinding.
>       xen/pciback: Move the FLR code to a function.
>       xen/pciback: Implement PCI reset slot or bus with 'do_flr' SysFS attribute
>       xen/pciback: Include the domain id if removing the device whilst still in use
>       xen/pciback: Print out the domain owning the device.
>       xen/pciback: Remove tons of dereferences

Could you push these to your kernel.org git tree ?

--
Sander




      parent reply	other threads:[~2014-07-08 19:15 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-07-08 18:58 konrad
2014-07-08 18:58 ` [PATCH v3 1/7] xen-pciback: Document the various parameters and attributes in SysFS konrad
2014-07-08 18:18   ` [Xen-devel] " Andrew Cooper
2014-07-09 12:17   ` David Vrabel
2014-07-09 13:59     ` Konrad Rzeszutek Wilk
2014-07-09 14:05       ` Andrew Cooper
2014-07-09 14:13         ` Konrad Rzeszutek Wilk
2014-07-09 14:22           ` Andrew Cooper
2014-07-09 14:25             ` Konrad Rzeszutek Wilk
2014-07-09 14:45               ` David Vrabel
2014-07-09 14:47                 ` Konrad Rzeszutek Wilk
2014-07-09 14:57                   ` David Vrabel
2014-07-09 15:11                     ` Konrad Rzeszutek Wilk
2014-07-08 18:58 ` [PATCH v3 2/7] xen/pciback: Don't deadlock when unbinding konrad
2014-07-09 12:21   ` David Vrabel
2014-07-09 14:01     ` Konrad Rzeszutek Wilk
2014-07-08 18:58 ` [PATCH v3 3/7] xen/pciback: Move the FLR code to a function konrad
2014-07-08 18:58 ` [PATCH v3 4/7] xen/pciback: Implement PCI reset slot or bus with 'do_flr' SysFS attribute konrad
2014-07-08 18:02   ` David Vrabel
2014-07-08 18:46     ` Konrad Rzeszutek Wilk
2014-07-08 19:28       ` Konrad Rzeszutek Wilk
2014-07-09 12:32       ` David Vrabel
2014-07-09 14:11         ` [Xen-devel] " David Vrabel
2014-07-09 14:12         ` Konrad Rzeszutek Wilk
2014-07-09 14:26           ` David Vrabel
2014-07-09 15:07             ` Konrad Rzeszutek Wilk
2014-07-08 18:17   ` [Xen-devel] " Andrew Cooper
2014-07-08 18:58 ` [PATCH v3 5/7] xen/pciback: Include the domain id if removing the device whilst still in use konrad
2014-07-09 12:34   ` David Vrabel
2014-07-08 18:58 ` [PATCH v3 6/7] xen/pciback: Print out the domain owning the device konrad
2014-07-09 13:04   ` David Vrabel
2014-07-08 18:58 ` [PATCH v3 7/7] xen/pciback: Remove tons of dereferences konrad
2014-07-08 19:15 ` Sander Eikelenboom [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=819511949.20140708211540@eikelenboom.it \
    --to=linux@eikelenboom.it \
    --cc=boris.ostrovsky@oracle.com \
    --cc=david.vrabel@citrix.com \
    --cc=konrad@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®