mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dan Carpenter <dan.carpenter@linaro.org>
To: Soumya Negi <soumya.negi97@gmail.com>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Micky Ching <micky_ching@realsil.com.cn>,
	outreachy@lists.linux.dev, linux-staging@lists.linux.dev,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] staging: rts5208: Parenthesize macro arguments
Date: Thu, 12 Oct 2023 09:33:07 +0300	[thread overview]
Message-ID: <81d6e283-fd87-4fd6-964f-22cbf420cdaa@kadam.mountain> (raw)
In-Reply-To: <20231012050240.20378-1-soumya.negi97@gmail.com>

On Wed, Oct 11, 2023 at 10:02:40PM -0700, Soumya Negi wrote:
> Use parenthesis with macro arguments to avoid possible precedence
> issues. Found by checkpatch.pl
> 
> Signed-off-by: Soumya Negi <soumya.negi97@gmail.com>
> ---
>  drivers/staging/rts5208/rtsx.h | 16 ++++++++--------
>  1 file changed, 8 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/staging/rts5208/rtsx.h b/drivers/staging/rts5208/rtsx.h
> index 2e101da83220..1cc05956ab6d 100644
> --- a/drivers/staging/rts5208/rtsx.h
> +++ b/drivers/staging/rts5208/rtsx.h
> @@ -40,17 +40,17 @@
>   * macros for easy use
>   */
>  #define rtsx_writel(chip, reg, value) \
> -	iowrite32(value, (chip)->rtsx->remap_addr + reg)
> +	iowrite32(value, (chip)->rtsx->remap_addr + (reg))

These would be better as functions instead of defines.

>  #define rtsx_readl(chip, reg) \
> -	ioread32((chip)->rtsx->remap_addr + reg)
> +	ioread32((chip)->rtsx->remap_addr + (reg))
>  #define rtsx_writew(chip, reg, value) \
> -	iowrite16(value, (chip)->rtsx->remap_addr + reg)
> +	iowrite16(value, (chip)->rtsx->remap_addr + (reg))
>  #define rtsx_readw(chip, reg) \
> -	ioread16((chip)->rtsx->remap_addr + reg)
> +	ioread16((chip)->rtsx->remap_addr + (reg))
>  #define rtsx_writeb(chip, reg, value) \
> -	iowrite8(value, (chip)->rtsx->remap_addr + reg)
> +	iowrite8(value, (chip)->rtsx->remap_addr + (reg))
>  #define rtsx_readb(chip, reg) \
> -	ioread8((chip)->rtsx->remap_addr + reg)
> +	ioread8((chip)->rtsx->remap_addr + (reg))
>  
>  #define rtsx_read_config_byte(chip, where, val) \
>  	pci_read_config_byte((chip)->rtsx->pci, where, val)
> @@ -131,8 +131,8 @@ static inline struct rtsx_dev *host_to_rtsx(struct Scsi_Host *host)
>   * The scsi_lock() and scsi_unlock() macros protect the sm_state and the
>   * single queue element srb for write access
>   */
> -#define scsi_unlock(host)	spin_unlock_irq(host->host_lock)
> -#define scsi_lock(host)		spin_lock_irq(host->host_lock)
> +#define scsi_unlock(host)	spin_unlock_irq((host)->host_lock)
> +#define scsi_lock(host)		spin_lock_irq((host)->host_lock)

For these ones, the name is too generic.  probably the right thing is
to just get rid of them completely and call spin_lock/unlock_irq()
directly.

regards,
dan carpenter


  reply	other threads:[~2023-10-12  6:33 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-10-12  5:02 Soumya Negi
2023-10-12  6:33 ` Dan Carpenter [this message]
2023-10-12  7:48   ` Soumya Negi
2023-10-12  7:51     ` Julia Lawall
2023-10-12 12:49       ` Soumya Negi
2023-10-12 13:03         ` Soumya Negi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=81d6e283-fd87-4fd6-964f-22cbf420cdaa@kadam.mountain \
    --to=dan.carpenter@linaro.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=micky_ching@realsil.com.cn \
    --cc=outreachy@lists.linux.dev \
    --cc=soumya.negi97@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®