From mboxrd@z Thu Jan 1 00:00:00 1970 Received: from smtp.kernel.org (aws-us-west-2-korg-mail-alma10-1.taild15c8.ts.net [100.103.45.18]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by smtp.subspace.kernel.org (Postfix) with ESMTPS id 3338435836A for ; Fri, 10 Jul 2026 03:04:29 +0000 (UTC) Authentication-Results: smtp.subspace.kernel.org; arc=none smtp.client-ip=100.103.45.18 ARC-Seal:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783652670; cv=none; b=truX7450qqfUWEl1bFq3ykFS4v4pYp28KF/BK2tFjsK6WlB1yRO0HxUVlCX/TWJbdAD79re+1BvIL8L3ZV5BFDWXv4tQi2oTx6tuWbNCEjJRt8jjM5HnlH9N3LrPGwdYA6X7p1uorBQL89hK3M4hJfpHuZRbmDhjdk4yD+E9uZI= ARC-Message-Signature:i=1; a=rsa-sha256; d=subspace.kernel.org; s=arc-20240116; t=1783652670; c=relaxed/simple; bh=sQt/jxnejdL9kIb1B256cz5TQwklDzvcBhhyZodWicQ=; h=Message-ID:Date:MIME-Version:Cc:Subject:To:References:From: In-Reply-To:Content-Type; b=OcFffNvl7kXDKgfKDx3Jrw82AnzuophXp0kyt19THcDkZl7zSyeaYgNaKwL8vNnrVxQiFU20H5ZCJHJ0pptVBWLSEzbN3rLSlU3K3cr8GJx2W6YzihQ9qE2u0GDoDMcri+IB23t6NdYBvKOQj5WbZO9BsbW+mSZCxJ5cQBtuPkU= ARC-Authentication-Results:i=1; smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b=eWNrKMdV; arc=none smtp.client-ip=100.103.45.18 Authentication-Results: smtp.subspace.kernel.org; dkim=pass (2048-bit key) header.d=kernel.org header.i=@kernel.org header.b="eWNrKMdV" Received: by smtp.kernel.org (Postfix) with ESMTPSA id 33C481F000E9; Fri, 10 Jul 2026 03:04:25 +0000 (UTC) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=kernel.org; s=k20260515; t=1783652668; bh=S6Uitytt2+vFrXVrmF3l1mzokRJyz/mIzlRDo6TPLDE=; h=Date:Cc:Subject:To:References:From:In-Reply-To; b=eWNrKMdVBLAfOfyglz+lvSWZFkqR8yTucnRjXUZRamnaIIElqi7dD9Ff3vjPWNy9g QdOdc5SDi54kTfk/kvc/x6JZBVoL3Vd5ySJHfvflAFm9nVP4D08/ySPNfioi1fv+ku qBxcxURlKh9eiPyHbgpLaiSMRpNzWaq5PWo9kCzImXISFeg3O9q0DjRwIjXR/NL8tK NeK7be7n5o8YOm0y8GjG/K53fmQJgWv+lOTFTi4aIqzCZuFgX+diBg2QcMZfbdOUCF Aw+j+q7fgdTYLUL6Hp9am2NqrgeI3BZdwhGjyxbBLrVjGBTutWMdE9uxqaYOiOUAAY Kt7paX0M59pmA== Message-ID: <835e14b7-17d7-4f9c-b84b-593a0f2d5982@kernel.org> Date: Fri, 10 Jul 2026 11:04:23 +0800 Precedence: bulk X-Mailing-List: linux-kernel@vger.kernel.org List-Id: List-Subscribe: List-Unsubscribe: MIME-Version: 1.0 User-Agent: Mozilla Thunderbird Cc: chao@kernel.org, linux-f2fs-devel@lists.sourceforge.net, Barry Song , Juan Yescas , Dev Jain , linux-kernel@vger.kernel.org, David Hildenbrand , Bo Zhang , Kalesh Singh , Ryan Roberts , Jaegeuk Kim , Pengfei Li Subject: Re: [f2fs-dev] [RFC PATCH v2 02/10] f2fs: carry subpage offset and count in write IO To: Nanzhe Zhao References: <20260710011534.2307696-1-zhaonanzhe@xiaomi.com> Content-Language: en-US From: Chao Yu In-Reply-To: <20260710011534.2307696-1-zhaonanzhe@xiaomi.com> Content-Type: text/plain; charset=UTF-8; format=flowed Content-Transfer-Encoding: 7bit On 7/10/26 09:15, Nanzhe Zhao wrote: >> How about cleaning up w/ below macros? >> >> #define F2FS_FOLIO_INDEX(folio, fio) (folio->index + fio->folio_offset) >> #define F2FS_FOLIO_BLKCNT(fio) (fio->folio_blkcnt ? fio->folio_blkcnt : 1) > > F2FS_FOLIO_XXX naming seems a bit weird to me :). It does not show that > we want to use the folio subpage index associated with fio, or the blkcnt > recorded in fio. I think names like F2FS_FIO_LBLK and F2FS_FIO_BLKCNT > may be better? Looks fine to me. :) Thanks,