mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Pekka Enberg <penberg@cs.helsinki.fi>
To: "André Goddard Rosa" <andre.goddard@gmail.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Catalin Marinas <catalin.marinas@arm.com>,
	Oleg Nesterov <oleg@redhat.com>, Jiri Kosina <jkosina@suse.cz>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH] pid: tighten pidmap_lock critical section
Date: Sun, 22 Nov 2009 11:17:45 +0200	[thread overview]
Message-ID: <84144f020911220117p5c4720e0g58587b97efdbb46b@mail.gmail.com> (raw)
In-Reply-To: <80d3c5c680300de7ebd41aba89723a5cf45396ed.1258783305.git.andre.goddard@gmail.com>

Hi Andre,

On Sat, Nov 21, 2009 at 8:04 AM, André Goddard Rosa
<andre.goddard@gmail.com> wrote:
> Avoid calling kfree() under pidmap_lock and doing unnecessary work.
> It doesn't change behavior.
>
> It decreases code size by 16 bytes on my gcc 4.4.1 on Core 2:
>   text    data     bss     dec     hex filename
>   4314    2216       8    6538    198a kernel/pid.o-BEFORE
>   4298    2216       8    6522    197a kernel/pid.o-AFTER
>
> Signed-off-by: André Goddard Rosa <andre.goddard@gmail.com>

This patch is doing a lot more than the changelog above says it does.
What exactly is the purpose of this patch? What's the upside?

> ---
>  kernel/pid.c |   16 ++++++++--------
>  1 files changed, 8 insertions(+), 8 deletions(-)
>
> diff --git a/kernel/pid.c b/kernel/pid.c
> index d3f722d..ec06912 100644
> --- a/kernel/pid.c
> +++ b/kernel/pid.c
> @@ -141,11 +141,12 @@ static int alloc_pidmap(struct pid_namespace *pid_ns)
>                         * installing it:
>                         */
>                        spin_lock_irq(&pidmap_lock);
> -                       if (map->page)
> -                               kfree(page);
> -                       else
> +                       if (!map->page) {
>                                map->page = page;
> +                               page = NULL;
> +                       }
>                        spin_unlock_irq(&pidmap_lock);
> +                       kfree(page);

OK, maybe. The upside seem rather small and the resulting code is IMHO
slightly less readable.

>                        if (unlikely(!map->page))
>                                break;
>                }
> @@ -225,11 +226,11 @@ static void delayed_put_pid(struct rcu_head *rhp)
>  void free_pid(struct pid *pid)
>  {
>        /* We can be called with write_lock_irq(&tasklist_lock) held */
> -       int i;
> +       int i = 0;
>        unsigned long flags;
>
>        spin_lock_irqsave(&pidmap_lock, flags);
> -       for (i = 0; i <= pid->level; i++)
> +       for ( ; i <= pid->level; i++)
>                hlist_del_rcu(&pid->numbers[i].pid_chain);
>        spin_unlock_irqrestore(&pidmap_lock, flags);

This has nothing to do with kfree(). AFAICT, it just obfuscates the
code as the initial assignment to zero is lost in the noise anyway.

> @@ -268,12 +269,11 @@ struct pid *alloc_pid(struct pid_namespace *ns)
>        for (type = 0; type < PIDTYPE_MAX; ++type)
>                INIT_HLIST_HEAD(&pid->tasks[type]);
>
> +       upid = pid->numbers + ns->level;
>        spin_lock_irq(&pidmap_lock);
> -       for (i = ns->level; i >= 0; i--) {
> -               upid = &pid->numbers[i];
> +       for ( ; upid >= pid->numbers; --upid)
>                hlist_add_head_rcu(&upid->pid_chain,
>                                &pid_hash[pid_hashfn(upid->nr, upid->ns)]);
> -       }
>        spin_unlock_irq(&pidmap_lock);

Again, this has nothing to do with kfree(). I suspect this is where
most of the 16 byte text savings come from. I'm not convinced it's
worth the hit in readability, though.

                        Pekka

  reply	other threads:[~2009-11-22  9:17 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-11-21  6:04 André Goddard Rosa
2009-11-22  9:17 ` Pekka Enberg [this message]
2009-11-22 10:52   ` André Goddard Rosa
2009-11-22 11:03     ` Pekka Enberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=84144f020911220117p5c4720e0g58587b97efdbb46b@mail.gmail.com \
    --to=penberg@cs.helsinki.fi \
    --cc=akpm@linux-foundation.org \
    --cc=andre.goddard@gmail.com \
    --cc=catalin.marinas@arm.com \
    --cc=jkosina@suse.cz \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oleg@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®