mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: huang ying <huang.ying.caritas@gmail.com>
To: Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>
Cc: linux-kernel@vger.kernel.org, Ingo Molnar <mingo@elte.hu>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Andi Kleen <ak@linux.intel.com>,
	Huang Ying <ying.huang@intel.com>
Subject: Re: [PATCH 12/16] x86, mce: squash mce_intel.c into therm_throt.c
Date: Thu, 18 Jun 2009 16:00:37 +0800	[thread overview]
Message-ID: <851fc09e0906180100n27c0a80ej1fb12a5cabac21b0@mail.gmail.com> (raw)
In-Reply-To: <4A39ED3B.2060800@jp.fujitsu.com>

On Thu, Jun 18, 2009 at 3:31 PM, Hidetoshi
Seto<seto.hidetoshi@jp.fujitsu.com> wrote:
> huang ying wrote:
>> 2009/6/15 Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>:
>>> move intel_init_thermal() into therm_throt.c
>>>
>>> Signed-off-by: Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>
>>> ---
>>>  arch/x86/kernel/cpu/mcheck/Makefile      |    2 +-
>>>  arch/x86/kernel/cpu/mcheck/mce_intel.c   |   73 ------------------------------
>>>  arch/x86/kernel/cpu/mcheck/therm_throt.c |   66 +++++++++++++++++++++++++++
>>>  3 files changed, 67 insertions(+), 74 deletions(-)
>>>  delete mode 100644 arch/x86/kernel/cpu/mcheck/mce_intel.c
>>
>> Why we need this patch? I think the design principle behind MCE is to
>> separate vendor/cpu specific code into different files. At least
>> #ifdef CONFIG_X86_MCE_INTEL should be used around moved code.
>
> Because at this time there are no vendor other than Intel that uses
> thermal codes here.  I don't know much about AMD, whether there are
> any plan to implement AMD specific thermal codes or not, and why they
> have to make such specific thing here in future (patent?).
>
> You can pull out "codes may not be shared" from therm_throt.c and
> put it again into mce_intel.c (that was mce_intel_64.c).  But I
> believe it is not needed now, until another code is available.
> Or you can rename therm_throt.c to thermal_intel.c or so for a while.

I think thermal_intel.c is better.

Best Regards,
Huang Ying

  reply	other threads:[~2009-06-18  8:06 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-06-15  8:09 [PATCH 00/16] last-minute patches for MCE .31 Hidetoshi Seto
2009-06-15  8:18 ` [PATCH 01/16] x86, mce: don't init timer if !mce_available Hidetoshi Seto
2009-06-15  8:19 ` [PATCH 02/16] x86, mce: call-in should be after updating global_nwo Hidetoshi Seto
2009-06-15  8:26   ` huang ying
2009-06-15  8:40     ` Hidetoshi Seto
2009-06-15  9:18     ` [PATCH] x86, mce: cleanup mce_start() Hidetoshi Seto
2009-06-15  8:20 ` [PATCH 03/16] x86, mce: add __read_mostly Hidetoshi Seto
2009-06-15  8:20 ` [PATCH 04/16] x86, mce: rename static variables around trigger Hidetoshi Seto
2009-06-15  8:21 ` [PATCH 05/16] x86, mce: sysfs entries for new options Hidetoshi Seto
2009-06-15  8:22 ` [PATCH 06/16] x86, mce: unify mce.h Hidetoshi Seto
2009-06-15  8:22 ` [PATCH 07/16] x86, mce: make mce_disabled boolean Hidetoshi Seto
2009-06-15  8:23 ` [PATCH 08/16] x86, mce: unify smp_thermal_interrupt, prepare p4 Hidetoshi Seto
2009-06-15  8:24 ` [PATCH 09/16] x86, mce: unify smp_thermal_interrupt, prepare mce_intel_64 Hidetoshi Seto
2009-06-15  8:24 ` [PATCH 10/16] x86, mce: unify smp_thermal_interrupt, prepare Hidetoshi Seto
2009-06-15  8:25 ` [PATCH 11/16] x86, mce: unify smp_thermal_interrupt Hidetoshi Seto
2009-06-15  8:26 ` [PATCH 12/16] x86, mce: squash mce_intel.c into therm_throt.c Hidetoshi Seto
2009-06-18  5:49   ` huang ying
2009-06-18  7:31     ` Hidetoshi Seto
2009-06-18  8:00       ` huang ying [this message]
2009-06-18 13:59         ` H. Peter Anvin
2009-06-18 13:56     ` H. Peter Anvin
2009-06-15  8:26 ` [PATCH 13/16] x86, mce: remove intel_set_thermal_handler() Hidetoshi Seto
2009-06-15  8:27 ` [PATCH 14/16] x86, mce: remove therm_throt.h Hidetoshi Seto
2009-06-15  8:27 ` [PATCH 15/16] x86, mce: mce.h cleanup Hidetoshi Seto
2009-06-15  8:28 ` [PATCH 16/16] x86, mce: rename Hidetoshi Seto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=851fc09e0906180100n27c0a80ej1fb12a5cabac21b0@mail.gmail.com \
    --to=huang.ying.caritas@gmail.com \
    --cc=ak@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=seto.hidetoshi@jp.fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=ying.huang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®