From: Hans de Goede <hdegoede@redhat.com>
To: Amir Goldstein <amir73il@gmail.com>
Cc: Arnd Bergmann <arnd@arndb.de>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Michael Thayer <michael.thayer@oracle.com>,
Alexander Viro <viro@zeniv.linux.org.uk>,
Larry Finger <Larry.Finger@lwfinger.net>,
Christoph Hellwig <hch@infradead.org>,
linux-kernel <linux-kernel@vger.kernel.org>,
linux-fsdevel <linux-fsdevel@vger.kernel.org>
Subject: Re: [PATCH v2] fs: Add VirtualBox guest shared folder (vboxsf) support
Date: Mon, 15 Jan 2018 20:41:54 +0100 [thread overview]
Message-ID: <86fa6f42-7993-ff56-45a5-85f89f9370ae@redhat.com> (raw)
In-Reply-To: <CAOQ4uxgM+gS4nY5QCKxSJfVmR+z4_rKmajoe3CoXRjBH9k7wbQ@mail.gmail.com>
Hi,
On 15-01-18 20:32, Amir Goldstein wrote:
> On Mon, Jan 15, 2018 at 7:51 PM, Hans de Goede <hdegoede@redhat.com> wrote:
>> VirtualBox hosts can share folders with guests, this commit adds a
>> VFS driver implementing the Linux-guest side of this, allowing folders
>> exported by the host to be mounted under Linux.
>>
>> This driver depends on the guest <-> host IPC functions exported by
>> the vboxguest driver.
>>
>> Signed-off-by: Hans de Goede <hdegoede@redhat.com>
>> ---
>> fs/Kconfig | 1 +
>> fs/Makefile | 1 +
>> fs/vboxsf/Kconfig | 9 +
>> fs/vboxsf/Makefile | 3 +
>> fs/vboxsf/dir.c | 648 +++++++++++++++++++++++++++++
>> fs/vboxsf/file.c | 416 +++++++++++++++++++
>> fs/vboxsf/shfl_hostintf.h | 919 +++++++++++++++++++++++++++++++++++++++++
>> fs/vboxsf/super.c | 430 +++++++++++++++++++
>> fs/vboxsf/utils.c | 589 ++++++++++++++++++++++++++
>> fs/vboxsf/vboxsf_wrappers.c | 365 ++++++++++++++++
>> fs/vboxsf/vboxsf_wrappers.h | 46 +++
>> fs/vboxsf/vfsmod.h | 104 +++++
>> include/uapi/linux/vbsfmount.h | 62 +++
>> 13 files changed, 3593 insertions(+)
>> create mode 100644 fs/vboxsf/Kconfig
>> create mode 100644 fs/vboxsf/Makefile
>> create mode 100644 fs/vboxsf/dir.c
>> create mode 100644 fs/vboxsf/file.c
>> create mode 100644 fs/vboxsf/shfl_hostintf.h
>> create mode 100644 fs/vboxsf/super.c
>> create mode 100644 fs/vboxsf/utils.c
>> create mode 100644 fs/vboxsf/vboxsf_wrappers.c
>> create mode 100644 fs/vboxsf/vboxsf_wrappers.h
>> create mode 100644 fs/vboxsf/vfsmod.h
>> create mode 100644 include/uapi/linux/vbsfmount.h
>
> A MAINTAINERS entry seems in order.
Ack and thank you for the feedback.
>> diff --git a/fs/Kconfig b/fs/Kconfig
>> index 7aee6d699fd6..7f80ad1cf591 100644
>> --- a/fs/Kconfig
>> +++ b/fs/Kconfig
>> @@ -248,6 +248,7 @@ source "fs/pstore/Kconfig"
>> source "fs/sysv/Kconfig"
>> source "fs/ufs/Kconfig"
>> source "fs/exofs/Kconfig"
>> +source "fs/vboxsf/Kconfig"
>>
>> endif # MISC_FILESYSTEMS
>>
>> diff --git a/fs/Makefile b/fs/Makefile
>> index ef772f1eaff8..3057830f112a 100644
>> --- a/fs/Makefile
>> +++ b/fs/Makefile
>> @@ -129,3 +129,4 @@ obj-y += exofs/ # Multiple modules
>> obj-$(CONFIG_CEPH_FS) += ceph/
>> obj-$(CONFIG_PSTORE) += pstore/
>> obj-$(CONFIG_EFIVAR_FS) += efivarfs/
>> +obj-$(CONFIG_VBOXSF_FS) += vboxsf/
>> diff --git a/fs/vboxsf/Kconfig b/fs/vboxsf/Kconfig
>> new file mode 100644
>> index 000000000000..620e2232969c
>> --- /dev/null
>> +++ b/fs/vboxsf/Kconfig
>> @@ -0,0 +1,9 @@
>> +config VBOXSF_FS
>> + tristate "VirtualBox guest shared folder (vboxsf) support"
>
>
> Don't know if you noticed, but calling your filesystem vboxsf
> is quite odd name among other XXXfs beasts.
Yes I noticed, note I'm only the guy pushing this upstream this code
has a long out-of-tree history. FWIW the sf stand for "shared folder"
> Will it be an option to re-brand this as vboxfs?
> Even if it is too late or too much of a hustle to change the user visible
> file_system_type name, I think changing the internal name is worth it.
We can quite definitely not change the user-visible name, the mount
arg changes Christoph Hellwig has requested are tricky enough wrt
compatibility with the out-of-tree version most users use atm.
The users will need updated userspace tools to deal with the mount arg
changes, but that is as easy as checking for -EINVAL and trying again
with the new style string args. But figuring out the right fstype name
is rather more tricky and the mount binary name has been mount.vboxsf
for ages... So I would really like to keep the file_system_type name
as vboxsf, at which point it seems counter-productive to me to rename
the files / kernel-mode to vboxfs.
> The other thing is if you can help it to avoid the short 'sf_' prefix and
> use a longer prefix even for static functions, something like vbsf_ or
> vbfs_ that would be better.
Agreed, I did not take the buildin use-case where everything gets linked
into a single binary into account, will fix for v3.
Regards,
Hans
next prev parent reply other threads:[~2018-01-15 19:41 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-01-15 17:51 [PATCH v2 0/1] " Hans de Goede
2018-01-15 17:51 ` [PATCH v2] " Hans de Goede
2018-01-15 17:55 ` Christoph Hellwig
2018-01-15 18:01 ` Hans de Goede
2018-01-15 19:32 ` Amir Goldstein
2018-01-15 19:41 ` Hans de Goede [this message]
2018-01-15 20:22 ` Amir Goldstein
2018-01-15 22:36 ` Al Viro
2018-01-16 10:15 ` Hans de Goede
2018-01-17 3:19 ` Al Viro
2018-01-17 10:45 ` Hans de Goede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86fa6f42-7993-ff56-45a5-85f89f9370ae@redhat.com \
--to=hdegoede@redhat.com \
--cc=Larry.Finger@lwfinger.net \
--cc=amir73il@gmail.com \
--cc=arnd@arndb.de \
--cc=gregkh@linuxfoundation.org \
--cc=hch@infradead.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=michael.thayer@oracle.com \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®